ViewVC Help
View File | Revision Log | Show Annotations | Root Listing
root/cvsroot/COMP/CMSDIST/PHEDEX-admin.spec
Revision: 1.29
Committed: Mon Feb 11 09:53:58 2008 UTC (17 years, 2 months ago) by egeland
Branch: MAIN
Changes since 1.28: +11 -6 lines
Log Message:
Updated for 2.6.0

File Contents

# User Rev Content
1 egeland 1.29 ### RPM cms PHEDEX-admin PHEDEX_2_6_0
2 egeland 1.28 ###
3 wildish 1.24 ## INITENV +PATH PERL5LIB %i/perl_lib
4 eulisse 1.3 %define downloadn %(echo %n | cut -f1 -d-)
5     Source: cvs://:pserver:anonymous@cmscvs.cern.ch:2401/cvs_server/repositories/CMSSW?passwd=AA_:yZZ3e&module=%{downloadn}&export=%{downloadn}&&tag=-r%{v}&output=/%{downloadn}.tar.gz
6 egeland 1.29 Requires: oracle oracle-env p5-time-hires p5-text-glob p5-compress-zlib p5-dbi p5-dbd-oracle p5-xml-parser python
7 rehn 1.1 Requires: py2-cx-oracle
8 egeland 1.28 Requires: dls dbs-client p5-monalisa-apmon
9 rehn 1.1
10     # Extra requires so we get everything necessary for env.{,c}sh.
11     Requires: zlib expat openssl bz2lib py2-pyxml py2-zsi py2-mysqldb mysql
12    
13     %prep
14 eulisse 1.3 %setup -n %{downloadn}
15 rehn 1.1
16     %build
17    
18     %install
19     mkdir -p %i/etc
20     tar -cf - * | (cd %i && tar -xf -)
21    
22 egeland 1.29 # Copy dependencies to dependencies-setup.sh
23 rehn 1.1 mkdir -p %i/etc/profile.d
24     for x in %pkgreqs; do
25     case $x in /* ) continue ;; esac
26     p=%{instroot}/%{cmsplatf}/$(echo $x | sed 's/\([^+]*\)+\(.*\)+\([A-Z0-9].*\)/\1 \2 \3/' | tr ' ' '/')
27 egeland 1.29 echo ". $p/etc/profile.d/init.sh" >> %i/etc/profile.d/dependencies-setup.sh
28     echo "source $p/etc/profile.d/init.csh" >> %i/etc/profile.d/dependencies-setup.csh
29 rehn 1.1 done
30    
31 egeland 1.29 # Make "env.sh" = "init.sh" for legacy configs
32     echo ". %i/etc/profile.d/init.sh" > %i/etc/profile.d/env.sh
33     echo "source %i/etc/profile.d/init.csh" > %i/etc/profile.d/env.csh
34    
35 rehn 1.1 %post
36     %{relocateConfig}etc/profile.d/env.sh
37     %{relocateConfig}etc/profile.d/env.csh
38 egeland 1.29 %{relocateConfig}etc/profile.d/dependencies-setup.sh
39     %{relocateConfig}etc/profile.d/dependencies-setup.csh