1 |
wildish |
1.43 |
### RPM cms PHEDEX-admin PHEDEX_3_0_0_pre11
|
2 |
egeland |
1.39 |
#
|
3 |
wildish |
1.24 |
## INITENV +PATH PERL5LIB %i/perl_lib
|
4 |
eulisse |
1.3 |
%define downloadn %(echo %n | cut -f1 -d-)
|
5 |
|
|
Source: cvs://:pserver:anonymous@cmscvs.cern.ch:2401/cvs_server/repositories/CMSSW?passwd=AA_:yZZ3e&module=%{downloadn}&export=%{downloadn}&&tag=-r%{v}&output=/%{downloadn}.tar.gz
|
6 |
wildish |
1.41 |
Requires: oracle oracle-env p5-time-hires p5-text-glob p5-compress-zlib p5-dbi p5-dbd-oracle p5-xml-parser p5-poe python
|
7 |
egeland |
1.31 |
Requires: dls-client dbs-client p5-monalisa-apmon
|
8 |
rehn |
1.1 |
|
9 |
egeland |
1.37 |
# Actually, it is p5-xml-parser that requires this, but it doesn't configure itself correctly
|
10 |
|
|
# This is so it gets into our dependencies-setup.sh
|
11 |
|
|
Requires: expat
|
12 |
|
|
|
13 |
egeland |
1.30 |
# Provided by system perl
|
14 |
|
|
Provides: perl(HTML::Entities)
|
15 |
egeland |
1.38 |
Provides: perl(DB_File)
|
16 |
egeland |
1.30 |
|
17 |
rehn |
1.1 |
%prep
|
18 |
eulisse |
1.3 |
%setup -n %{downloadn}
|
19 |
rehn |
1.1 |
|
20 |
|
|
%build
|
21 |
|
|
|
22 |
|
|
%install
|
23 |
|
|
mkdir -p %i/etc
|
24 |
|
|
tar -cf - * | (cd %i && tar -xf -)
|
25 |
|
|
|
26 |
egeland |
1.29 |
# Copy dependencies to dependencies-setup.sh
|
27 |
rehn |
1.1 |
mkdir -p %i/etc/profile.d
|
28 |
|
|
for x in %pkgreqs; do
|
29 |
|
|
case $x in /* ) continue ;; esac
|
30 |
|
|
p=%{instroot}/%{cmsplatf}/$(echo $x | sed 's/\([^+]*\)+\(.*\)+\([A-Z0-9].*\)/\1 \2 \3/' | tr ' ' '/')
|
31 |
egeland |
1.29 |
echo ". $p/etc/profile.d/init.sh" >> %i/etc/profile.d/dependencies-setup.sh
|
32 |
|
|
echo "source $p/etc/profile.d/init.csh" >> %i/etc/profile.d/dependencies-setup.csh
|
33 |
rehn |
1.1 |
done
|
34 |
|
|
|
35 |
egeland |
1.29 |
# Make "env.sh" = "init.sh" for legacy configs
|
36 |
|
|
echo ". %i/etc/profile.d/init.sh" > %i/etc/profile.d/env.sh
|
37 |
|
|
echo "source %i/etc/profile.d/init.csh" > %i/etc/profile.d/env.csh
|
38 |
|
|
|
39 |
rehn |
1.1 |
%post
|
40 |
|
|
%{relocateConfig}etc/profile.d/env.sh
|
41 |
|
|
%{relocateConfig}etc/profile.d/env.csh
|
42 |
egeland |
1.29 |
%{relocateConfig}etc/profile.d/dependencies-setup.sh
|
43 |
|
|
%{relocateConfig}etc/profile.d/dependencies-setup.csh
|