ViewVC Help
View File | Revision Log | Show Annotations | Root Listing
root/cvsroot/COMP/CMSDIST/PHEDEX-admin.spec
Revision: 1.73
Committed: Wed Sep 16 09:51:21 2009 UTC (15 years, 7 months ago) by wildish
Branch: MAIN
CVS Tags: forPHEDEX323
Changes since 1.72: +1 -1 lines
Log Message:
bump revision

File Contents

# User Rev Content
1 wildish 1.73 ### RPM cms PHEDEX-admin PHEDEX_3_2_3
2 wildish 1.24 ## INITENV +PATH PERL5LIB %i/perl_lib
3 eulisse 1.3 %define downloadn %(echo %n | cut -f1 -d-)
4     Source: cvs://:pserver:anonymous@cmscvs.cern.ch:2401/cvs_server/repositories/CMSSW?passwd=AA_:yZZ3e&module=%{downloadn}&export=%{downloadn}&&tag=-r%{v}&output=/%{downloadn}.tar.gz
5 egeland 1.53 # Oracle libs
6     Requires: oracle oracle-env
7     # perl libs
8     Requires: p5-time-hires p5-text-glob p5-compress-zlib p5-dbi
9     Requires: p5-dbd-oracle p5-xml-parser p5-poe p5-poe-component-child
10     Requires: p5-log-log4perl p5-log-dispatch p5-log-dispatch-filerotate
11     Requires: p5-params-validate p5-monalisa-apmon
12     # CMS libs
13     Requires: dls-client dbs-client
14     # Etc.
15     Requires: python
16 egeland 1.37 # Actually, it is p5-xml-parser that requires this, but it doesn't configure itself correctly
17     # This is so it gets into our dependencies-setup.sh
18 egeland 1.53 Requires: expat
19 egeland 1.37
20 egeland 1.30 # Provided by system perl
21     Provides: perl(HTML::Entities)
22 egeland 1.38 Provides: perl(DB_File)
23 egeland 1.52 Provides: perl(Date::Manip)
24     Provides: perl(XML::LibXML)
25 egeland 1.30
26 rehn 1.1 %prep
27 eulisse 1.3 %setup -n %{downloadn}
28 rehn 1.1
29     %build
30    
31     %install
32     mkdir -p %i/etc
33     tar -cf - * | (cd %i && tar -xf -)
34    
35 egeland 1.55 # Set permissions
36     chmod 755 %i/Toolkit/DBS/*
37     chmod 755 %i/Utilities/*
38    
39 egeland 1.29 # Copy dependencies to dependencies-setup.sh
40 rehn 1.1 mkdir -p %i/etc/profile.d
41     for x in %pkgreqs; do
42     case $x in /* ) continue ;; esac
43     p=%{instroot}/%{cmsplatf}/$(echo $x | sed 's/\([^+]*\)+\(.*\)+\([A-Z0-9].*\)/\1 \2 \3/' | tr ' ' '/')
44 egeland 1.29 echo ". $p/etc/profile.d/init.sh" >> %i/etc/profile.d/dependencies-setup.sh
45     echo "source $p/etc/profile.d/init.csh" >> %i/etc/profile.d/dependencies-setup.csh
46 rehn 1.1 done
47    
48 egeland 1.29 # Make "env.sh" = "init.sh" for legacy configs
49     echo ". %i/etc/profile.d/init.sh" > %i/etc/profile.d/env.sh
50     echo "source %i/etc/profile.d/init.csh" > %i/etc/profile.d/env.csh
51    
52 rehn 1.1 %post
53     %{relocateConfig}etc/profile.d/env.sh
54     %{relocateConfig}etc/profile.d/env.csh
55 egeland 1.29 %{relocateConfig}etc/profile.d/dependencies-setup.sh
56     %{relocateConfig}etc/profile.d/dependencies-setup.csh