1 |
egeland |
1.5 |
### RPM cms PHEDEX-datasvc DATASVC_1_1_0
|
2 |
|
|
#
|
3 |
egeland |
1.1 |
## INITENV +PATH PERL5LIB %i/perl_lib
|
4 |
|
|
%define downloadn %(echo %n | cut -f1 -d-)
|
5 |
egeland |
1.3 |
%define nversion %(echo %v | sed 's|DATASVC_||' | sed 's|_|.|g')
|
6 |
egeland |
1.1 |
|
7 |
|
|
Source: cvs://:pserver:anonymous@cmscvs.cern.ch:2401/cvs_server/repositories/CMSSW?passwd=AA_:yZZ3e&module=%{downloadn}&export=%{downloadn}&&tag=-r%{v}&output=/%{downloadn}.tar.gz
|
8 |
|
|
Requires: oracle oracle-env p5-time-hires p5-text-glob p5-compress-zlib p5-dbi p5-dbd-oracle p5-xml-parser
|
9 |
egeland |
1.3 |
Requires: p5-monalisa-apmon p5-poe p5-cgi p5-json-xs p5-apache-dbi
|
10 |
egeland |
1.1 |
Requires: apache2-conf
|
11 |
|
|
|
12 |
|
|
# Actually, it is p5-xml-parser that requires this, but it doesn't configure itself correctly
|
13 |
|
|
# This is so it gets into our dependencies-setup.sh
|
14 |
|
|
Requires: expat
|
15 |
|
|
|
16 |
|
|
# Provided by system perl
|
17 |
|
|
Provides: perl(HTML::Entities)
|
18 |
|
|
Provides: perl(DB_File)
|
19 |
|
|
|
20 |
|
|
%prep
|
21 |
|
|
%setup -n %{downloadn}
|
22 |
|
|
|
23 |
|
|
%build
|
24 |
|
|
|
25 |
|
|
%install
|
26 |
|
|
mkdir -p %i/etc
|
27 |
|
|
tar -cf - * | (cd %i && tar -xf -)
|
28 |
|
|
|
29 |
|
|
# Switch template variables in the configuration files
|
30 |
|
|
|
31 |
|
|
export DOCUMENT_ROOT=%i/PhEDExWeb/DataService
|
32 |
|
|
export CACHE_DIRECTORY=/tmp/phedex-datasvc
|
33 |
egeland |
1.3 |
export VERSION=%nversion
|
34 |
egeland |
1.1 |
perl -p -i -e "s|\@DOCUMENT_ROOT\@|$DOCUMENT_ROOT|g;
|
35 |
egeland |
1.3 |
s|\@CACHE_DIRECTORY\@|$CACHE_DIRECTORY|g;
|
36 |
|
|
s|\@VERSION\@|$VERSION|g;" %i/PhEDExWeb/DataService/conf/*
|
37 |
egeland |
1.1 |
|
38 |
|
|
# Copy dependencies to dependencies-setup.sh
|
39 |
|
|
mkdir -p %i/etc/profile.d
|
40 |
|
|
for x in %pkgreqs; do
|
41 |
|
|
case $x in /* ) continue ;; esac
|
42 |
|
|
p=%{instroot}/%{cmsplatf}/$(echo $x | sed 's/\([^+]*\)+\(.*\)+\([A-Z0-9].*\)/\1 \2 \3/' | tr ' ' '/')
|
43 |
|
|
echo ". $p/etc/profile.d/init.sh" >> %i/etc/profile.d/dependencies-setup.sh
|
44 |
|
|
echo "source $p/etc/profile.d/init.csh" >> %i/etc/profile.d/dependencies-setup.csh
|
45 |
|
|
done
|
46 |
|
|
|
47 |
|
|
%post
|
48 |
|
|
mkdir -p /tmp/phedex-datasvc
|
49 |
|
|
%{relocateConfig}PhEDExWeb/DataService/conf/datasvc-app.conf
|
50 |
|
|
%{relocateConfig}PhEDExWeb/DataService/conf/datasvc-httpd.conf
|
51 |
|
|
%{relocateConfig}etc/profile.d/dependencies-setup.sh
|
52 |
|
|
%{relocateConfig}etc/profile.d/dependencies-setup.csh
|