1 |
egeland |
1.5 |
### RPM cms PHEDEX-web WEB_3_0_1
|
2 |
egeland |
1.1 |
#
|
3 |
|
|
## INITENV +PATH PERL5LIB %i/perl_lib
|
4 |
|
|
%define downloadn %(echo %n | cut -f1 -d-)
|
5 |
egeland |
1.3 |
%define nversion %(echo %v | sed 's|WEB_||' | sed 's|_|.|g')
|
6 |
|
|
%define cvsserver cvs://:pserver:anonymous@cmscvs.cern.ch:2401/cvs_server/repositories/CMSSW?passwd=AA_:yZZ3e
|
7 |
egeland |
1.1 |
|
8 |
egeland |
1.3 |
Source: %cvsserver&strategy=checkout&module=%{downloadn}&export=%{downloadn}&&tag=-r%{v}&output=/%{downloadn}.tar.gz
|
9 |
egeland |
1.1 |
Requires: oracle oracle-env p5-time-hires p5-text-glob p5-compress-zlib p5-dbi p5-dbd-oracle p5-xml-parser
|
10 |
egeland |
1.2 |
Requires: p5-monalisa-apmon p5-poe p5-cgi p5-cgi-session p5-json-xs p5-apache-dbi p5-sort-key
|
11 |
egeland |
1.4 |
Requires: py2-pil py2-matplotlib py2-numpy libjpg
|
12 |
egeland |
1.2 |
Requires: apache2-conf webtools dbs-client
|
13 |
egeland |
1.1 |
|
14 |
|
|
# Actually, it is p5-xml-parser that requires this, but it doesn't configure itself correctly
|
15 |
|
|
# This is so it gets into our dependencies-setup.sh
|
16 |
|
|
Requires: expat
|
17 |
|
|
|
18 |
egeland |
1.3 |
# Required to use SecurityModule (part of webtools.spec)
|
19 |
egeland |
1.5 |
Requires: p5-crypt-cbc p5-crypt-blowfish
|
20 |
egeland |
1.3 |
|
21 |
egeland |
1.1 |
# Provided by system perl
|
22 |
|
|
Provides: perl(HTML::Entities)
|
23 |
|
|
Provides: perl(DB_File)
|
24 |
|
|
Provides: perl(XML::LibXML)
|
25 |
|
|
|
26 |
|
|
%prep
|
27 |
|
|
%setup -n %{downloadn}
|
28 |
|
|
|
29 |
|
|
%build
|
30 |
|
|
|
31 |
|
|
%install
|
32 |
|
|
mkdir -p %i/etc
|
33 |
|
|
tar -cf - * | (cd %i && tar -xf -)
|
34 |
|
|
|
35 |
|
|
# Switch template variables in the configuration files
|
36 |
|
|
export PHEDEX_ROOT=%i
|
37 |
egeland |
1.4 |
export APACHE2_CONFIG_ROOT=$APACHE2_CONFIG_ROOT
|
38 |
|
|
perl -p -i -e "s|\@PHEDEX_ROOT\@|$PHEDEX_ROOT|g;
|
39 |
|
|
s|\@APACHE2_CONF_ROOT\@|$APACHE2_CONF_ROOT|g" %i/Documentation/WebConfig/* %i/Documentation/WebSite/PlotConfig/config/*
|
40 |
egeland |
1.1 |
|
41 |
|
|
# Copy dependencies to dependencies-setup.sh
|
42 |
|
|
mkdir -p %i/etc/profile.d
|
43 |
|
|
for x in %pkgreqs; do
|
44 |
|
|
case $x in /* ) continue ;; esac
|
45 |
|
|
p=%{instroot}/%{cmsplatf}/$(echo $x | sed 's/\([^+]*\)+\(.*\)+\([A-Z0-9].*\)/\1 \2 \3/' | tr ' ' '/')
|
46 |
|
|
echo ". $p/etc/profile.d/init.sh" >> %i/etc/profile.d/dependencies-setup.sh
|
47 |
|
|
echo "source $p/etc/profile.d/init.csh" >> %i/etc/profile.d/dependencies-setup.csh
|
48 |
|
|
done
|
49 |
|
|
|
50 |
egeland |
1.4 |
# cp startup scripts to /bin
|
51 |
|
|
mkdir -p %i/bin
|
52 |
|
|
cp %i/Documentation/WebConfig/cmsweb_phedex* %i/bin
|
53 |
|
|
|
54 |
egeland |
1.1 |
%post
|
55 |
|
|
%{relocateConfig}Documentation/WebConfig/phedexweb-httpd.conf
|
56 |
|
|
%{relocateConfig}Documentation/WebConfig/phedexweb-app.conf
|
57 |
|
|
%{relocateConfig}Documentation/WebConfig/phedexweb-secmod.conf
|
58 |
egeland |
1.4 |
%{relocateConfig}Documentation/WebSite/PlotConfig/config/cherrypy_prod.conf
|
59 |
|
|
%{relocateConfig}bin/cmsweb_phedex
|
60 |
|
|
%{relocateConfig}bin/cmsweb_phedex_graphs
|
61 |
egeland |
1.1 |
%{relocateConfig}etc/profile.d/dependencies-setup.sh
|
62 |
|
|
%{relocateConfig}etc/profile.d/dependencies-setup.csh
|