ViewVC Help
View File | Revision Log | Show Annotations | Root Listing
root/cvsroot/COMP/CMSDIST/SCRAM.spec
Revision: 1.2
Committed: Thu Feb 9 15:07:19 2006 UTC (19 years, 2 months ago) by argiro
Branch: MAIN
Changes since 1.1: +1 -1 lines
Log Message:
fixed download location for V1.0.2

File Contents

# User Rev Content
1 argiro 1.1 ### RPM lcg SCRAM V1_0_2
2     ## INITENV +PATH PATH %instroot/bin
3    
4     # This package is somewhat unusual compared to other packages we
5     # build: we install the normally versioned product "SCRAM", but also
6     # create the front-end "scram" wrapper and the package database. The
7     # latter do not follow the standard versioning.
8     #
9     # The front-end script can be overwritten by any version *PROVIDED*
10     # the platform string comes first as is the default (i.e. the
11     # installation tree looks like <platf>/lcg/SCRAM/<version>/src).
12     #
13     # The database is only created, but never changeed. It is made part
14     # of this package, but none of the files in it are included, so if
15     # the package is removed, the directory will left intact. (FIXME:
16     # check this is really so -- should we use %dir, or the default is
17     # good?)
18     #
19     # The front-end wrapper and the script go at the installation root,
20     # not anywhere in the package tree. They must remain modifiable.
21     #
22     # We do the install ourselves, as "Installation/install_scram" would
23     # do, but putting the results elsewhere and using our own scram
24     # wrapper instead of using the supplied one -- mainly for easier
25     # override of SCRAM_LOOKUPDB; the wrapper is really rather simple so
26     # there is no point in trying to patch it.
27     #
28     # FIXME: should we have more than one project database and link them
29     # together into one big one?
30    
31 argiro 1.2 %define cvsrepo cvs://:pserver:anonymous@cmscvs.cern.ch:2401/cvs_server/repositories/SCRAM?passwd=AA_:yZZ3e
32 argiro 1.1
33     Source0: %{cvsrepo}&tag=-r%{v}&module=%n&output=/source.tar.gz
34    
35     %prep
36     %setup -n %n
37    
38     %build
39     %install
40     tar -cf - . | tar -C %i -xvvf -
41    
42     mkdir -p %instroot/bin %instroot/share/scramdb
43     cat > %instroot/bin/scram << \EOF
44     #!/bin/sh
45    
46     # FIXME: Handle -re?
47     # FIXME: Since we can install the same package on many platforms in
48     # one tree, should the project lookup database be platform-specific?
49    
50     SCRAM=$0
51     : ${SCRAM_HOME=%i}
52     : ${SCRAM_LOOKUPDB=%instroot/share/scramdb/project.lookup}
53     : ${SCRAMPERL="/usr/bin/env perl"}
54     PERL5LIB=$SCRAM_HOME/src${PERL5LIB+":$PERL5LIB"}
55     : ${SITENAME=CERN}
56     : ${SEARCHOVRD=true}
57     : ${LOCTOOLS=NODEFAULT}
58     export SCRAM SCRAM_HOME SCRAM_LOOKUPDB SCRAMPERL
59     export PERL5LIB SITENAME SEARCHOVRD LOCTOOLS
60    
61     exec perl "$SCRAM_HOME/src/scramcli" ${1+"$@"}
62     EOF
63     chmod 755 %instroot/bin/scram
64    
65     %files
66     %i
67     %instroot/bin/scram
68     %instroot/share/scramdb