1 |
argiro |
1.3 |
### RPM lcg SCRAM V0_20_0
|
2 |
argiro |
1.1 |
## INITENV +PATH PATH %instroot/bin
|
3 |
|
|
|
4 |
|
|
# This package is somewhat unusual compared to other packages we
|
5 |
|
|
# build: we install the normally versioned product "SCRAM", but also
|
6 |
|
|
# create the front-end "scram" wrapper and the package database. The
|
7 |
|
|
# latter do not follow the standard versioning.
|
8 |
|
|
#
|
9 |
|
|
# The front-end script can be overwritten by any version *PROVIDED*
|
10 |
|
|
# the platform string comes first as is the default (i.e. the
|
11 |
|
|
# installation tree looks like <platf>/lcg/SCRAM/<version>/src).
|
12 |
|
|
#
|
13 |
|
|
# The database is only created, but never changeed. It is made part
|
14 |
|
|
# of this package, but none of the files in it are included, so if
|
15 |
|
|
# the package is removed, the directory will left intact. (FIXME:
|
16 |
|
|
# check this is really so -- should we use %dir, or the default is
|
17 |
|
|
# good?)
|
18 |
|
|
#
|
19 |
|
|
# The front-end wrapper and the script go at the installation root,
|
20 |
|
|
# not anywhere in the package tree. They must remain modifiable.
|
21 |
|
|
#
|
22 |
|
|
# We do the install ourselves, as "Installation/install_scram" would
|
23 |
|
|
# do, but putting the results elsewhere and using our own scram
|
24 |
|
|
# wrapper instead of using the supplied one -- mainly for easier
|
25 |
|
|
# override of SCRAM_LOOKUPDB; the wrapper is really rather simple so
|
26 |
|
|
# there is no point in trying to patch it.
|
27 |
|
|
#
|
28 |
|
|
# FIXME: should we have more than one project database and link them
|
29 |
|
|
# together into one big one?
|
30 |
|
|
|
31 |
argiro |
1.3 |
%define cvsrepo cvs://:pserver:anonymous@spitools.cvs.cern.ch:2401/cvs/SPITOOLS?passwd=Ah<Z
|
32 |
argiro |
1.1 |
|
33 |
|
|
Source0: %{cvsrepo}&tag=-r%{v}&module=%n&output=/source.tar.gz
|
34 |
eulisse |
1.4 |
Requires: perl-virtual
|
35 |
|
|
Provides: perl(Utilities::GroupChecker)
|
36 |
argiro |
1.1 |
|
37 |
|
|
%prep
|
38 |
|
|
%setup -n %n
|
39 |
eulisse |
1.4 |
rm src/URL/test/test_URL_cvsfile.pm
|
40 |
argiro |
1.1 |
%build
|
41 |
|
|
%install
|
42 |
|
|
tar -cf - . | tar -C %i -xvvf -
|
43 |
|
|
|
44 |
|
|
mkdir -p %instroot/bin %instroot/share/scramdb
|
45 |
|
|
cat > %instroot/bin/scram << \EOF
|
46 |
|
|
#!/bin/sh
|
47 |
|
|
|
48 |
|
|
# FIXME: Handle -re?
|
49 |
|
|
# FIXME: Since we can install the same package on many platforms in
|
50 |
|
|
# one tree, should the project lookup database be platform-specific?
|
51 |
|
|
|
52 |
|
|
SCRAM=$0
|
53 |
|
|
: ${SCRAM_HOME=%i}
|
54 |
|
|
: ${SCRAM_LOOKUPDB=%instroot/share/scramdb/project.lookup}
|
55 |
|
|
: ${SCRAMPERL="/usr/bin/env perl"}
|
56 |
|
|
PERL5LIB=$SCRAM_HOME/src${PERL5LIB+":$PERL5LIB"}
|
57 |
|
|
: ${SITENAME=CERN}
|
58 |
|
|
: ${SEARCHOVRD=true}
|
59 |
|
|
: ${LOCTOOLS=NODEFAULT}
|
60 |
|
|
export SCRAM SCRAM_HOME SCRAM_LOOKUPDB SCRAMPERL
|
61 |
|
|
export PERL5LIB SITENAME SEARCHOVRD LOCTOOLS
|
62 |
|
|
|
63 |
|
|
exec perl "$SCRAM_HOME/src/scramcli" ${1+"$@"}
|
64 |
|
|
EOF
|
65 |
|
|
chmod 755 %instroot/bin/scram
|
66 |
eulisse |
1.4 |
perl -p -i -e "s|#!.*perl|#!/usr/bin/env perl|" $(find %{i})
|
67 |
argiro |
1.1 |
%files
|
68 |
|
|
%i
|
69 |
|
|
%instroot/bin/scram
|
70 |
|
|
%instroot/share/scramdb
|
71 |
eulisse |
1.5 |
%post
|
72 |
eulisse |
1.8 |
perl -p -i -e "s|%instroot|$RPM_INSTALL_PREFIX|g" $RPM_INSTALL_PREFIX/bin/scram
|