ViewVC Help
View File | Revision Log | Show Annotations | Root Listing
root/cvsroot/COMP/CMSDIST/SCRAM.spec
Revision: 1.9
Committed: Wed May 17 14:40:18 2006 UTC (18 years, 11 months ago) by eulisse
Branch: MAIN
Changes since 1.8: +0 -1 lines
Log Message:
Removed dependency on perl-virtual.

File Contents

# User Rev Content
1 argiro 1.3 ### RPM lcg SCRAM V0_20_0
2 argiro 1.1 ## INITENV +PATH PATH %instroot/bin
3    
4     # This package is somewhat unusual compared to other packages we
5     # build: we install the normally versioned product "SCRAM", but also
6     # create the front-end "scram" wrapper and the package database. The
7     # latter do not follow the standard versioning.
8     #
9     # The front-end script can be overwritten by any version *PROVIDED*
10     # the platform string comes first as is the default (i.e. the
11     # installation tree looks like <platf>/lcg/SCRAM/<version>/src).
12     #
13     # The database is only created, but never changeed. It is made part
14     # of this package, but none of the files in it are included, so if
15     # the package is removed, the directory will left intact. (FIXME:
16     # check this is really so -- should we use %dir, or the default is
17     # good?)
18     #
19     # The front-end wrapper and the script go at the installation root,
20     # not anywhere in the package tree. They must remain modifiable.
21     #
22     # We do the install ourselves, as "Installation/install_scram" would
23     # do, but putting the results elsewhere and using our own scram
24     # wrapper instead of using the supplied one -- mainly for easier
25     # override of SCRAM_LOOKUPDB; the wrapper is really rather simple so
26     # there is no point in trying to patch it.
27     #
28     # FIXME: should we have more than one project database and link them
29     # together into one big one?
30    
31 argiro 1.3 %define cvsrepo cvs://:pserver:anonymous@spitools.cvs.cern.ch:2401/cvs/SPITOOLS?passwd=Ah<Z
32 argiro 1.1
33     Source0: %{cvsrepo}&tag=-r%{v}&module=%n&output=/source.tar.gz
34 eulisse 1.4 Provides: perl(Utilities::GroupChecker)
35 argiro 1.1
36     %prep
37     %setup -n %n
38 eulisse 1.4 rm src/URL/test/test_URL_cvsfile.pm
39 argiro 1.1 %build
40     %install
41     tar -cf - . | tar -C %i -xvvf -
42    
43     mkdir -p %instroot/bin %instroot/share/scramdb
44     cat > %instroot/bin/scram << \EOF
45     #!/bin/sh
46    
47     # FIXME: Handle -re?
48     # FIXME: Since we can install the same package on many platforms in
49     # one tree, should the project lookup database be platform-specific?
50    
51     SCRAM=$0
52     : ${SCRAM_HOME=%i}
53     : ${SCRAM_LOOKUPDB=%instroot/share/scramdb/project.lookup}
54     : ${SCRAMPERL="/usr/bin/env perl"}
55     PERL5LIB=$SCRAM_HOME/src${PERL5LIB+":$PERL5LIB"}
56     : ${SITENAME=CERN}
57     : ${SEARCHOVRD=true}
58     : ${LOCTOOLS=NODEFAULT}
59     export SCRAM SCRAM_HOME SCRAM_LOOKUPDB SCRAMPERL
60     export PERL5LIB SITENAME SEARCHOVRD LOCTOOLS
61    
62     exec perl "$SCRAM_HOME/src/scramcli" ${1+"$@"}
63     EOF
64     chmod 755 %instroot/bin/scram
65 eulisse 1.4 perl -p -i -e "s|#!.*perl|#!/usr/bin/env perl|" $(find %{i})
66 argiro 1.1 %files
67     %i
68     %instroot/bin/scram
69     %instroot/share/scramdb
70 eulisse 1.5 %post
71 eulisse 1.8 perl -p -i -e "s|%instroot|$RPM_INSTALL_PREFIX|g" $RPM_INSTALL_PREFIX/bin/scram