ViewVC Help
View File | Revision Log | Show Annotations | Root Listing
root/cvsroot/COMP/CMSDIST/SCRAMV1.spec
Revision: 1.13
Committed: Mon Jun 19 09:50:24 2006 UTC (18 years, 10 months ago) by eulisse
Branch: MAIN
Changes since 1.12: +2 -0 lines
Log Message:
Does not pack the project.lookup db.

File Contents

# User Rev Content
1 eulisse 1.3 ### RPM lcg SCRAMV1 V1_0_2
2 argiro 1.1 ## INITENV +PATH PATH %instroot/bin
3 eulisse 1.3 ## INITENV SET SCRAM_ARCH %{cmsplatf}
4 eulisse 1.7 ## INITENV +PATH PERL5LIB %{i}
5 eulisse 1.9 Requires: expat p5-template-toolkit p5-uri p5-xml-parser p5-libwww-perl
6 eulisse 1.7 Provides: perl(SCRAM::Helper)
7     Provides: perl(Utilities::AddDir)
8     Provides: perl(Utilities::Architecture)
9     Provides: perl(Utilities::SCRAMUtils)
10     Provides: perl(ActiveDoc::GroupChecker)
11     Provides: perl(ActiveDoc::UserInterface_basic)
12     Provides: perl(ActiveDoc::UserQuery)
13     Provides: perl(Doxygen::Context)
14     Provides: perl(Graph::Graph)
15     Provides: perl(ObjectStore)
16    
17 argiro 1.1 # This package is somewhat unusual compared to other packages we
18     # build: we install the normally versioned product "SCRAM", but also
19     # create the front-end "scram" wrapper and the package database. The
20     # latter do not follow the standard versioning.
21     #
22     # The front-end script can be overwritten by any version *PROVIDED*
23     # the platform string comes first as is the default (i.e. the
24     # installation tree looks like <platf>/lcg/SCRAM/<version>/src).
25     #
26     # The database is only created, but never changeed. It is made part
27     # of this package, but none of the files in it are included, so if
28     # the package is removed, the directory will left intact. (FIXME:
29     # check this is really so -- should we use %dir, or the default is
30     # good?)
31     #
32     # The front-end wrapper and the script go at the installation root,
33     # not anywhere in the package tree. They must remain modifiable.
34     #
35     # We do the install ourselves, as "Installation/install_scram" would
36     # do, but putting the results elsewhere and using our own scram
37     # wrapper instead of using the supplied one -- mainly for easier
38     # override of SCRAM_LOOKUPDB; the wrapper is really rather simple so
39     # there is no point in trying to patch it.
40     #
41     # FIXME: should we have more than one project database and link them
42     # together into one big one?
43    
44 eulisse 1.2 %define cvsrepo cvs://:pserver:anonymous@cmscvs.cern.ch:2401/cvs_server/repositories/SCRAM?passwd=AA_:yZZ3e
45 argiro 1.1
46 eulisse 1.2 Source0: %{cvsrepo}&tag=-r%{v}&module=SCRAM&output=/source.tar.gz
47 argiro 1.1
48     %prep
49     %setup -n SCRAM
50     %build
51     %install
52     tar -cf - . | tar -C %i -xvvf -
53 eulisse 1.7 rm -rf %i/cgi
54 eulisse 1.2 mkdir -p %instroot/bin %instroot/share/scramdb %i/Installation
55 eulisse 1.13 touch %instroot/share/scramdb/project.lookup
56 eulisse 1.2
57 eulisse 1.7 cat Installation/scram.pl.in | sed -e "s|@PERLEXE@|/usr/bin/env perl|;s|@SCRAM_HOME@|%i|;s|@INSTALLDIR@|%i/src|" > %instroot/bin/scramv1
58     cat Installation/SCRAM_SITE.pm.in | sed -e "s|@SCRAM_HOME@|%i|;s|@SCRAM_LOOKUPDB_DIR@|%instroot/share/scramdb/|;s|@PERLEXE@|/usr/bin/env perl|;s|@TT2INSTALLDIR@|$TEMPLATE_TOOLKIT_ROOT/lib|;s|@SITETEMPLATEDIR@|%i/Templates|;s|@SCRAM_SITENAME@|STANDALONE|" > %i/Installation/SCRAM_SITE.pm
59 eulisse 1.2
60     # cat > %instroot/bin/scramv1 << \EOF
61     # #!/bin/sh
62     #
63     # # FIXME: Handle -re?
64     # # FIXME: Since we can install the same package on many platforms in
65     # # one tree, should the project lookup database be platform-specific?
66     #
67     # SCRAM=$0
68     # : ${SCRAM_HOME=%i}
69     # : ${SCRAM_LOOKUPDB=%instroot/share/scramdb/project.lookup}
70     # : ${SCRAMPERL="/usr/bin/env perl"}
71     # PERL5LIB=$SCRAM_HOME/src${PERL5LIB+":$PERL5LIB"}
72     # : ${SITENAME=CERN}
73     # : ${SEARCHOVRD=true}
74     # : ${LOCTOOLS=NODEFAULT}
75     # export SCRAM SCRAM_HOME SCRAM_LOOKUPDB SCRAMPERL
76     # export PERL5LIB SITENAME SEARCHOVRD LOCTOOLS
77     #
78     # exec perl "$SCRAM_HOME/src/scramcli" ${1+"$@"}
79     # EOF
80     chmod 755 %instroot/bin/scramv1
81 eulisse 1.3 mkdir %i/etc
82     echo $PERL5LIB > %i/etc/perl5lib.env
83 eulisse 1.6
84     mkdir -p %{i}/etc/profile.d
85     echo "#!/bin/sh" > %i/etc/profile.d/dependencies-setup.sh
86     echo "source $EXPAT_ROOT/etc/profile.d/init.sh" >> %i/etc/profile.d/dependencies-setup.sh
87     echo "source $P5_TEMPLATE_TOOLKIT_ROOT/etc/profile.d/init.sh" >> %i/etc/profile.d/dependencies-setup.sh
88     echo "source $P5_URI_ROOT/etc/profile.d/init.sh" >> %i/etc/profile.d/dependencies-setup.sh
89     echo "source $P5_XML_PARSER_ROOT/etc/profile.d/init.sh" >> %i/etc/profile.d/dependencies-setup.sh
90     echo "source $P5_LIBWWW_PERL_ROOT/etc/profile.d/init.sh" >> %i/etc/profile.d/dependencies-setup.sh
91    
92 eulisse 1.11 echo "#!/bin/csh" > %i/etc/profile.d/dependencies-setup.csh
93     echo "source $EXPAT_ROOT/etc/profile.d/init.csh" >> %i/etc/profile.d/dependencies-setup.csh
94     echo "source $P5_TEMPLATE_TOOLKIT_ROOT/etc/profile.d/init.csh" >> %i/etc/profile.d/dependencies-setup.csh
95     echo "source $P5_URI_ROOT/etc/profile.d/init.csh" >> %i/etc/profile.d/dependencies-setup.csh
96     echo "source $P5_XML_PARSER_ROOT/etc/profile.d/init.csh" >> %i/etc/profile.d/dependencies-setup.csh
97     echo "source $P5_LIBWWW_PERL_ROOT/etc/profile.d/init.csh" >> %i/etc/profile.d/dependencies-setup.csh
98    
99    
100 eulisse 1.7 perl -p -i -e "s|#!.*perl|/usr/bin/env perl|" %{i}/doc/doxygen/DoxyFilt.pl
101    
102 eulisse 1.5 %post
103 eulisse 1.6 %{relocateConfig}etc/perl5lib.env
104 eulisse 1.5 %{relocateConfig}Installation/SCRAM_SITE.pm
105 eulisse 1.7
106     if [ -f $RPM_INSTALL_PREFIX/%pkgrel/bin/scramv1 ]
107     then
108     %{relocateConfig}%{instroot}/bin/scramv1
109     fi
110    
111 eulisse 1.6 %{relocateConfig}etc/profile.d/dependencies-setup.sh
112 eulisse 1.12 %{relocateConfig}etc/profile.d/dependencies-setup.csh
113 eulisse 1.7 perl -p -i -e "s|%{instroot}|$RPM_INSTALL_PREFIX|g" $RPM_INSTALL_PREFIX/bin/scramv1
114 argiro 1.1 %files
115     %i
116 eulisse 1.2 %instroot/bin/scramv1
117 argiro 1.1 %instroot/share/scramdb
118 eulisse 1.13 %exclude %instroot/share/scramdb/project.lookup