ViewVC Help
View File | Revision Log | Show Annotations | Root Listing
root/cvsroot/COMP/CMSDIST/SCRAMV1.spec
Revision: 1.22
Committed: Tue Aug 22 07:35:05 2006 UTC (18 years, 8 months ago) by eulisse
Branch: MAIN
Changes since 1.21: +1 -1 lines
Log Message:
Regenerating scramv1_0_1 toolfile

File Contents

# User Rev Content
1 eulisse 1.22 ### RPM lcg SCRAMV1 V1_0_1
2 argiro 1.1 ## INITENV +PATH PATH %instroot/bin
3 eulisse 1.7 ## INITENV +PATH PERL5LIB %{i}
4 eulisse 1.21 Requires: expat p5-template-toolkit p5-uri p5-xml-parser p5-libwww-perl cms-env
5 eulisse 1.7 Provides: perl(SCRAM::Helper)
6     Provides: perl(Utilities::AddDir)
7     Provides: perl(Utilities::Architecture)
8     Provides: perl(Utilities::SCRAMUtils)
9     Provides: perl(ActiveDoc::GroupChecker)
10     Provides: perl(ActiveDoc::UserInterface_basic)
11     Provides: perl(ActiveDoc::UserQuery)
12     Provides: perl(Doxygen::Context)
13     Provides: perl(Graph::Graph)
14     Provides: perl(ObjectStore)
15    
16 argiro 1.1 # This package is somewhat unusual compared to other packages we
17     # build: we install the normally versioned product "SCRAM", but also
18     # create the front-end "scram" wrapper and the package database. The
19     # latter do not follow the standard versioning.
20     #
21     # The front-end script can be overwritten by any version *PROVIDED*
22     # the platform string comes first as is the default (i.e. the
23     # installation tree looks like <platf>/lcg/SCRAM/<version>/src).
24     #
25     # The database is only created, but never changeed. It is made part
26     # of this package, but none of the files in it are included, so if
27     # the package is removed, the directory will left intact. (FIXME:
28     # check this is really so -- should we use %dir, or the default is
29     # good?)
30     #
31     # The front-end wrapper and the script go at the installation root,
32     # not anywhere in the package tree. They must remain modifiable.
33     #
34     # We do the install ourselves, as "Installation/install_scram" would
35     # do, but putting the results elsewhere and using our own scram
36     # wrapper instead of using the supplied one -- mainly for easier
37     # override of SCRAM_LOOKUPDB; the wrapper is really rather simple so
38     # there is no point in trying to patch it.
39     #
40     # FIXME: should we have more than one project database and link them
41     # together into one big one?
42    
43 eulisse 1.2 %define cvsrepo cvs://:pserver:anonymous@cmscvs.cern.ch:2401/cvs_server/repositories/SCRAM?passwd=AA_:yZZ3e
44 argiro 1.1
45 eulisse 1.2 Source0: %{cvsrepo}&tag=-r%{v}&module=SCRAM&output=/source.tar.gz
46 argiro 1.1
47     %prep
48     %setup -n SCRAM
49     %build
50     %install
51     tar -cf - . | tar -C %i -xvvf -
52 eulisse 1.7 rm -rf %i/cgi
53 eulisse 1.2 mkdir -p %instroot/bin %instroot/share/scramdb %i/Installation
54 eulisse 1.19 mkdir -p %i/bin
55 eulisse 1.13 touch %instroot/share/scramdb/project.lookup
56 eulisse 1.2
57 eulisse 1.19 cat Installation/scram.pl.in | sed -e "s|@PERLEXE@|/usr/bin/env perl|;s|@SCRAM_HOME@|%i|;s|@INSTALLDIR@|%i/src|" > %i/bin/scramv1
58     cat << \EOF_BIN_SCRAMV1 > %instroot/bin/scramv1
59     #!/bin/sh
60 eulisse 1.21 source %instroot/`cmsarch`/lcg/%n/%v/etc/profile.d/init.sh
61     %instroot/`cmsarch`/lcg/%n/%v/bin/scramv1 $@
62 eulisse 1.19 EOF_BIN_SCRAMV1
63    
64 eulisse 1.7 cat Installation/SCRAM_SITE.pm.in | sed -e "s|@SCRAM_HOME@|%i|;s|@SCRAM_LOOKUPDB_DIR@|%instroot/share/scramdb/|;s|@PERLEXE@|/usr/bin/env perl|;s|@TT2INSTALLDIR@|$TEMPLATE_TOOLKIT_ROOT/lib|;s|@SITETEMPLATEDIR@|%i/Templates|;s|@SCRAM_SITENAME@|STANDALONE|" > %i/Installation/SCRAM_SITE.pm
65 eulisse 1.2
66     # cat > %instroot/bin/scramv1 << \EOF
67     # #!/bin/sh
68     #
69     # # FIXME: Handle -re?
70     # # FIXME: Since we can install the same package on many platforms in
71     # # one tree, should the project lookup database be platform-specific?
72     #
73     # SCRAM=$0
74     # : ${SCRAM_HOME=%i}
75     # : ${SCRAM_LOOKUPDB=%instroot/share/scramdb/project.lookup}
76     # : ${SCRAMPERL="/usr/bin/env perl"}
77     # PERL5LIB=$SCRAM_HOME/src${PERL5LIB+":$PERL5LIB"}
78     # : ${SITENAME=CERN}
79     # : ${SEARCHOVRD=true}
80     # : ${LOCTOOLS=NODEFAULT}
81     # export SCRAM SCRAM_HOME SCRAM_LOOKUPDB SCRAMPERL
82     # export PERL5LIB SITENAME SEARCHOVRD LOCTOOLS
83     #
84     # exec perl "$SCRAM_HOME/src/scramcli" ${1+"$@"}
85     # EOF
86     chmod 755 %instroot/bin/scramv1
87 eulisse 1.19 chmod 755 %i/bin/scramv1
88    
89 eulisse 1.3 mkdir %i/etc
90     echo $PERL5LIB > %i/etc/perl5lib.env
91 eulisse 1.6
92 eulisse 1.15 mkdir -p %{instroot}/%{cmsplatf}/etc/profile.d
93 eulisse 1.6 mkdir -p %{i}/etc/profile.d
94     echo "#!/bin/sh" > %i/etc/profile.d/dependencies-setup.sh
95     echo "source $EXPAT_ROOT/etc/profile.d/init.sh" >> %i/etc/profile.d/dependencies-setup.sh
96     echo "source $P5_TEMPLATE_TOOLKIT_ROOT/etc/profile.d/init.sh" >> %i/etc/profile.d/dependencies-setup.sh
97     echo "source $P5_URI_ROOT/etc/profile.d/init.sh" >> %i/etc/profile.d/dependencies-setup.sh
98     echo "source $P5_XML_PARSER_ROOT/etc/profile.d/init.sh" >> %i/etc/profile.d/dependencies-setup.sh
99     echo "source $P5_LIBWWW_PERL_ROOT/etc/profile.d/init.sh" >> %i/etc/profile.d/dependencies-setup.sh
100    
101 eulisse 1.11 echo "#!/bin/csh" > %i/etc/profile.d/dependencies-setup.csh
102     echo "source $EXPAT_ROOT/etc/profile.d/init.csh" >> %i/etc/profile.d/dependencies-setup.csh
103     echo "source $P5_TEMPLATE_TOOLKIT_ROOT/etc/profile.d/init.csh" >> %i/etc/profile.d/dependencies-setup.csh
104     echo "source $P5_URI_ROOT/etc/profile.d/init.csh" >> %i/etc/profile.d/dependencies-setup.csh
105     echo "source $P5_XML_PARSER_ROOT/etc/profile.d/init.csh" >> %i/etc/profile.d/dependencies-setup.csh
106     echo "source $P5_LIBWWW_PERL_ROOT/etc/profile.d/init.csh" >> %i/etc/profile.d/dependencies-setup.csh
107    
108 eulisse 1.7 perl -p -i -e "s|#!.*perl|/usr/bin/env perl|" %{i}/doc/doxygen/DoxyFilt.pl
109    
110 eulisse 1.5 %post
111 eulisse 1.6 %{relocateConfig}etc/perl5lib.env
112 eulisse 1.5 %{relocateConfig}Installation/SCRAM_SITE.pm
113 eulisse 1.19 %{relocateConfig}bin/scramv1
114 eulisse 1.6 %{relocateConfig}etc/profile.d/dependencies-setup.sh
115 eulisse 1.12 %{relocateConfig}etc/profile.d/dependencies-setup.csh
116 eulisse 1.7 perl -p -i -e "s|%{instroot}|$RPM_INSTALL_PREFIX|g" $RPM_INSTALL_PREFIX/bin/scramv1
117 eulisse 1.15
118 argiro 1.1 %files
119     %i
120 eulisse 1.2 %instroot/bin/scramv1
121 argiro 1.1 %instroot/share/scramdb
122 eulisse 1.13 %exclude %instroot/share/scramdb/project.lookup
123 eulisse 1.18 %exclude %i/scripts/DrDOC.sh