ViewVC Help
View File | Revision Log | Show Annotations | Root Listing
root/cvsroot/COMP/CMSDIST/SCRAMV1.spec
Revision: 1.35
Committed: Thu Sep 28 09:53:43 2006 UTC (18 years, 7 months ago) by eulisse
Branch: MAIN
Changes since 1.34: +9 -0 lines
Log Message:
one more iteration to remove hidden dependencies.

File Contents

# User Rev Content
1 eulisse 1.34 ### RPM lcg SCRAMV1 V1_0_3
2 argiro 1.1 ## INITENV +PATH PATH %instroot/bin
3 eulisse 1.7 ## INITENV +PATH PERL5LIB %{i}
4 eulisse 1.21 Requires: expat p5-template-toolkit p5-uri p5-xml-parser p5-libwww-perl cms-env
5 eulisse 1.24 Requires: scramv1-wrapper
6 eulisse 1.7 Provides: perl(SCRAM::Helper)
7     Provides: perl(Utilities::AddDir)
8     Provides: perl(Utilities::Architecture)
9     Provides: perl(Utilities::SCRAMUtils)
10     Provides: perl(ActiveDoc::GroupChecker)
11     Provides: perl(ActiveDoc::UserInterface_basic)
12     Provides: perl(ActiveDoc::UserQuery)
13     Provides: perl(Doxygen::Context)
14     Provides: perl(Graph::Graph)
15     Provides: perl(ObjectStore)
16 eulisse 1.24 Provides: perl(Utilities::SVNmodule)
17     Provides: perl(URL::URL_cvsfile)
18 eulisse 1.35 Provides: perl(BuildSystem::Block)
19     Provides: perl(BuildSystem::Build)
20     Provides: perl(BuildSystem::BuildClass)
21     Provides: perl(BuildSystem::BuildSetup)
22     Provides: perl(BuildSystem::DateStampRecord)
23     Provides: perl(BuildSystem::Tool)
24     Provides: perl(BuildSystem::ToolBox)
25     Provides: perl(BuildSystem::ToolDoc)
26     Provides: perl(Utilities::GroupChecker)
27 eulisse 1.7
28 argiro 1.1 # This package is somewhat unusual compared to other packages we
29     # build: we install the normally versioned product "SCRAM", but also
30     # create the front-end "scram" wrapper and the package database. The
31     # latter do not follow the standard versioning.
32     #
33     # The front-end script can be overwritten by any version *PROVIDED*
34     # the platform string comes first as is the default (i.e. the
35     # installation tree looks like <platf>/lcg/SCRAM/<version>/src).
36     #
37     # The database is only created, but never changeed. It is made part
38     # of this package, but none of the files in it are included, so if
39     # the package is removed, the directory will left intact. (FIXME:
40     # check this is really so -- should we use %dir, or the default is
41     # good?)
42     #
43     # The front-end wrapper and the script go at the installation root,
44     # not anywhere in the package tree. They must remain modifiable.
45     #
46     # We do the install ourselves, as "Installation/install_scram" would
47     # do, but putting the results elsewhere and using our own scram
48     # wrapper instead of using the supplied one -- mainly for easier
49     # override of SCRAM_LOOKUPDB; the wrapper is really rather simple so
50     # there is no point in trying to patch it.
51     #
52     # FIXME: should we have more than one project database and link them
53     # together into one big one?
54    
55 eulisse 1.2 %define cvsrepo cvs://:pserver:anonymous@cmscvs.cern.ch:2401/cvs_server/repositories/SCRAM?passwd=AA_:yZZ3e
56 argiro 1.1
57 eulisse 1.2 Source0: %{cvsrepo}&tag=-r%{v}&module=SCRAM&output=/source.tar.gz
58 argiro 1.1
59     %prep
60     %setup -n SCRAM
61     %build
62     %install
63     tar -cf - . | tar -C %i -xvvf -
64 eulisse 1.7 rm -rf %i/cgi
65 eulisse 1.2 mkdir -p %instroot/bin %instroot/share/scramdb %i/Installation
66 eulisse 1.19 mkdir -p %i/bin
67 eulisse 1.13 touch %instroot/share/scramdb/project.lookup
68 eulisse 1.2
69 eulisse 1.19 cat Installation/scram.pl.in | sed -e "s|@PERLEXE@|/usr/bin/env perl|;s|@SCRAM_HOME@|%i|;s|@INSTALLDIR@|%i/src|" > %i/bin/scramv1
70 eulisse 1.24 cat Installation/scram.pl.in | sed -e "s|@PERLEXE@|/usr/bin/env perl|;s|@SCRAM_HOME@|%i|;s|@INSTALLDIR@|%i/src|" > %i/src/main/scram.pl
71     chmod +x %i/src/main/scram.pl
72 eulisse 1.7 cat Installation/SCRAM_SITE.pm.in | sed -e "s|@SCRAM_HOME@|%i|;s|@SCRAM_LOOKUPDB_DIR@|%instroot/share/scramdb/|;s|@PERLEXE@|/usr/bin/env perl|;s|@TT2INSTALLDIR@|$TEMPLATE_TOOLKIT_ROOT/lib|;s|@SITETEMPLATEDIR@|%i/Templates|;s|@SCRAM_SITENAME@|STANDALONE|" > %i/Installation/SCRAM_SITE.pm
73 eulisse 1.2
74     # cat > %instroot/bin/scramv1 << \EOF
75     # #!/bin/sh
76     #
77     # # FIXME: Handle -re?
78     # # FIXME: Since we can install the same package on many platforms in
79     # # one tree, should the project lookup database be platform-specific?
80     #
81     # SCRAM=$0
82     # : ${SCRAM_HOME=%i}
83     # : ${SCRAM_LOOKUPDB=%instroot/share/scramdb/project.lookup}
84     # : ${SCRAMPERL="/usr/bin/env perl"}
85     # PERL5LIB=$SCRAM_HOME/src${PERL5LIB+":$PERL5LIB"}
86     # : ${SITENAME=CERN}
87     # : ${SEARCHOVRD=true}
88     # : ${LOCTOOLS=NODEFAULT}
89     # export SCRAM SCRAM_HOME SCRAM_LOOKUPDB SCRAMPERL
90     # export PERL5LIB SITENAME SEARCHOVRD LOCTOOLS
91     #
92     # exec perl "$SCRAM_HOME/src/scramcli" ${1+"$@"}
93     # EOF
94 eulisse 1.19 chmod 755 %i/bin/scramv1
95    
96 eulisse 1.3 mkdir %i/etc
97     echo $PERL5LIB > %i/etc/perl5lib.env
98 eulisse 1.6
99 eulisse 1.15 mkdir -p %{instroot}/%{cmsplatf}/etc/profile.d
100 eulisse 1.6 mkdir -p %{i}/etc/profile.d
101     echo "#!/bin/sh" > %i/etc/profile.d/dependencies-setup.sh
102     echo "source $EXPAT_ROOT/etc/profile.d/init.sh" >> %i/etc/profile.d/dependencies-setup.sh
103     echo "source $P5_TEMPLATE_TOOLKIT_ROOT/etc/profile.d/init.sh" >> %i/etc/profile.d/dependencies-setup.sh
104     echo "source $P5_URI_ROOT/etc/profile.d/init.sh" >> %i/etc/profile.d/dependencies-setup.sh
105     echo "source $P5_XML_PARSER_ROOT/etc/profile.d/init.sh" >> %i/etc/profile.d/dependencies-setup.sh
106     echo "source $P5_LIBWWW_PERL_ROOT/etc/profile.d/init.sh" >> %i/etc/profile.d/dependencies-setup.sh
107    
108 eulisse 1.11 echo "#!/bin/csh" > %i/etc/profile.d/dependencies-setup.csh
109     echo "source $EXPAT_ROOT/etc/profile.d/init.csh" >> %i/etc/profile.d/dependencies-setup.csh
110     echo "source $P5_TEMPLATE_TOOLKIT_ROOT/etc/profile.d/init.csh" >> %i/etc/profile.d/dependencies-setup.csh
111     echo "source $P5_URI_ROOT/etc/profile.d/init.csh" >> %i/etc/profile.d/dependencies-setup.csh
112     echo "source $P5_XML_PARSER_ROOT/etc/profile.d/init.csh" >> %i/etc/profile.d/dependencies-setup.csh
113     echo "source $P5_LIBWWW_PERL_ROOT/etc/profile.d/init.csh" >> %i/etc/profile.d/dependencies-setup.csh
114    
115 eulisse 1.7 perl -p -i -e "s|#!.*perl|/usr/bin/env perl|" %{i}/doc/doxygen/DoxyFilt.pl
116    
117 eulisse 1.5 %post
118 eulisse 1.6 %{relocateConfig}etc/perl5lib.env
119 eulisse 1.5 %{relocateConfig}Installation/SCRAM_SITE.pm
120 eulisse 1.19 %{relocateConfig}bin/scramv1
121 eulisse 1.24 %{relocateConfig}src/main/scram.pl
122 eulisse 1.6 %{relocateConfig}etc/profile.d/dependencies-setup.sh
123 eulisse 1.12 %{relocateConfig}etc/profile.d/dependencies-setup.csh
124 eulisse 1.24 # If and only if there is no default-scramv1 set the default to be the version we package in this spec.
125     OLD_VERSION=""
126 eulisse 1.32 if [ -f $RPM_INSTALL_PREFIX/%{cmsplatf}/etc/default-scramv1-version ]
127 eulisse 1.24 then
128 eulisse 1.32 mkdir -p $RPM_INSTALL_PREFIX/%{cmsplatf}/etc
129 eulisse 1.24 OLD_VERSION=`cat $RPM_INSTALL_PREFIX/%{cmsplatf}/etc/default-scramv1-version`
130     fi
131     NEW_VERSION=%v
132     (echo $OLD_VERSION;echo $NEW_VERSION) | sort | tail -1 > $RPM_INSTALL_PREFIX/%{cmsplatf}/etc/default-scramv1-version
133 eulisse 1.15
134 argiro 1.1 %files
135     %i
136     %instroot/share/scramdb
137 eulisse 1.13 %exclude %instroot/share/scramdb/project.lookup
138 eulisse 1.18 %exclude %i/scripts/DrDOC.sh