1 |
dlange |
1.73 |
### RPM lcg SCRAMV1 V1_2_0-cand6
|
2 |
elmer |
1.71 |
## INITENV +PATH PATH %instroot/common
|
3 |
eulisse |
1.7 |
|
4 |
argiro |
1.1 |
# This package is somewhat unusual compared to other packages we
|
5 |
|
|
# build: we install the normally versioned product "SCRAM", but also
|
6 |
elmer |
1.71 |
# create the package database. The latter do not follow the
|
7 |
|
|
# standard versioning.
|
8 |
argiro |
1.1 |
#
|
9 |
|
|
# The database is only created, but never changeed. It is made part
|
10 |
|
|
# of this package, but none of the files in it are included, so if
|
11 |
|
|
# the package is removed, the directory will left intact. (FIXME:
|
12 |
|
|
# check this is really so -- should we use %dir, or the default is
|
13 |
|
|
# good?)
|
14 |
|
|
#
|
15 |
|
|
# FIXME: should we have more than one project database and link them
|
16 |
|
|
# together into one big one?
|
17 |
|
|
|
18 |
elmer |
1.71 |
%define cvsrepo cvs://:pserver:anonymous@cmscvs.cern.ch:/cvs_server/repositories/CMSSW?passwd=AA_:yZZ3e
|
19 |
muzaffar |
1.72 |
%define cvstag %v
|
20 |
elmer |
1.71 |
Source0: %{cvsrepo}&tag=-r%{cvstag}&module=SCRAM&output=/source.tar.gz
|
21 |
argiro |
1.1 |
|
22 |
|
|
%prep
|
23 |
|
|
%setup -n SCRAM
|
24 |
|
|
%build
|
25 |
|
|
%install
|
26 |
|
|
tar -cf - . | tar -C %i -xvvf -
|
27 |
muzaffar |
1.72 |
|
28 |
|
|
mkdir -p %i/src/main %instroot/%cmsplatf/lcg/SCRAMV1/scramdb
|
29 |
ratnik |
1.52 |
touch %instroot/%cmsplatf/lcg/SCRAMV1/scramdb/project.lookup
|
30 |
eulisse |
1.2 |
|
31 |
muzaffar |
1.72 |
#SCRAM/INSTALL.txt recomendations
|
32 |
|
|
sed -i -e "s|@SCRAM_LOOKUPDB_DIR@|%instroot/%cmsplatf/lcg/SCRAMV1/scramdb/|g;s|@SCRAM_VERSION@|%v|g" %i/bin/scram
|
33 |
|
|
ln -s ../../bin/scram %i/src/main/scram.pl
|
34 |
elmer |
1.71 |
chmod 755 %i/bin/scram
|
35 |
eulisse |
1.2 |
|
36 |
eulisse |
1.15 |
mkdir -p %{instroot}/%{cmsplatf}/etc/profile.d
|
37 |
eulisse |
1.6 |
mkdir -p %{i}/etc/profile.d
|
38 |
eulisse |
1.7 |
|
39 |
eulisse |
1.5 |
%post
|
40 |
elmer |
1.71 |
%{relocateConfig}bin/scram
|
41 |
eulisse |
1.24 |
# If and only if there is no default-scramv1 set the default to be the version we package in this spec.
|
42 |
|
|
OLD_VERSION=""
|
43 |
eulisse |
1.32 |
if [ -f $RPM_INSTALL_PREFIX/%{cmsplatf}/etc/default-scramv1-version ]
|
44 |
eulisse |
1.24 |
then
|
45 |
eulisse |
1.32 |
mkdir -p $RPM_INSTALL_PREFIX/%{cmsplatf}/etc
|
46 |
eulisse |
1.24 |
OLD_VERSION=`cat $RPM_INSTALL_PREFIX/%{cmsplatf}/etc/default-scramv1-version`
|
47 |
|
|
fi
|
48 |
|
|
NEW_VERSION=%v
|
49 |
|
|
(echo $OLD_VERSION;echo $NEW_VERSION) | sort | tail -1 > $RPM_INSTALL_PREFIX/%{cmsplatf}/etc/default-scramv1-version
|
50 |
eulisse |
1.15 |
|
51 |
ratnik |
1.52 |
mkdir -p $RPM_INSTALL_PREFIX/%cmsplatf/lcg/SCRAMV1/scramdb
|
52 |
|
|
touch $RPM_INSTALL_PREFIX/%cmsplatf/lcg/SCRAMV1/scramdb/project.lookup
|
53 |
|
|
if [ -f $RPM_INSTALL_PREFIX/share/scramdb/project.lookup ] ; then
|
54 |
|
|
dblinked=`grep "DB $RPM_INSTALL_PREFIX/share/scramdb/project.lookup" $RPM_INSTALL_PREFIX/%cmsplatf/lcg/SCRAMV1/scramdb/project.lookup`
|
55 |
elmer |
1.71 |
if [ "X$dblinked" = "X" ] ; then
|
56 |
ratnik |
1.52 |
echo '!DB' $RPM_INSTALL_PREFIX/share/scramdb/project.lookup > $RPM_INSTALL_PREFIX/%cmsplatf/lcg/SCRAMV1/scramdb/project.lookup.link
|
57 |
|
|
cat $RPM_INSTALL_PREFIX/%cmsplatf/lcg/SCRAMV1/scramdb/project.lookup >> $RPM_INSTALL_PREFIX/%cmsplatf/lcg/SCRAMV1/scramdb/project.lookup.link
|
58 |
|
|
mv $RPM_INSTALL_PREFIX/%cmsplatf/lcg/SCRAMV1/scramdb/project.lookup.link $RPM_INSTALL_PREFIX/%cmsplatf/lcg/SCRAMV1/scramdb/project.lookup
|
59 |
|
|
fi
|
60 |
|
|
fi
|
61 |
eulisse |
1.55 |
|
62 |
argiro |
1.1 |
%files
|
63 |
|
|
%i
|
64 |
ratnik |
1.52 |
%instroot/%cmsplatf/lcg/SCRAMV1/scramdb
|
65 |
|
|
%exclude %instroot/%cmsplatf/lcg/SCRAMV1/scramdb/project.lookup
|