1 |
muzaffar |
1.86 |
### RPM lcg SCRAMV1 V1_0_3-p3
|
2 |
elmer |
1.71 |
## INITENV +PATH PATH %instroot/common
|
3 |
muzaffar |
1.80 |
## INITENV +PATH PERL5LIB %{i}
|
4 |
muzaffar |
1.85 |
Requires: p5-template-toolkit p5-uri p5-xml-parser p5-libwww-perl cms-env
|
5 |
muzaffar |
1.80 |
Provides: perl(SCRAM::Helper)
|
6 |
|
|
Provides: perl(Utilities::AddDir)
|
7 |
|
|
Provides: perl(Utilities::Architecture)
|
8 |
|
|
Provides: perl(Utilities::SCRAMUtils)
|
9 |
|
|
Provides: perl(ActiveDoc::GroupChecker)
|
10 |
|
|
Provides: perl(ActiveDoc::UserInterface_basic)
|
11 |
|
|
Provides: perl(ActiveDoc::UserQuery)
|
12 |
|
|
Provides: perl(Doxygen::Context)
|
13 |
|
|
Provides: perl(Graph::Graph)
|
14 |
|
|
Provides: perl(ObjectStore)
|
15 |
muzaffar |
1.83 |
Provides: perl(Utilities::SVNmodule)
|
16 |
|
|
Provides: perl(URL::URL_cvsfile)
|
17 |
|
|
Provides: perl(BuildSystem::Block)
|
18 |
|
|
Provides: perl(BuildSystem::Build)
|
19 |
|
|
Provides: perl(BuildSystem::BuildClass)
|
20 |
|
|
Provides: perl(BuildSystem::BuildSetup)
|
21 |
|
|
Provides: perl(BuildSystem::DateStampRecord)
|
22 |
|
|
Provides: perl(BuildSystem::Tool)
|
23 |
|
|
Provides: perl(BuildSystem::ToolBox)
|
24 |
|
|
Provides: perl(BuildSystem::ToolDoc)
|
25 |
|
|
Provides: perl(Utilities::GroupChecker)
|
26 |
eulisse |
1.7 |
|
27 |
argiro |
1.1 |
# This package is somewhat unusual compared to other packages we
|
28 |
|
|
# build: we install the normally versioned product "SCRAM", but also
|
29 |
muzaffar |
1.80 |
# create the front-end "scram" wrapper and the package database. The
|
30 |
|
|
# latter do not follow the standard versioning.
|
31 |
|
|
#
|
32 |
|
|
# The front-end script can be overwritten by any version *PROVIDED*
|
33 |
|
|
# the platform string comes first as is the default (i.e. the
|
34 |
|
|
# installation tree looks like <platf>/lcg/SCRAM/<version>/src).
|
35 |
argiro |
1.1 |
#
|
36 |
|
|
# The database is only created, but never changeed. It is made part
|
37 |
|
|
# of this package, but none of the files in it are included, so if
|
38 |
|
|
# the package is removed, the directory will left intact. (FIXME:
|
39 |
|
|
# check this is really so -- should we use %dir, or the default is
|
40 |
|
|
# good?)
|
41 |
|
|
#
|
42 |
muzaffar |
1.80 |
# The front-end wrapper and the script go at the installation root,
|
43 |
|
|
# not anywhere in the package tree. They must remain modifiable.
|
44 |
|
|
#
|
45 |
|
|
# We do the install ourselves, as "Installation/install_scram" would
|
46 |
|
|
# do, but putting the results elsewhere and using our own scram
|
47 |
|
|
# wrapper instead of using the supplied one -- mainly for easier
|
48 |
|
|
# override of SCRAM_LOOKUPDB; the wrapper is really rather simple so
|
49 |
|
|
# there is no point in trying to patch it.
|
50 |
|
|
#
|
51 |
argiro |
1.1 |
# FIXME: should we have more than one project database and link them
|
52 |
|
|
# together into one big one?
|
53 |
|
|
|
54 |
elmer |
1.71 |
%define cvsrepo cvs://:pserver:anonymous@cmscvs.cern.ch:/cvs_server/repositories/CMSSW?passwd=AA_:yZZ3e
|
55 |
muzaffar |
1.80 |
|
56 |
|
|
Source0: %{cvsrepo}&tag=-r%{v}&module=SCRAM&output=/source.tar.gz
|
57 |
muzaffar |
1.82 |
Patch: %n-%realversion
|
58 |
argiro |
1.1 |
|
59 |
|
|
%prep
|
60 |
|
|
%setup -n SCRAM
|
61 |
muzaffar |
1.82 |
%patch -p1
|
62 |
argiro |
1.1 |
%build
|
63 |
|
|
%install
|
64 |
|
|
tar -cf - . | tar -C %i -xvvf -
|
65 |
muzaffar |
1.80 |
rm -rf %i/cgi
|
66 |
|
|
mkdir -p %i/Installation %i/bin %i/etc/profile.d
|
67 |
muzaffar |
1.77 |
|
68 |
muzaffar |
1.80 |
cat Installation/scram.pl.in | sed -e "s|@PERLEXE@|/usr/bin/env perl|;s|@SCRAM_HOME@|%i|;s|@INSTALLDIR@|%i/src|" > %i/bin/scramv1
|
69 |
|
|
cat Installation/SCRAM_SITE.pm.in | sed -e "s|@SCRAM_HOME@|%i|;s|@SCRAM_LOOKUPDB_DIR@|%instroot/%cmsplatf/lcg/SCRAMV1/scramdb/|;s|@PERLEXE@|/usr/bin/env perl|;s|@TT2INSTALLDIR@|$TEMPLATE_TOOLKIT_ROOT/lib|;s|@SITETEMPLATEDIR@|%i/Templates|;s|@SCRAM_SITENAME@|STANDALONE|" > %i/Installation/SCRAM_SITE.pm
|
70 |
|
|
chmod 755 %i/bin/scramv1
|
71 |
|
|
cp %i/bin/scramv1 %i/src/main/scram.pl
|
72 |
|
|
|
73 |
|
|
echo $PERL5LIB > %i/etc/perl5lib.env
|
74 |
|
|
|
75 |
|
|
echo "#!/bin/sh" > %i/etc/profile.d/dependencies-setup.sh
|
76 |
|
|
echo "source $P5_TEMPLATE_TOOLKIT_ROOT/etc/profile.d/init.sh" >> %i/etc/profile.d/dependencies-setup.sh
|
77 |
|
|
echo "source $P5_URI_ROOT/etc/profile.d/init.sh" >> %i/etc/profile.d/dependencies-setup.sh
|
78 |
|
|
echo "source $P5_XML_PARSER_ROOT/etc/profile.d/init.sh" >> %i/etc/profile.d/dependencies-setup.sh
|
79 |
|
|
echo "source $P5_LIBWWW_PERL_ROOT/etc/profile.d/init.sh" >> %i/etc/profile.d/dependencies-setup.sh
|
80 |
|
|
|
81 |
|
|
echo "#!/bin/csh" > %i/etc/profile.d/dependencies-setup.csh
|
82 |
|
|
echo "source $P5_TEMPLATE_TOOLKIT_ROOT/etc/profile.d/init.csh" >> %i/etc/profile.d/dependencies-setup.csh
|
83 |
|
|
echo "source $P5_URI_ROOT/etc/profile.d/init.csh" >> %i/etc/profile.d/dependencies-setup.csh
|
84 |
|
|
echo "source $P5_XML_PARSER_ROOT/etc/profile.d/init.csh" >> %i/etc/profile.d/dependencies-setup.csh
|
85 |
|
|
echo "source $P5_LIBWWW_PERL_ROOT/etc/profile.d/init.csh" >> %i/etc/profile.d/dependencies-setup.csh
|
86 |
eulisse |
1.2 |
|
87 |
muzaffar |
1.80 |
perl -p -i -e "s|#!.*perl|#!/usr/bin/env perl|" %{i}/doc/doxygen/DoxyFilt.pl
|
88 |
eulisse |
1.7 |
|
89 |
eulisse |
1.5 |
%post
|
90 |
muzaffar |
1.80 |
%{relocateConfig}etc/perl5lib.env
|
91 |
|
|
%{relocateConfig}Installation/SCRAM_SITE.pm
|
92 |
|
|
%{relocateConfig}bin/scramv1
|
93 |
|
|
%{relocateConfig}src/main/scram.pl
|
94 |
|
|
%{relocateConfig}etc/profile.d/dependencies-setup.sh
|
95 |
|
|
%{relocateConfig}etc/profile.d/dependencies-setup.csh
|
96 |
|
|
# If and only if there is no default-scramv1 set the default to be the version we package in this spec.
|
97 |
|
|
OLD_VERSION=""
|
98 |
|
|
mkdir -p $RPM_INSTALL_PREFIX/%{cmsplatf}/etc
|
99 |
|
|
if [ -f $RPM_INSTALL_PREFIX/%{cmsplatf}/etc/default-scramv1-version ]
|
100 |
|
|
then
|
101 |
|
|
OLD_VERSION=`cat $RPM_INSTALL_PREFIX/%{cmsplatf}/etc/default-scramv1-version`
|
102 |
|
|
fi
|
103 |
|
|
NEW_VERSION=%v
|
104 |
|
|
(echo $OLD_VERSION;echo $NEW_VERSION) | sort | tail -1 > $RPM_INSTALL_PREFIX/%{cmsplatf}/etc/default-scramv1-version
|
105 |
muzaffar |
1.76 |
|
106 |
muzaffar |
1.80 |
mkdir -p $RPM_INSTALL_PREFIX/%cmsplatf/lcg/SCRAMV1/scramdb $RPM_INSTALL_PREFIX/share/scramdb
|
107 |
|
|
touch $RPM_INSTALL_PREFIX/%cmsplatf/lcg/SCRAMV1/scramdb/project.lookup $RPM_INSTALL_PREFIX/share/scramdb/project.lookup
|
108 |
|
|
dblinked=`grep "DB $RPM_INSTALL_PREFIX/share/scramdb/project.lookup" $RPM_INSTALL_PREFIX/%cmsplatf/lcg/SCRAMV1/scramdb/project.lookup`
|
109 |
|
|
if [ "X$dblinked" == "X" ] ; then
|
110 |
|
|
echo '!DB' $RPM_INSTALL_PREFIX/share/scramdb/project.lookup > $RPM_INSTALL_PREFIX/%cmsplatf/lcg/SCRAMV1/scramdb/project.lookup.link
|
111 |
|
|
cat $RPM_INSTALL_PREFIX/%cmsplatf/lcg/SCRAMV1/scramdb/project.lookup >> $RPM_INSTALL_PREFIX/%cmsplatf/lcg/SCRAMV1/scramdb/project.lookup.link
|
112 |
|
|
mv $RPM_INSTALL_PREFIX/%cmsplatf/lcg/SCRAMV1/scramdb/project.lookup.link $RPM_INSTALL_PREFIX/%cmsplatf/lcg/SCRAMV1/scramdb/project.lookup
|
113 |
muzaffar |
1.76 |
fi
|
114 |
eulisse |
1.55 |
|
115 |
argiro |
1.1 |
%files
|
116 |
|
|
%i
|