ViewVC Help
View File | Revision Log | Show Annotations | Root Listing
root/cvsroot/COMP/CMSDIST/SCRAMV1.spec
Revision: 1.93
Committed: Mon Jun 16 07:13:22 2008 UTC (16 years, 10 months ago) by muzaffar
Branch: MAIN
CVS Tags: nr080624_for21x, pe20080624a-for21X-412, pe20080624a-for21X, nr080623_for21x, pe20080623b-for21X-gp-412, pe20080623b-for21X-gp, pe20080623-for21X-gp, CMSSW_2_1_0_pre6, apFor210p6v0, pe20080616-for21X-412, pe20080616-for21X
Changes since 1.92: +1 -1 lines
Log Message:
SCRAM V2_0_2 tag which fixed the LOCALRT bug

File Contents

# User Rev Content
1 muzaffar 1.93 ### RPM lcg SCRAMV1 V2_0_2
2 elmer 1.71 ## INITENV +PATH PATH %instroot/common
3 eulisse 1.7
4 argiro 1.1 # This package is somewhat unusual compared to other packages we
5     # build: we install the normally versioned product "SCRAM", but also
6 muzaffar 1.87 # create the package database. The latter do not follow the
7     # standard versioning.
8 argiro 1.1 #
9     # The database is only created, but never changeed. It is made part
10     # of this package, but none of the files in it are included, so if
11     # the package is removed, the directory will left intact. (FIXME:
12     # check this is really so -- should we use %dir, or the default is
13     # good?)
14     #
15     # FIXME: should we have more than one project database and link them
16     # together into one big one?
17    
18 elmer 1.71 %define cvsrepo cvs://:pserver:anonymous@cmscvs.cern.ch:/cvs_server/repositories/CMSSW?passwd=AA_:yZZ3e
19 muzaffar 1.87 %define cvstag %v
20     Source0: %{cvsrepo}&tag=-r%{cvstag}&module=SCRAM&output=/source.tar.gz
21 argiro 1.1
22     %prep
23 muzaffar 1.87 #SCRAM version policy check
24     %define SCRAM_REL_SERIES %(echo %v | grep '^V[0-9]\\+_[0-9]\\+_[0-9]\\+' | sed 's|^\\(V[0-9]\\+_[0-9]\\+\\)_.*|\\1|')
25     if [ "X%{SCRAM_REL_SERIES}" == "X" ] ; then
26     echo "You are trying to build SCRAM version %v which does not follow the SCRAM version policy. Valid SCRAM versions should be of the form V[0-9]+_[0-9]+_[0-9].*"
27     exit 1
28     fi
29 argiro 1.1 %setup -n SCRAM
30     %build
31     %install
32     tar -cf - . | tar -C %i -xvvf -
33 muzaffar 1.92 mkdir -p %i/src/main %{i}/etc/profile.d
34 muzaffar 1.77
35 muzaffar 1.87 #SCRAM/INSTALL.txt recomendations
36     sed -i -e "s|@SCRAM_LOOKUPDB_DIR@|%instroot/%cmsplatf/lcg/SCRAMV1/scramdb/|g;s|@SCRAM_VERSION@|%v|g" %i/bin/scram
37     ln -s ../../bin/scram %i/src/main/scram.pl
38     chmod 755 %i/bin/scram
39 eulisse 1.2
40 muzaffar 1.87 %post
41     %{relocateConfig}bin/scram
42 eulisse 1.7
43 muzaffar 1.87 mkdir -p $RPM_INSTALL_PREFIX/%{cmsplatf}/etc/default-scram
44     # default version for SCRAM release series Vx_y_
45     VERSION_STR="%v"
46     if [ -f $RPM_INSTALL_PREFIX/%{cmsplatf}/etc/default-scram/%{SCRAM_REL_SERIES} ] ; then
47     VERSION_STR="$VERSION_STR `cat $RPM_INSTALL_PREFIX/%{cmsplatf}/etc/default-scram/%{SCRAM_REL_SERIES}`"
48     fi
49     echo $VERSION_STR | tr ' ' '\n' | sort | tail -1 > $RPM_INSTALL_PREFIX/%{cmsplatf}/etc/default-scram/%{SCRAM_REL_SERIES}
50     # default version in common
51     VERSION_STR="%v"
52     if [ -f $RPM_INSTALL_PREFIX/%{cmsplatf}/etc/default-scramv1-version ] ; then
53     VERSION_STR="$VERSION_STR `cat $RPM_INSTALL_PREFIX/%{cmsplatf}/etc/default-scramv1-version`"
54 muzaffar 1.80 fi
55 muzaffar 1.87 echo $VERSION_STR | tr ' ' '\n' | sort | tail -1 > $RPM_INSTALL_PREFIX/%{cmsplatf}/etc/default-scramv1-version
56 muzaffar 1.76
57 muzaffar 1.87 mkdir -p $RPM_INSTALL_PREFIX/%cmsplatf/lcg/SCRAMV1/scramdb
58     touch $RPM_INSTALL_PREFIX/%cmsplatf/lcg/SCRAMV1/scramdb/project.lookup
59     if [ -f $RPM_INSTALL_PREFIX/share/scramdb/project.lookup ] ; then
60     dblinked=`grep "DB $RPM_INSTALL_PREFIX/share/scramdb/project.lookup" $RPM_INSTALL_PREFIX/%cmsplatf/lcg/SCRAMV1/scramdb/project.lookup`
61     if [ "X$dblinked" = "X" ] ; then
62     echo '!DB' $RPM_INSTALL_PREFIX/share/scramdb/project.lookup > $RPM_INSTALL_PREFIX/%cmsplatf/lcg/SCRAMV1/scramdb/project.lookup.link
63     cat $RPM_INSTALL_PREFIX/%cmsplatf/lcg/SCRAMV1/scramdb/project.lookup >> $RPM_INSTALL_PREFIX/%cmsplatf/lcg/SCRAMV1/scramdb/project.lookup.link
64     mv $RPM_INSTALL_PREFIX/%cmsplatf/lcg/SCRAMV1/scramdb/project.lookup.link $RPM_INSTALL_PREFIX/%cmsplatf/lcg/SCRAMV1/scramdb/project.lookup
65     fi
66 muzaffar 1.76 fi
67 eulisse 1.55
68 argiro 1.1 %files
69     %i