Revision: | 1.17 |
Committed: | Fri Nov 7 08:34:43 2008 UTC (16 years, 5 months ago) by ngarcian |
Branch: | MAIN |
CVS Tags: | DBS-APP_20100122_slc4, DBS-APP_20100121_slc4, DBS-WEB_20100120_slc4, DBS-APP_20100120_slc4, DBS-APP_20100118_slc4, DBS-WEB_20100118_slc4, DBS-APP_20100114_slc4, DBS-WEB_20100113_slc4, DAS_20091202, FILEMOVER_20091118, DBS-APPS_20090929, pe20091117a-fromDAS_20090709, pe20091116b-fromDAS_20090709, pe20091116a-fromDAS_20090709, DAS_20091104, DBS-WEB_20091021, DAS_20091016, DAS_20091014, DBS-WEB_20091012, DBS-WEB_20090921, pe20090910-fromDAS_20090709, FILEMOVER_20090910, DBS-WEB_20090817, FILEMOVER_20090828, DBS-APPS_20090706, WEBTOOLS_APPS_20090817, DBS-APPS_20090804, DBS-APPS_20090730, DAS_20090709, DAS_20090607, DBS-WEB_20090618, DBS-APPS_20090619, DBS-APPS_20090608, DBS-APPS_20090604_1, DAS_20090604, DBS-APPS_20090604, DAS_20090603, DBS-APPS_20090603, DBS-APPS_20090528, condcore306, DBS_APPS_20090518, DAS_20090514_3, DAS_20090514_2, DAS_20090514_1, DAS_20090514, DBS-WEB_20090512, DBS-WEB_20090507, DBS_APPS_20090504, DBS_APPS_20090501, DBS-APPS_20090429_2, DBS-WEB_20090429, DBS-APPS_20090429, DBS-WEB_20090428, DBS-WEB_20090422, DBS-WEB_20090420, DBS-APPS_20090417, DBS-APPS_20090415, DBS-APPS_20090410, DAS_20090408, DBS-APPS_20090406, DAS_20090330, DBS-APPS_20090326, DAS_20090319_1, DBS-APPS_20090318, DBS-APPS_20090316, COUCHDB_20090313, DBS-APPS_20090310, WEBTOOLS-APPS_20090310_1, WEBTOOLS-APPS_20090310, WEBTOOLS-APPS_20090309, DBS-APPS_20090306, DBS-APPS_20090304_1, DBS-APPS_20090304, DBS-APPS_20090303_1, DBS-APPS_20090303, DBS-APPS_20090302, DBS-APPS_20090220_1, DBS-APPS_20090220, T0M_0_0_5, MEMCACHED_20090219_1, MEMCACHED_20090219, WEBTOOLS-APPS_20090217_1, WEBTOOLS-APPS_20090217, WEBTOOLS-APPS_20090216, zx20090216, condcore305, WEBTOOLS-APPS_20090212, WEBTOOLS-APPS_20090209_64bit, zx20090209, WEBTOOLS-APPS_20090206, T0M_0_0_4, T0M_0_0_3, WEBTOOLS-APPS_20090203_1, WEBTOOLS-APPS_20090203, T0M_0_0_2, zx20090201, WEBTOOLS-APPS_20090130, WEBTOOLS-APPS_20090129, PRODAGENT_0_12_10_pre3, PRODAGENT_0_12_10_pre2_20090127_V2, PRODAGENT_0_12_10_20090122, PRODAGENT_0_12_10_pre1_MISC, sw_20090115a, sw_20090115, testofc, T0Mon_081107_1 |
Changes since 1.16: | +2 -2 lines |
Log Message: | Updated to version 1.0.1 for tag T0Mon_081107_1 |
# | User | Rev | Content |
---|---|---|---|
1 | ngarcian | 1.17 | ### RPM cms T0Mon 1.0.1 |
2 | gowdy | 1.1 | ## INITENV +PATH PYTHONPATH %i/lib/python`echo $PYTHON_VERSION | cut -d. -f 1,2`/site-packages |
3 | %define moduleName WEBTOOLS | ||
4 | %define exportName WEBTOOLS | ||
5 | ngarcian | 1.17 | %define cvstag T0Mon_081107_1 |
6 | gowdy | 1.1 | %define cvsserver cvs://:pserver:anonymous@cmscvs.cern.ch:2401/cvs_server/repositories/CMSSW?passwd=AA_:yZZ3e |
7 | Source: %cvsserver&strategy=checkout&module=%{moduleName}&nocache=true&export=%{exportName}&tag=-r%{cvstag}&output=/%{moduleName}.tar.gz | ||
8 | gowdy | 1.5 | Requires: python cherrypy py2-sqlalchemy webtools |
9 | gowdy | 1.1 | %prep |
10 | %setup -n %{moduleName} | ||
11 | %build | ||
12 | |||
13 | rm -rf %i/etc/profile.d | ||
14 | mkdir -p %i/etc/profile.d | ||
15 | echo '#!/bin/sh' > %{i}/etc/profile.d/dependencies-setup.sh | ||
16 | echo '#!/bin/tcsh' > %{i}/etc/profile.d/dependencies-setup.csh | ||
17 | echo requiredtools `echo %{requiredtools} | sed -e's|\s+| |;s|^\s+||'` | ||
18 | for tool in `echo %{requiredtools} | sed -e's|\s+| |;s|^\s+||'` | ||
19 | do | ||
20 | case X$tool in | ||
21 | Xdistcc|Xccache ) | ||
22 | ;; | ||
23 | * ) | ||
24 | toolcap=`echo $tool | tr a-z- A-Z_` | ||
25 | eval echo ". $`echo ${toolcap}_ROOT`/etc/profile.d/init.sh" >> %{i}/etc/profile.d/dependencies-setup.sh | ||
26 | eval echo "source $`echo ${toolcap}_ROOT`/etc/profile.d/init.csh" >> %{i}/etc/profile.d/dependencies-setup.csh | ||
27 | ;; | ||
28 | esac | ||
29 | done | ||
30 | |||
31 | perl -p -i -e 's|\. /etc/profile\.d/init\.sh||' %{i}/etc/profile.d/dependencies-setup.sh | ||
32 | perl -p -i -e 's|source /etc/profile\.d/init\.csh||' %{i}/etc/profile.d/dependencies-setup.csh | ||
33 | |||
34 | %install | ||
35 | mkdir -p %i/etc | ||
36 | mkdir -p %i/bin | ||
37 | mkdir -p %i/lib/python`echo $PYTHON_VERSION | cut -d. -f1,2`/site-packages/Applications | ||
38 | cp -r Applications/T0Mon %i/lib/python`echo $PYTHON_VERSION | cut -d. -f1,2`/site-packages/Applications | ||
39 | mkdir -p %i/lib/python`echo $PYTHON_VERSION | cut -d. -f1,2`/site-packages/Applications/T0Mon/csv | ||
40 | |||
41 | %define pythonv %(echo $PYTHON_ROOT | cut -d. -f1,2) | ||
42 | %post | ||
43 | |||
44 | %{relocateConfig}etc/cherrypy.conf | ||
45 | %{relocateConfig}etc/apache2.conf | ||
46 | %{relocateConfig}etc/apache2-header.conf | ||
47 | %{relocateConfig}etc/apache2-footer.conf | ||
48 | %{relocateConfig}etc/profile.d/dependencies-setup.sh | ||
49 | %{relocateConfig}etc/profile.d/dependencies-setup.csh |