ViewVC Help
View File | Revision Log | Show Annotations | Root Listing
root/cvsroot/COMP/CMSDIST/apache.spec
Revision: 1.10
Committed: Wed Apr 18 23:46:01 2007 UTC (18 years ago) by ratnik
Branch: MAIN
Changes since 1.9: +2 -0 lines
Log Message:
Changes for building  externals in 64/32 mode: added gcc-wrapper .

File Contents

# User Rev Content
1 steen 1.9 ### RPM external apache 2.0.59
2 ratnik 1.10 Requires: gcc-wrapper
3 eulisse 1.1 %define downloadn httpd
4 steen 1.9 Source: http://apache.osuosl.org/httpd/httpd-%v.tar.gz
5     Requires: zlib openssl expat
6 eulisse 1.1 %prep
7     %setup -n %{downloadn}-%{v}
8    
9     %build
10 ratnik 1.10 ## IMPORT gcc-wrapper
11 steen 1.9 ./configure CFLAGS="-I$EXPAT_ROOT/include" \
12     LDFLAGS="-L$EXPAT_ROOT/lib" \
13     --prefix=%{i} \
14 eulisse 1.1 --with-z=$LIBZ_ROOT \
15 steen 1.4 --with-ssl=$OPENSSL_ROOT \
16     --enable-ssl \
17     --enable-rewrite \
18     --enable-so
19 steen 1.7
20     mkdir -p %i/conf.d
21    
22 eulisse 1.1 make %makeprocesses
23 steen 1.7 %install
24     %initenv
25     mkdir -p %{i}
26     true || exit 0
27     make install
28    
29 steen 1.8 echo 'Include '"%i/conf.d/"'*.conf' >> \
30     %i/conf/httpd.conf
31 steen 1.7
32    
33 eulisse 1.6 %post
34     %{relocateConfig}conf/highperformance.conf
35     %{relocateConfig}conf/highperformance-std.conf
36     %{relocateConfig}conf/httpd.conf
37     %{relocateConfig}conf/httpd-std.conf
38     %{relocateConfig}conf/ssl.conf
39     %{relocateConfig}conf/ssl-std.conf
40     %{relocateConfig}include/ap_config_auto.h
41     %{relocateConfig}include/ap_config_layout.h
42     %{relocateConfig}bin/apachectl
43     %{relocateConfig}bin/apr-config
44     %{relocateConfig}bin/apu-config
45     %{relocateConfig}bin/apxs
46     %{relocateConfig}bin/envvars
47     %{relocateConfig}bin/envvars-std