1 |
steen |
1.5 |
### RPM external apache 2.0.55
|
2 |
eulisse |
1.1 |
%define downloadn httpd
|
3 |
|
|
Source: http://mirror1.zic-network.ch/apache/%{downloadn}/%{downloadn}-%{v}.tar.gz
|
4 |
steen |
1.5 |
Requires: zlib openssl
|
5 |
eulisse |
1.1 |
%prep
|
6 |
|
|
%setup -n %{downloadn}-%{v}
|
7 |
|
|
|
8 |
|
|
%build
|
9 |
|
|
./configure --prefix=%{i} \
|
10 |
|
|
--with-z=$LIBZ_ROOT \
|
11 |
steen |
1.4 |
--with-ssl=$OPENSSL_ROOT \
|
12 |
|
|
--enable-ssl \
|
13 |
|
|
--enable-rewrite \
|
14 |
|
|
--enable-so
|
15 |
steen |
1.7 |
|
16 |
|
|
mkdir -p %i/conf.d
|
17 |
|
|
|
18 |
eulisse |
1.1 |
make %makeprocesses
|
19 |
steen |
1.7 |
%install
|
20 |
|
|
%initenv
|
21 |
|
|
mkdir -p %{i}
|
22 |
|
|
true || exit 0
|
23 |
|
|
|
24 |
|
|
|
25 |
|
|
make install
|
26 |
|
|
|
27 |
|
|
|
28 |
|
|
mkdir -p %i/conf.d
|
29 |
|
|
|
30 |
|
|
#--------------------------------------------------------------------
|
31 |
|
|
mkdir -p %i/etc/profile.d
|
32 |
|
|
cat << DEPS_SETUP > %i/etc/profile.d/dependencies-setup.sh
|
33 |
|
|
#!/bin/sh
|
34 |
|
|
|
35 |
|
|
temp_line=\$(grep 'Include[ \t]*[^ ]*/conf.d/\*.conf' \
|
36 |
|
|
\$APACHE_ROOT/conf/httpd.conf)
|
37 |
|
|
|
38 |
|
|
if [ -z "\$temp_line" ]
|
39 |
|
|
then
|
40 |
|
|
echo "Inserting Include statement"
|
41 |
|
|
echo 'Include '"\$APACHE_ROOT/conf.d/"'*.conf' >> \
|
42 |
|
|
\$APACHE_ROOT/conf/httpd.conf
|
43 |
|
|
fi
|
44 |
|
|
|
45 |
|
|
DEPS_SETUP
|
46 |
|
|
|
47 |
eulisse |
1.6 |
%post
|
48 |
|
|
%{relocateConfig}conf/highperformance.conf
|
49 |
|
|
%{relocateConfig}conf/highperformance-std.conf
|
50 |
|
|
%{relocateConfig}conf/httpd.conf
|
51 |
|
|
%{relocateConfig}conf/httpd-std.conf
|
52 |
|
|
%{relocateConfig}conf/ssl.conf
|
53 |
|
|
%{relocateConfig}conf/ssl-std.conf
|
54 |
|
|
%{relocateConfig}include/ap_config_auto.h
|
55 |
|
|
%{relocateConfig}include/ap_config_layout.h
|
56 |
|
|
%{relocateConfig}bin/apachectl
|
57 |
|
|
%{relocateConfig}bin/apr-config
|
58 |
|
|
%{relocateConfig}bin/apu-config
|
59 |
|
|
%{relocateConfig}bin/apxs
|
60 |
|
|
%{relocateConfig}bin/envvars
|
61 |
|
|
%{relocateConfig}bin/envvars-std
|