ViewVC Help
View File | Revision Log | Show Annotations | Root Listing
root/cvsroot/COMP/CMSDIST/boost.spec
Revision: 1.17
Committed: Tue Jun 26 10:49:30 2007 UTC (17 years, 10 months ago) by elmer
Branch: MAIN
CVS Tags: pe20070626c-ports, pe20070626b-ports
Changes since 1.16: +12 -16 lines
Log Message:
Fix python version passed to boost build (take account of "-XXXX" part
representing a CMS rebuild in the version string in the rpm spec file)

File Contents

# User Rev Content
1 elmer 1.17 ### RPM external boost 1.33.1-XXXX
2 argiro 1.1 # Patches and build fudging by Lassi A. Tuura <lat@iki.fi> (FIXME: contribute to boost)
3 elmer 1.17 %define boostver _%(echo %realversion | tr . _)
4 eulisse 1.8 Requires: boost-build python bz2lib zlib
5 argiro 1.2 Source: http://dl.sourceforge.net/sourceforge/%n/%{n}%{boostver}.tar.gz
6 argiro 1.1
7     %prep
8     %setup -n %{n}%{boostver}
9    
10     %build
11     # Note that some targets will fail to build (the test programs have
12     # missing symbols), causing darwin to fail to link and bjam to return
13     # an error. So ignore the exit code from bjam on darwin to avoid
14     # RPM falsely detecting a problem.
15     PR="PYTHON_ROOT=$PYTHON_ROOT"
16 elmer 1.17 #PV="PYTHON_VERSION=$(echo $PYTHON_VERSION | sed 's/\.[0-9]*$//')"
17     # The following line assumes a version of the form x.y.z-XXXX, where the
18     # "-XXXX" part represents some CMS rebuild of version x.y.z
19     PV="PYTHON_VERSION=$(echo $PYTHON_VERSION | sed 's/\.[0-9]*-.*$//')"
20     BZ2LIBR="BZIP2_LIBPATH=$BZ2LIB_ROOT/lib"
21 eulisse 1.8 ZLIBR="ZLIB_LIBPATH=$ZLIB_ROOT/lib"
22 elmer 1.17 BZ2LIBI="BZIP2_INCLUDE=$BZ2LIB_ROOT/include"
23 eulisse 1.8 ZLIBI="ZLIB_INCLUDE=$ZLIB_ROOT/include"
24    
25 argiro 1.1 case $(uname) in
26 eulisse 1.8 Darwin ) bjam -s$PR -s$PV -s$BZ2LIBR -s$ZLIBR -sTOOLS=darwin || true ;;
27     * ) bjam -s$PR -s$PV -s$BZ2LIBR -s$ZLIBR -sTOOLS=gcc ;;
28 argiro 1.1 esac
29    
30     %install
31 eulisse 1.6 boost_abi=$(echo %boostver | sed 's/^_//; s/_0$//')
32 argiro 1.1 case $(uname) in Darwin ) so=dylib ;; * ) so=so ;; esac
33     mkdir -p %i/lib/debug
34     (cd bin/boost; find libs -path "libs/*/debug/*.$so" -exec cp {} %i/lib/debug \;)
35     (cd bin/boost; find libs -path "libs/*/release/*.$so" -exec cp {} %i/lib \;)
36 eulisse 1.7 find boost -name '*.[hi]*' -print |
37 argiro 1.1 while read f; do
38     mkdir -p %i/include/$(dirname $f)
39     install -c $f %i/include/$f
40     done
41     find libs -name '*.py' -print |
42     while read f; do
43     mkdir -p %i/lib/$(dirname $f)
44     install -c $f %i/lib/$f
45     done
46     [ $(uname) = Darwin ] &&
47     for f in %i/lib/*.$so %i/lib/debug/*.$so; do
48     install_name_tool -id $f $f
49     done
50 eulisse 1.6
51 argiro 1.1 (cd %i/lib; for f in lib*-$boost_abi.$so; do ln -s $f $(echo $f | sed "s/-$boost_abi//"); done)
52 elmer 1.17 (cd %i/lib; for f in lib*-$boost_abi.$so; do ln -s $f $f.%realversion ; done)
53 argiro 1.1 (cd %i/lib/debug; for f in lib*-d-$boost_abi.$so; do ln -s $f $(echo $f | sed "s/-d-$boost_abi//"); done)
54 elmer 1.17 (cd %i/lib/debug; for f in lib*-d-$boost_abi.$so; do ln -s $f $f.%realversion; done)
55 eulisse 1.4 (cd %i/lib/libs/python/pyste/install; python setup.py install --prefix=%i)
56 ratnik 1.16
57 elmer 1.17 perl -p -i -e "s|^#!.*python|/usr/bin/env python|" $(find %{i}/lib %{i}/bin)
58