ViewVC Help
View File | Revision Log | Show Annotations | Root Listing
root/cvsroot/COMP/CMSDIST/boost.spec
Revision: 1.62
Committed: Fri Jun 24 08:12:39 2011 UTC (13 years, 10 months ago) by lat
Branch: MAIN
CVS Tags: builder_2011-09-13_22-04-02_filemover, builder_2011-09-06_16-09-09_stagemanager-agent, builder_2011-09-06_15-53-16_stagemanager-agent, builder_2011-08-27_00-05-05_asyncstageout, builder_2011-08-26_19-05-27_crab-server3, builder_2011-08-16_12-09-37_cmsweb, HG1108b, builder_2011-08-12_22-56-45_cmsweb, builder_2011-08-09_17-03-37_dbs-server, builder_2011-08-09_14-45-47_dbs-client, builder_2011-08-08_23-23-23_dbs-server, DBS_2_1_6-pre5, DBS_2_1_6-pre4, TW20110808a, DBS_2_1_6-pre3, builder_2011-08-04_18-42-50_stagemanager-agent, builder_2011-08-04_17-25-36_das, builder_2011-08-04_13-25-47_cmsweb, builder_2011-08-02_16-19-02_wmagent, TW20110729a, builder_2011-07-28_21-25-51_dbs-server, builder_2011-07-28_21-25-43_dbs-client, DBS_2_1_6-pre2, TW20110728d, TW20110728c, TW20110728b, TW20110728a, builder_2011-07-28_00-46-23_cmsweb, DBS_2_1_6-pre1, builder_2011-07-27_18-04-14_reqmgr, HG1108a, TW20110727a, TW20110726a, builder_2011-07-20_14-45-50_wmagent, builder_2011-07-18_15-32-58_wmagent, builder_2011-07-14_18-33-29_asyncstageout, builder_2011-07-13_17-03-17_stagemanager-agent, builder_2011-07-13_16-55-50_stagemanager-agent, builder_2011-07-13_16-52-30_wmagent, builder_2011-07-13_09-48-46_crab-server3, builder_2011-07-11_12-04-16_cmsweb, builder_2011-07-11_11-53-31_cmsweb, HG1107c, HG1108a-osx, builder_2011-07-08_16-07-44_cmsweb, TW20110707b, TW20110707a, builder_2011-07-05_11-26-58_cmsweb, HG1107b, builder_2011-07-04_15-53-33_cmsweb, TW20110704b, builder_2011-07-04_12-54-16_stagemanager, TW20110704a, builder_2011-07-02_17-25-15_dbs3-client, TW20110701a, builder_2011-07-01_14-15-56_cmsweb, builder_2011-07-01_12-35-36_cmsweb, builder_2011-06-30_17-06-37_crab-server3, builder_2011-06-29_20-56-28_cmsweb, TW20110629a, TW20110628a, TW20110627b, builder_2011-06-24_21-18-43_cmsweb, builder_2011-06-24_15-28-33_workqueue, HG1107a, lat20110624a
Changes since 1.61: +1 -2 lines
Log Message:
Replace %closingbrace with balanced parentheses in "case".

File Contents

# User Rev Content
1 elmer 1.61 ### RPM external boost 1.46.0
2 elmer 1.17 %define boostver _%(echo %realversion | tr . _)
3 elmer 1.58 Source: http://switch.dl.sourceforge.net/project/%{n}/%{n}/%{v}/%{n}%{boostver}.tar.gz
4 lat 1.62 %define online %(case %cmsplatf in (*onl_*_*) echo true;; (*) echo false;; esac)
5 argiro 1.1
6 ratnik 1.25 Requires: boost-build python bz2lib
7 muzaffar 1.45 %if "%online" != "true"
8 ratnik 1.25 Requires: zlib
9     %endif
10    
11 argiro 1.1 %prep
12     %setup -n %{n}%{boostver}
13    
14     %build
15 ratnik 1.25 PV="PYTHON_VERSION=$(echo $PYTHON_VERSION | sed 's/\.[0-9]*-.*$//')"
16 argiro 1.1 PR="PYTHON_ROOT=$PYTHON_ROOT"
17 ratnik 1.25
18 elmer 1.17 # The following line assumes a version of the form x.y.z-XXXX, where the
19     # "-XXXX" part represents some CMS rebuild of version x.y.z
20     BZ2LIBR="BZIP2_LIBPATH=$BZ2LIB_ROOT/lib"
21 ratnik 1.25 BZ2LIBI="BZIP2_INCLUDE=$BZ2LIB_ROOT/include"
22    
23 muzaffar 1.45 %if "%online" != "true"
24 eulisse 1.8 ZLIBR="ZLIB_LIBPATH=$ZLIB_ROOT/lib"
25     ZLIBI="ZLIB_INCLUDE=$ZLIB_ROOT/include"
26    
27 argiro 1.1 case $(uname) in
28 dsr 1.51 Darwin ) bjam %makeprocesses -s$PR -s$PV -s$BZ2LIBR -s$ZLIBR toolset=darwin stage;;
29     * ) bjam %makeprocesses -s$PR -s$PV -s$BZ2LIBR -s$ZLIBR toolset=gcc stage;;
30 argiro 1.1 esac
31 ratnik 1.25 %else
32 dsr 1.51 bjam %makeprocesses -s$PR -s$PV -s$BZ2LIBR -s$BZ2LIBI toolset=gcc stage
33 ratnik 1.25 %endif
34 argiro 1.1
35     %install
36     case $(uname) in Darwin ) so=dylib ;; * ) so=so ;; esac
37 eulisse 1.52 mkdir -p %i/lib %i/include
38     # copy files around in their final location.
39     # We use tar to reduce the number of processes required
40     # and because we need to build the build hierarchy for
41     # the files that we are copying.
42     pushd stage/lib
43     find . -name "*.$so*" -type f | tar cf - -T - | (cd %i/lib; tar xfp -)
44     popd
45     find boost -name '*.[hi]*' | tar cf - -T - | ( cd %i/include; tar xfp -)
46 ratnik 1.19
47 eulisse 1.42 for l in `find %i/lib -name "*.$so.*"`
48     do
49     ln -s `basename $l` `echo $l | sed -e "s|[.]$so[.].*|.$so|"`
50     done
51 ratnik 1.31
52 eulisse 1.52 pushd libs/python/pyste/install
53     python setup.py install --prefix=%i
54     popd
55    
56     # Do all manipulation with files before creating symbolic links:
57     perl -p -i -e "s|^#!.*python|/usr/bin/env python|" $(find %{i}/lib %{i}/bin -type f)
58 ratnik 1.16
59 diego 1.59 # Generate dependencies-setup.{sh,csh} so init.{sh,csh} picks full environment.
60 diego 1.54 mkdir -p %i/etc/profile.d
61 diego 1.59 : > %i/etc/profile.d/dependencies-setup.sh
62     : > %i/etc/profile.d/dependencies-setup.csh
63     for tool in $(echo %{requiredtools} | sed -e's|\s+| |;s|^\s+||'); do
64     root=$(echo $tool | tr a-z- A-Z_)_ROOT; eval r=\$$root
65     if [ X"$r" != X ] && [ -r "$r/etc/profile.d/init.sh" ]; then
66     echo "test X\$$root != X || . $r/etc/profile.d/init.sh" >> %i/etc/profile.d/dependencies-setup.sh
67     echo "test X\$$root != X || source $r/etc/profile.d/init.csh" >> %i/etc/profile.d/dependencies-setup.csh
68     fi
69 diego 1.54 done
70 diego 1.53
71 muzaffar 1.21 %post
72 diego 1.59 %{relocateConfig}etc/profile.d/dependencies-setup.*sh