ViewVC Help
View File | Revision Log | Show Annotations | Root Listing
root/cvsroot/COMP/CMSDIST/boost.spec
Revision: 1.63
Committed: Mon Aug 22 15:24:00 2011 UTC (13 years, 8 months ago) by eulisse
Branch: MAIN
CVS Tags: TW20120302a, bld_1320341101_PHEDEX-combined-agents_slc5_amd64_gcc434, bld_1320248863_PHEDEX-combined-agents_slc5_amd64_gcc434, TW20111010c, TW20111010b, TW20111010a, builder_2011-10-04_16-25-49_das, builder_2011-09-30_15-50-42_PHEDEX-combined-agents, builder_2011-09-29_09-05-43_crab-server3, builder_2011-09-29_09-05-42_asyncstageout, builder_2011-09-29_05-49-40_wmagent, builder_2011-09-28_19-05-55_PHEDEX-combined-agents, builder_2011-09-28_16-45-33_das, builder_2011-09-28_16-05-45_das, TW20110928b, TW20110928a, builder_2011-09-27_17-51-30_reqmon, builder_2011-09-23_12-09-06_wmagent, builder_2011-09-22_12-03-59_asyncstageout, builder_2011-09-22_11-25-57_crab-server3, builder_2011-09-22_11-24-38_asyncstageout, builder_2011-09-22_05-26-44_wmagent, builder_2011-09-21_18-06-30_asyncstageout, builder_2011-09-21_15-26-46_wmagent, builder_2011-09-21_12-53-09_crab-server3, builder_2011-09-21_12-53-09_asyncstageout, builder_2011-09-21_12-47-08_crab-server3, builder_2011-09-21_12-45-23_asyncstageout, builder_2011-09-20_21-03-55_regsvc, builder_2011-09-15_17-45-48_PHEDEX-combined-agents, TW20110913b, TW20110913a, TW20110911a, TW20110909d, TW20110909c, builder_2011-09-09_17-05-31_dbs3-client, TW20110909b, TW20110909a, builder_2011-09-08_22-46-50_reqmgr, HG1109b, builder_2011-09-07_19-00-35_cmsweb, builder_2011-09-06_22-45-07_globalmonitor, builder_2011-09-01_12-14-12_wmagent, HG1109a, builder_2011-08-29_19-08-40_cmsweb, az20110825-50X-ports, az20110825-50X
Changes since 1.62: +19 -13 lines
Log Message:
Updated to boost 1.47.00

File Contents

# User Rev Content
1 eulisse 1.63 ### RPM external boost 1.47.0
2 elmer 1.17 %define boostver _%(echo %realversion | tr . _)
3 elmer 1.58 Source: http://switch.dl.sourceforge.net/project/%{n}/%{n}/%{v}/%{n}%{boostver}.tar.gz
4 lat 1.62 %define online %(case %cmsplatf in (*onl_*_*) echo true;; (*) echo false;; esac)
5 argiro 1.1
6 eulisse 1.63 Requires: python bz2lib
7 muzaffar 1.45 %if "%online" != "true"
8 ratnik 1.25 Requires: zlib
9     %endif
10    
11 argiro 1.1 %prep
12     %setup -n %{n}%{boostver}
13    
14     %build
15 eulisse 1.63 case %cmsos in
16     osx*) TOOLSET=darwin ;;
17     *) TOOLSET=gcc ;;
18     esac
19    
20     pushd tools/build/v2
21    
22     sh bootstrap.sh $TOOLSET
23     popd
24    
25 ratnik 1.25 PV="PYTHON_VERSION=$(echo $PYTHON_VERSION | sed 's/\.[0-9]*-.*$//')"
26 argiro 1.1 PR="PYTHON_ROOT=$PYTHON_ROOT"
27 ratnik 1.25
28 elmer 1.17 # The following line assumes a version of the form x.y.z-XXXX, where the
29     # "-XXXX" part represents some CMS rebuild of version x.y.z
30     BZ2LIBR="BZIP2_LIBPATH=$BZ2LIB_ROOT/lib"
31 ratnik 1.25 BZ2LIBI="BZIP2_INCLUDE=$BZ2LIB_ROOT/include"
32    
33 eulisse 1.63 if [ ! X%online = "Xtrue" ]
34     then
35     ZLIBR="ZLIB_LIBPATH=$ZLIB_ROOT/lib"
36     ZLIBI="ZLIB_INCLUDE=$ZLIB_ROOT/include"
37     fi
38 eulisse 1.8
39 eulisse 1.63 tools/build/v2/bjam %makeprocesses -s$PR -s$PV -s$BZ2LIBR -s$BZ2LIBI ${ZLIBR+-s$ZLIBR} ${ZLIBI+-s$ZLIBI} toolset=$TOOLSET stage
40 argiro 1.1
41     %install
42 eulisse 1.63 case %cmsos in osx*) so=dylib ;; *) so=so ;; esac
43 eulisse 1.52 mkdir -p %i/lib %i/include
44     # copy files around in their final location.
45     # We use tar to reduce the number of processes required
46     # and because we need to build the build hierarchy for
47     # the files that we are copying.
48     pushd stage/lib
49     find . -name "*.$so*" -type f | tar cf - -T - | (cd %i/lib; tar xfp -)
50     popd
51     find boost -name '*.[hi]*' | tar cf - -T - | ( cd %i/include; tar xfp -)
52 ratnik 1.19
53 eulisse 1.42 for l in `find %i/lib -name "*.$so.*"`
54     do
55     ln -s `basename $l` `echo $l | sed -e "s|[.]$so[.].*|.$so|"`
56     done
57 ratnik 1.31
58 eulisse 1.52 pushd libs/python/pyste/install
59     python setup.py install --prefix=%i
60     popd
61    
62     # Do all manipulation with files before creating symbolic links:
63     perl -p -i -e "s|^#!.*python|/usr/bin/env python|" $(find %{i}/lib %{i}/bin -type f)
64 ratnik 1.16
65 diego 1.59 # Generate dependencies-setup.{sh,csh} so init.{sh,csh} picks full environment.
66 diego 1.54 mkdir -p %i/etc/profile.d
67 diego 1.59 : > %i/etc/profile.d/dependencies-setup.sh
68     : > %i/etc/profile.d/dependencies-setup.csh
69     for tool in $(echo %{requiredtools} | sed -e's|\s+| |;s|^\s+||'); do
70     root=$(echo $tool | tr a-z- A-Z_)_ROOT; eval r=\$$root
71     if [ X"$r" != X ] && [ -r "$r/etc/profile.d/init.sh" ]; then
72     echo "test X\$$root != X || . $r/etc/profile.d/init.sh" >> %i/etc/profile.d/dependencies-setup.sh
73     echo "test X\$$root != X || source $r/etc/profile.d/init.csh" >> %i/etc/profile.d/dependencies-setup.csh
74     fi
75 diego 1.54 done
76 diego 1.53
77 muzaffar 1.21 %post
78 diego 1.59 %{relocateConfig}etc/profile.d/dependencies-setup.*sh