ViewVC Help
View File | Revision Log | Show Annotations | Root Listing
root/cvsroot/COMP/CMSDIST/boost.spec
Revision: 1.20
Committed: Fri Aug 24 20:35:00 2007 UTC (17 years, 8 months ago) by dlange
Branch: MAIN
CVS Tags: CMSSW_1_7_0_pre1, dl070829, dl070828t2, dl070828, dl070827, dl070826, dl070824
Changes since 1.19: +9 -7 lines
Log Message:
remove debug libs from boost

File Contents

# User Rev Content
1 dlange 1.20 ### RPM external boost 1.33.1-CMS4
2 argiro 1.1 # Patches and build fudging by Lassi A. Tuura <lat@iki.fi> (FIXME: contribute to boost)
3 elmer 1.17 %define boostver _%(echo %realversion | tr . _)
4 eulisse 1.8 Requires: boost-build python bz2lib zlib
5 argiro 1.2 Source: http://dl.sourceforge.net/sourceforge/%n/%{n}%{boostver}.tar.gz
6 argiro 1.1
7     %prep
8     %setup -n %{n}%{boostver}
9    
10     %build
11     # Note that some targets will fail to build (the test programs have
12     # missing symbols), causing darwin to fail to link and bjam to return
13     # an error. So ignore the exit code from bjam on darwin to avoid
14     # RPM falsely detecting a problem.
15     PR="PYTHON_ROOT=$PYTHON_ROOT"
16 elmer 1.17 #PV="PYTHON_VERSION=$(echo $PYTHON_VERSION | sed 's/\.[0-9]*$//')"
17     # The following line assumes a version of the form x.y.z-XXXX, where the
18     # "-XXXX" part represents some CMS rebuild of version x.y.z
19     PV="PYTHON_VERSION=$(echo $PYTHON_VERSION | sed 's/\.[0-9]*-.*$//')"
20     BZ2LIBR="BZIP2_LIBPATH=$BZ2LIB_ROOT/lib"
21 eulisse 1.8 ZLIBR="ZLIB_LIBPATH=$ZLIB_ROOT/lib"
22 elmer 1.17 BZ2LIBI="BZIP2_INCLUDE=$BZ2LIB_ROOT/include"
23 eulisse 1.8 ZLIBI="ZLIB_INCLUDE=$ZLIB_ROOT/include"
24    
25 argiro 1.1 case $(uname) in
26 eulisse 1.8 Darwin ) bjam -s$PR -s$PV -s$BZ2LIBR -s$ZLIBR -sTOOLS=darwin || true ;;
27     * ) bjam -s$PR -s$PV -s$BZ2LIBR -s$ZLIBR -sTOOLS=gcc ;;
28 argiro 1.1 esac
29    
30     %install
31 eulisse 1.6 boost_abi=$(echo %boostver | sed 's/^_//; s/_0$//')
32 argiro 1.1 case $(uname) in Darwin ) so=dylib ;; * ) so=so ;; esac
33 dlange 1.20 #no debug libs...
34     #mkdir -p %i/lib/debug
35     mkdir %i/lib
36     #(cd bin/boost; find libs -path "libs/*/debug/*.$so" -exec cp {} %i/lib/debug \;)
37     (cd bin/boost; find libs -path "libs/*/release/*.$so" -exec cp {} %i/lib/. \;)
38 eulisse 1.7 find boost -name '*.[hi]*' -print |
39 argiro 1.1 while read f; do
40     mkdir -p %i/include/$(dirname $f)
41     install -c $f %i/include/$f
42     done
43     find libs -name '*.py' -print |
44     while read f; do
45     mkdir -p %i/lib/$(dirname $f)
46     install -c $f %i/lib/$f
47     done
48     [ $(uname) = Darwin ] &&
49     for f in %i/lib/*.$so %i/lib/debug/*.$so; do
50     install_name_tool -id $f $f
51     done
52 eulisse 1.6
53 ratnik 1.19 # Do all manipulation with files before creating symbolic links:
54     perl -p -i -e "s|^#!.*python|/usr/bin/env python|" $(find %{i}/lib %{i}/bin)
55 dlange 1.20 strip %i/lib/*.$so
56 ratnik 1.19
57 argiro 1.1 (cd %i/lib; for f in lib*-$boost_abi.$so; do ln -s $f $(echo $f | sed "s/-$boost_abi//"); done)
58 elmer 1.17 (cd %i/lib; for f in lib*-$boost_abi.$so; do ln -s $f $f.%realversion ; done)
59 dlange 1.20 #(cd %i/lib/debug; for f in lib*-d-$boost_abi.$so; do ln -s $f $(echo $f | sed "s/-d-$boost_abi//"); done)
60     #(cd %i/lib/debug; for f in lib*-d-$boost_abi.$so; do ln -s $f $f.%realversion; done)
61 eulisse 1.4 (cd %i/lib/libs/python/pyste/install; python setup.py install --prefix=%i)
62 ratnik 1.16