Revision: | 1.18 |
Committed: | Wed Jun 27 12:50:44 2007 UTC (17 years, 10 months ago) by elmer |
Branch: | MAIN |
CVS Tags: | nr20071011-bootstrap, nr20070926-bootstrap, ap-20070925, CMSSW_1_6_1, CMSSW_1_6_1_pre1, CMSSW_1_6_0, CMSSW_1_6_0_pre14, pe20070831d-160p14, pe20070831c-160p14, pe20070831b-160p14, pe20070831a-160p14, pe20070830a-160p14, CMSSW_1_6_0_DAQ3, CMSSW_1_6_0_pre13, pe20070826a-160p13, CMSSW_1_6_0_pre12, pe20070824b-160p12, pe20070824-160p12, pe20070823-160p12, CMSSW_1_6_0_pre11, CMSSW_1_6_0_pre10, ge20070810-ptc, CMSSW_1_6_0_pre9, CMSSW_1_6_0_pre8, CMSSW_1_6_0_pre7, dl070730, cms160daq1_zhen2, cms160daq1_zhen1, ge20070730-cmsbuild, ge20070729-amd64, CMSSW_1_6_0_pre6, pe20070727-160p6, CMSSW_1_6_0_DAQ1, ge20070726, ge20070724-slc3, ap20070723, CMSSW_1_6_0_pre5, dl070721, dl070720_160daq1_1, pe20070720-160daq1, pe20070720-160p5, ge20070718, ge20070717, ap20070717, ge20070713-macosx, ap20070712, ge20070712-migration, ge20070712, ge20070711-prodcommon, CMSSW_1_6_0_pre4, ge20070710-formencode, ge20070709-slc3, ge20070709-macosx, ge20070709a-macosx, ge20070706-macosx, ap20070706, CMSSW_1_6_0_pre3, pe20070705a-160p3, CMSSW_1_6_0_pre2, ge20070705, ge20070704, ge20070703b, pe20070702b-160p3, pe20070702b-160p2, ge20070702-rpm-webtools, CMSSW_1_6_0_pre1, pe20070729b-160p2, pe20070729b-160p1, pe20070729a-160p2, pe20070729a-160p1, pe20070629a-ports, pe20070628e-ports, pe20070628d-ports, pe20070628c-ports, pe20070628b-ports, pe20070628a-ports, pe20070627b-ports, pe20070627a-ports |
Changes since 1.17: | +1 -1 lines |
Log Message: | Update to -CMS3 for full rebuild |
# | User | Rev | Content |
---|---|---|---|
1 | elmer | 1.18 | ### RPM external boost 1.33.1-CMS3 |
2 | argiro | 1.1 | # Patches and build fudging by Lassi A. Tuura <lat@iki.fi> (FIXME: contribute to boost) |
3 | elmer | 1.17 | %define boostver _%(echo %realversion | tr . _) |
4 | eulisse | 1.8 | Requires: boost-build python bz2lib zlib |
5 | argiro | 1.2 | Source: http://dl.sourceforge.net/sourceforge/%n/%{n}%{boostver}.tar.gz |
6 | argiro | 1.1 | |
7 | %prep | ||
8 | %setup -n %{n}%{boostver} | ||
9 | |||
10 | %build | ||
11 | # Note that some targets will fail to build (the test programs have | ||
12 | # missing symbols), causing darwin to fail to link and bjam to return | ||
13 | # an error. So ignore the exit code from bjam on darwin to avoid | ||
14 | # RPM falsely detecting a problem. | ||
15 | PR="PYTHON_ROOT=$PYTHON_ROOT" | ||
16 | elmer | 1.17 | #PV="PYTHON_VERSION=$(echo $PYTHON_VERSION | sed 's/\.[0-9]*$//')" |
17 | # The following line assumes a version of the form x.y.z-XXXX, where the | ||
18 | # "-XXXX" part represents some CMS rebuild of version x.y.z | ||
19 | PV="PYTHON_VERSION=$(echo $PYTHON_VERSION | sed 's/\.[0-9]*-.*$//')" | ||
20 | BZ2LIBR="BZIP2_LIBPATH=$BZ2LIB_ROOT/lib" | ||
21 | eulisse | 1.8 | ZLIBR="ZLIB_LIBPATH=$ZLIB_ROOT/lib" |
22 | elmer | 1.17 | BZ2LIBI="BZIP2_INCLUDE=$BZ2LIB_ROOT/include" |
23 | eulisse | 1.8 | ZLIBI="ZLIB_INCLUDE=$ZLIB_ROOT/include" |
24 | |||
25 | argiro | 1.1 | case $(uname) in |
26 | eulisse | 1.8 | Darwin ) bjam -s$PR -s$PV -s$BZ2LIBR -s$ZLIBR -sTOOLS=darwin || true ;; |
27 | * ) bjam -s$PR -s$PV -s$BZ2LIBR -s$ZLIBR -sTOOLS=gcc ;; | ||
28 | argiro | 1.1 | esac |
29 | |||
30 | %install | ||
31 | eulisse | 1.6 | boost_abi=$(echo %boostver | sed 's/^_//; s/_0$//') |
32 | argiro | 1.1 | case $(uname) in Darwin ) so=dylib ;; * ) so=so ;; esac |
33 | mkdir -p %i/lib/debug | ||
34 | (cd bin/boost; find libs -path "libs/*/debug/*.$so" -exec cp {} %i/lib/debug \;) | ||
35 | (cd bin/boost; find libs -path "libs/*/release/*.$so" -exec cp {} %i/lib \;) | ||
36 | eulisse | 1.7 | find boost -name '*.[hi]*' -print | |
37 | argiro | 1.1 | while read f; do |
38 | mkdir -p %i/include/$(dirname $f) | ||
39 | install -c $f %i/include/$f | ||
40 | done | ||
41 | find libs -name '*.py' -print | | ||
42 | while read f; do | ||
43 | mkdir -p %i/lib/$(dirname $f) | ||
44 | install -c $f %i/lib/$f | ||
45 | done | ||
46 | [ $(uname) = Darwin ] && | ||
47 | for f in %i/lib/*.$so %i/lib/debug/*.$so; do | ||
48 | install_name_tool -id $f $f | ||
49 | done | ||
50 | eulisse | 1.6 | |
51 | argiro | 1.1 | (cd %i/lib; for f in lib*-$boost_abi.$so; do ln -s $f $(echo $f | sed "s/-$boost_abi//"); done) |
52 | elmer | 1.17 | (cd %i/lib; for f in lib*-$boost_abi.$so; do ln -s $f $f.%realversion ; done) |
53 | argiro | 1.1 | (cd %i/lib/debug; for f in lib*-d-$boost_abi.$so; do ln -s $f $(echo $f | sed "s/-d-$boost_abi//"); done) |
54 | elmer | 1.17 | (cd %i/lib/debug; for f in lib*-d-$boost_abi.$so; do ln -s $f $f.%realversion; done) |
55 | eulisse | 1.4 | (cd %i/lib/libs/python/pyste/install; python setup.py install --prefix=%i) |
56 | ratnik | 1.16 | |
57 | elmer | 1.17 | perl -p -i -e "s|^#!.*python|/usr/bin/env python|" $(find %{i}/lib %{i}/bin) |
58 |