ViewVC Help
View File | Revision Log | Show Annotations | Root Listing
root/cvsroot/COMP/CMSDIST/boost.spec
Revision: 1.21
Committed: Mon Sep 3 15:28:45 2007 UTC (17 years, 7 months ago) by muzaffar
Branch: MAIN
CVS Tags: CMSSW_1_7_0_pre3, dl070916, dl070912, dl070812, sm070912b, sm070912a, sm070911a, dl070909p3, dl070909, CMSSW_1_7_0_pre2, dl070906, dl070905, sm030907a
Changes since 1.20: +84 -1 lines
Log Message:
new spec files for auto generation of toolfile i.e. no need of scramtoolbox

File Contents

# User Rev Content
1 muzaffar 1.21 ### RPM external boost 1.33.1-CMS8
2 argiro 1.1 # Patches and build fudging by Lassi A. Tuura <lat@iki.fi> (FIXME: contribute to boost)
3 elmer 1.17 %define boostver _%(echo %realversion | tr . _)
4 eulisse 1.8 Requires: boost-build python bz2lib zlib
5 argiro 1.2 Source: http://dl.sourceforge.net/sourceforge/%n/%{n}%{boostver}.tar.gz
6 argiro 1.1
7     %prep
8     %setup -n %{n}%{boostver}
9    
10     %build
11     # Note that some targets will fail to build (the test programs have
12     # missing symbols), causing darwin to fail to link and bjam to return
13     # an error. So ignore the exit code from bjam on darwin to avoid
14     # RPM falsely detecting a problem.
15     PR="PYTHON_ROOT=$PYTHON_ROOT"
16 elmer 1.17 #PV="PYTHON_VERSION=$(echo $PYTHON_VERSION | sed 's/\.[0-9]*$//')"
17     # The following line assumes a version of the form x.y.z-XXXX, where the
18     # "-XXXX" part represents some CMS rebuild of version x.y.z
19     PV="PYTHON_VERSION=$(echo $PYTHON_VERSION | sed 's/\.[0-9]*-.*$//')"
20     BZ2LIBR="BZIP2_LIBPATH=$BZ2LIB_ROOT/lib"
21 eulisse 1.8 ZLIBR="ZLIB_LIBPATH=$ZLIB_ROOT/lib"
22 elmer 1.17 BZ2LIBI="BZIP2_INCLUDE=$BZ2LIB_ROOT/include"
23 eulisse 1.8 ZLIBI="ZLIB_INCLUDE=$ZLIB_ROOT/include"
24    
25 argiro 1.1 case $(uname) in
26 eulisse 1.8 Darwin ) bjam -s$PR -s$PV -s$BZ2LIBR -s$ZLIBR -sTOOLS=darwin || true ;;
27     * ) bjam -s$PR -s$PV -s$BZ2LIBR -s$ZLIBR -sTOOLS=gcc ;;
28 argiro 1.1 esac
29    
30     %install
31 eulisse 1.6 boost_abi=$(echo %boostver | sed 's/^_//; s/_0$//')
32 argiro 1.1 case $(uname) in Darwin ) so=dylib ;; * ) so=so ;; esac
33 dlange 1.20 #no debug libs...
34     #mkdir -p %i/lib/debug
35     mkdir %i/lib
36     #(cd bin/boost; find libs -path "libs/*/debug/*.$so" -exec cp {} %i/lib/debug \;)
37     (cd bin/boost; find libs -path "libs/*/release/*.$so" -exec cp {} %i/lib/. \;)
38 eulisse 1.7 find boost -name '*.[hi]*' -print |
39 argiro 1.1 while read f; do
40     mkdir -p %i/include/$(dirname $f)
41     install -c $f %i/include/$f
42     done
43     find libs -name '*.py' -print |
44     while read f; do
45     mkdir -p %i/lib/$(dirname $f)
46     install -c $f %i/lib/$f
47     done
48     [ $(uname) = Darwin ] &&
49     for f in %i/lib/*.$so %i/lib/debug/*.$so; do
50     install_name_tool -id $f $f
51     done
52 eulisse 1.6
53 ratnik 1.19 # Do all manipulation with files before creating symbolic links:
54     perl -p -i -e "s|^#!.*python|/usr/bin/env python|" $(find %{i}/lib %{i}/bin)
55 dlange 1.20 strip %i/lib/*.$so
56 ratnik 1.19
57 argiro 1.1 (cd %i/lib; for f in lib*-$boost_abi.$so; do ln -s $f $(echo $f | sed "s/-$boost_abi//"); done)
58 elmer 1.17 (cd %i/lib; for f in lib*-$boost_abi.$so; do ln -s $f $f.%realversion ; done)
59 dlange 1.20 #(cd %i/lib/debug; for f in lib*-d-$boost_abi.$so; do ln -s $f $(echo $f | sed "s/-d-$boost_abi//"); done)
60     #(cd %i/lib/debug; for f in lib*-d-$boost_abi.$so; do ln -s $f $f.%realversion; done)
61 eulisse 1.4 (cd %i/lib/libs/python/pyste/install; python setup.py install --prefix=%i)
62 ratnik 1.16
63 muzaffar 1.21 # SCRAM ToolBox toolfile
64     mkdir -p %i/etc/scram.d
65     # boost toolfile
66     cat << \EOF_TOOLFILE >%i/etc/scram.d/boost
67     <doc type=BuildSystem::ToolDoc version=1.0>
68     <Tool name=boost version=%v>
69     <info url="http://www.boost.org"></info>
70     <lib name=boost_thread-gcc-mt>
71     <lib name=boost_signals-gcc-mt>
72     <Client>
73     <Environment name=BOOST_BASE default="%i"></Environment>
74     <Environment name=LIBDIR default="$BOOST_BASE/lib"></Environment>
75     <Environment name=INCLUDE default="$BOOST_BASE/include"></Environment>
76     </Client>
77     <use name=sockets>
78     </Tool>
79     EOF_TOOLFILE
80    
81     # boost_filesystem toolfile
82     cat << \EOF_TOOLFILE >%i/etc/scram.d/boost_filesystem
83     <doc type=BuildSystem::ToolDoc version=1.0>
84     <Tool name=boost_filesystem version=%v>
85     <info url="http://www.boost.org"></info>
86     <lib name=boost_filesystem-gcc-mt>
87     <use name=boost>
88     </Tool>
89     EOF_TOOLFILE
90    
91     # boost_program_options toolfile
92     cat << \EOF_TOOLFILE >%i/etc/scram.d/boost_program_options
93     <doc type=BuildSystem::ToolDoc version=1.0>
94     <Tool name=boost_program_options version=%v>
95     <info url="http://www.boost.org"></info>
96     <lib name=boost_program_options-gcc-mt>
97     <use name=boost>
98     </Tool>
99     EOF_TOOLFILE
100    
101     # boost_python toolfile
102     cat << \EOF_TOOLFILE >%i/etc/scram.d/boost_python
103     <doc type=BuildSystem::ToolDoc version=1.0>
104     <Tool name=boost_python version=%v>
105     <info url="http://www.boost.org"></info>
106     <lib name=boost_python-gcc-mt>
107     <Client>
108     <Environment name=BOOST_PYTHON_BASE default="%i"></Environment>
109     <Environment name=PYSTE_EXEC default="$BOOST_PYTHON_BASE/lib/python2.4/site-packages/Pyste/pyste.py"></Environment>
110     <Environment name=LIBDIR default="$BOOST_PYTHON_BASE/lib"></Environment>
111     <Environment name=INCLUDE default="$BOOST_PYTHON_BASE/include"></Environment>
112     </Client>
113     <use name=elementtree>
114     <use name=gccxml>
115     <use name=python>
116     </Tool>
117     EOF_TOOLFILE
118    
119     # boost_regex toolfile
120     cat << \EOF_TOOLFILE >%i/etc/scram.d/boost_regex
121     <doc type=BuildSystem::ToolDoc version=1.0>
122     <Tool name=boost_regex version=%v>
123     <info url="http://www.boost.org"></info>
124     <lib name=boost_regex-gcc-mt>
125     <use name=boost>
126     </Tool>
127     EOF_TOOLFILE
128    
129     # boost_signals toolfile
130     cat << \EOF_TOOLFILE >%i/etc/scram.d/boost_signals
131     <doc type=BuildSystem::ToolDoc version=1.0>
132     <Tool name=boost_signals version=%v>
133     <info url="http://www.boost.org"></info>
134     <lib name=boost_signals-gcc-mt>
135     <use name=boost>
136     </Tool>
137     EOF_TOOLFILE
138    
139     %post
140     %{relocateConfig}etc/scram.d/boost
141     %{relocateConfig}etc/scram.d/boost_filesystem
142     %{relocateConfig}etc/scram.d/boost_program_options
143     %{relocateConfig}etc/scram.d/boost_python
144     %{relocateConfig}etc/scram.d/boost_regex
145     %{relocateConfig}etc/scram.d/boost_signals