1 |
eulisse |
1.1 |
### RPM external bootstrap-driver 1.0
|
2 |
|
|
Source: bootstrap
|
3 |
|
|
Requires: apt
|
4 |
|
|
|
5 |
|
|
%prep
|
6 |
|
|
%build
|
7 |
|
|
%install
|
8 |
|
|
packageList="external+elfutils+$ELFUTILS_VERSION-1-$ELFUTILS_REVISION.%cmsplatf.rpm
|
9 |
|
|
external+expat+$EXPAT_VERSION-1-$EXPAT_REVISION.%cmsplatf.rpm
|
10 |
|
|
external+db4+$DB4_VERSION-1-$DB4_REVISION.%cmsplatf.rpm
|
11 |
|
|
external+beecrypt+$BEECRYPT_VERSION-1-$BEECRYPT_REVISION.%cmsplatf.rpm
|
12 |
|
|
external+bz2lib+$BZ2LIB_VERSION-1-$BZ2LIB_REVISION.%cmsplatf.rpm
|
13 |
|
|
external+neon+$NEON_VERSION-1-$NEON_REVISION.%cmsplatf.rpm
|
14 |
|
|
external+rpm+$RPM_VERSION-1-$RPM_REVISION.%cmsplatf.rpm
|
15 |
|
|
external+libxml2+$LIBXML2_VERSION-1-$LIBXML2_REVISION.%cmsplatf.rpm
|
16 |
|
|
external+apt+$APT_VERSION-1-$APT_REVISION.%cmsplatf.rpm"
|
17 |
|
|
|
18 |
|
|
case %cmsplatf in
|
19 |
|
|
slc*online* )
|
20 |
|
|
platformSeeds="glibc coreutils bash tcsh zsh pdksh perl tcl
|
21 |
|
|
readline openssl ncurses
|
22 |
|
|
e2fsprogs krb5-libs freetype fontconfig
|
23 |
|
|
xorg-x11-deprecated-libs xorg-x11-libs xorg-x11-Mesa-libGLU
|
24 |
|
|
xorg-x11-Mesa-libGL compat-libstdc++-33 libidn"
|
25 |
|
|
|
26 |
|
|
# ONLINE: seed system compiler (only libraries for runtime)
|
27 |
|
|
platformSeeds="$platformSeeds libgcc libstdc++"
|
28 |
|
|
|
29 |
|
|
# ONLINE: seed other available system tools:
|
30 |
|
|
platformSeeds="$platformSeeds curl libpng libtiff libungif openssl qt zlib perl-DBI-1.40-8"
|
31 |
|
|
# Python tools are commented out due to compatibility problems.
|
32 |
|
|
#platformSeeds="$platformSeeds python python-elementtree"
|
33 |
|
|
|
34 |
|
|
# ONLINE: seed daq-built tools:
|
35 |
|
|
platformSeeds="$platformSeeds daq-cgicc daq-mimetic daq-oracle daq-tinyproxy
|
36 |
|
|
daq-xerces daq-xdaq"
|
37 |
|
|
platformSeeds="$platformSeeds daq-config daq-log4cplus daq-logudpappender
|
38 |
|
|
daq-logxmlappender daq-pt daq-ptfifo daq-pthttp
|
39 |
|
|
daq-pttcp daq-toolbox daq-xcept daq-xdaq2rc daq-xdata
|
40 |
|
|
daq-xgi daq-xoap"
|
41 |
|
|
;;
|
42 |
|
|
*)
|
43 |
|
|
packageList="external+zlib+$ZLIB_VERSION-1-$ZLIB_REVISION.%cmsplatf.rpm
|
44 |
|
|
external+openssl+$OPENSSL_VERSION-1-$OPENSSL_REVISION.%cmsplatf.rpm
|
45 |
|
|
$packageList"
|
46 |
|
|
platformSeeds="glibc glibc-32bit coreutils bash tcsh zsh pdksh perl
|
47 |
|
|
tcl tk perl-Tk readline openssl ncurses XFree86-libs
|
48 |
|
|
e2fsprogs krb5-libs freetype fontconfig XFree86-Mesa-libGLU
|
49 |
|
|
XFree86-Mesa-libGL xorg-x11-deprecated-libs
|
50 |
|
|
xorg-x11-libs xorg-x11-Mesa-libGLU xorg-x11-Mesa-libGL
|
51 |
|
|
compat-libstdc++-33 fglrx_6_8_0 libidn"
|
52 |
|
|
;;
|
53 |
|
|
esac
|
54 |
|
|
|
55 |
|
|
case $cmsplatf in
|
56 |
|
|
ydl*_ppc64* )
|
57 |
|
|
platformSeeds="$platformSeeds gcc libgcc libstdc++"
|
58 |
|
|
;;
|
59 |
|
|
esac
|
60 |
|
|
|
61 |
|
|
# OpenSuse
|
62 |
|
|
unsupportedSeeds="xorg-x11-Mesa compat-readline4 compat-curl2 freetype2
|
63 |
|
|
xorg-x11-libX11"
|
64 |
|
|
# Ubuntu
|
65 |
|
|
unsupportedSeeds="$unsupportedSeeds libcomerr2 libidn11 libxi6 libxpm4 libxinerama1
|
66 |
|
|
libncurses5 libsm6 libice6 libc6 libxcursor1 libxmu6
|
67 |
|
|
libgl1-mesa-glx libxft2 perl-base xserver-xorg xserver-xorg-core
|
68 |
|
|
libfreetype6 libfontconfig1 libgl1-mesa libxrandr2 libglu1-mesa
|
69 |
|
|
libxext6 libx11-6 libxrender1"
|
70 |
|
|
# Fedora
|
71 |
|
|
unsupportedSeeds="$unsupportedSeeds libX11 libXmu libSM libICE libXcursor
|
72 |
|
|
libXext libXrandr libXft mesa-libGLU mesa-libGL e2fsprogs-libs libXi libXinerama
|
73 |
|
|
libXft libXrender libXpm"
|
74 |
|
|
|
75 |
|
|
# Case statement for additional provides.
|
76 |
|
|
case %cmsplatf in
|
77 |
|
|
osx* )
|
78 |
|
|
additionalProvides="AGL ApplicationServices Carbon CoreFoundation
|
79 |
|
|
CoreServices OpenGL Python QuickTime Tcl Tk
|
80 |
|
|
libintl.3.dylib"
|
81 |
|
|
;;
|
82 |
|
|
esac
|
83 |
|
|
|
84 |
|
|
unsupportedProvides="libtcl8.3.so libtk8.3.so /bin/env libcom_err.so.3
|
85 |
|
|
libcrypto.so.4 libgssapi_krb5.so.2 libk5crypto.so.3
|
86 |
|
|
libkrb5.so.3 libssl.so.4 /bin/csh /bin/tcsh libreadline.so.4
|
87 |
|
|
libtcl8.4.so libtk8.4.so"
|
88 |
|
|
|
89 |
|
|
mkdir -p %{i}/etc/profile.d
|
90 |
|
|
(echo "instroot=%{instroot}"; \
|
91 |
|
|
echo "rpm_version=$RPM_VERSION"; \
|
92 |
eulisse |
1.2 |
echo "apt_version=$APT_VERSION"; \
|
93 |
eulisse |
1.1 |
echo "platformSeeds=\"$platformSeeds\""; \
|
94 |
|
|
echo "unsupportedSeeds=\"$unsupportedSeeds\""; \
|
95 |
|
|
echo "packageList=\"$packageList\""; \
|
96 |
|
|
echo "additionalProvides=\"$additionalProvides\""; \
|
97 |
|
|
echo "unsupportedProvides=\"$unsupportedProvides\""; \
|
98 |
|
|
) > %{i}/%{cmsplatf}-driver.txt
|