1 |
elmer |
1.9 |
### RPM external bootstrap-driver 19.0
|
2 |
eulisse |
1.8 |
Source: bootstrap
|
3 |
|
|
Requires: apt zlib expat openssl beecrypt bz2lib db4 elfutils neon libxml2 rpm cms-common
|
4 |
eulisse |
1.1 |
|
5 |
|
|
%prep
|
6 |
|
|
%build
|
7 |
|
|
%install
|
8 |
eulisse |
1.3 |
packageList=""
|
9 |
|
|
echo requiredtools `echo %{requiredtools} | sed -e's|\s+| |;s|^\s+||'`
|
10 |
|
|
for tool in `echo %{requiredtools} | sed -e's|\s+| |;s|^\s+||'`
|
11 |
|
|
do
|
12 |
|
|
case X$tool in
|
13 |
|
|
Xdistcc|Xccache )
|
14 |
|
|
;;
|
15 |
|
|
* )
|
16 |
|
|
toolcap=`echo $tool | tr a-z- A-Z_`
|
17 |
|
|
toolversion=$(eval echo $`echo ${toolcap}_VERSION`)
|
18 |
|
|
toolrevision=$(eval echo $`echo ${toolcap}_REVISION`)
|
19 |
|
|
echo $toolversion $toolrevision
|
20 |
|
|
packageList="$packageList external+${tool}+${toolversion}-1-${toolrevision}.%cmsplatf.rpm"
|
21 |
|
|
;;
|
22 |
|
|
esac
|
23 |
|
|
done
|
24 |
|
|
|
25 |
eulisse |
1.1 |
|
26 |
|
|
case %cmsplatf in
|
27 |
|
|
slc*online* )
|
28 |
|
|
platformSeeds="glibc coreutils bash tcsh zsh pdksh perl tcl
|
29 |
|
|
readline openssl ncurses
|
30 |
|
|
e2fsprogs krb5-libs freetype fontconfig
|
31 |
|
|
xorg-x11-deprecated-libs xorg-x11-libs xorg-x11-Mesa-libGLU
|
32 |
|
|
xorg-x11-Mesa-libGL compat-libstdc++-33 libidn"
|
33 |
|
|
|
34 |
|
|
# ONLINE: seed system compiler (only libraries for runtime)
|
35 |
|
|
platformSeeds="$platformSeeds libgcc libstdc++"
|
36 |
|
|
|
37 |
|
|
# ONLINE: seed other available system tools:
|
38 |
|
|
platformSeeds="$platformSeeds curl libpng libtiff libungif openssl qt zlib perl-DBI-1.40-8"
|
39 |
|
|
# Python tools are commented out due to compatibility problems.
|
40 |
|
|
#platformSeeds="$platformSeeds python python-elementtree"
|
41 |
|
|
|
42 |
|
|
# ONLINE: seed daq-built tools:
|
43 |
|
|
platformSeeds="$platformSeeds daq-cgicc daq-mimetic daq-oracle daq-tinyproxy
|
44 |
|
|
daq-xerces daq-xdaq"
|
45 |
|
|
platformSeeds="$platformSeeds daq-config daq-log4cplus daq-logudpappender
|
46 |
|
|
daq-logxmlappender daq-pt daq-ptfifo daq-pthttp
|
47 |
|
|
daq-pttcp daq-toolbox daq-xcept daq-xdaq2rc daq-xdata
|
48 |
|
|
daq-xgi daq-xoap"
|
49 |
|
|
;;
|
50 |
|
|
*)
|
51 |
|
|
platformSeeds="glibc glibc-32bit coreutils bash tcsh zsh pdksh perl
|
52 |
|
|
tcl tk perl-Tk readline openssl ncurses XFree86-libs
|
53 |
|
|
e2fsprogs krb5-libs freetype fontconfig XFree86-Mesa-libGLU
|
54 |
|
|
XFree86-Mesa-libGL xorg-x11-deprecated-libs
|
55 |
|
|
xorg-x11-libs xorg-x11-Mesa-libGLU xorg-x11-Mesa-libGL
|
56 |
|
|
compat-libstdc++-33 fglrx_6_8_0 libidn"
|
57 |
|
|
;;
|
58 |
|
|
esac
|
59 |
|
|
|
60 |
|
|
case $cmsplatf in
|
61 |
elmer |
1.6 |
ydl*_ppc64_* )
|
62 |
|
|
platformSeeds="$platformSeeds gcc libgcc libstdc++"
|
63 |
|
|
;;
|
64 |
|
|
ydl*_ppc_* )
|
65 |
eulisse |
1.1 |
platformSeeds="$platformSeeds gcc libgcc libstdc++"
|
66 |
|
|
;;
|
67 |
|
|
esac
|
68 |
|
|
|
69 |
|
|
# OpenSuse
|
70 |
|
|
unsupportedSeeds="xorg-x11-Mesa compat-readline4 compat-curl2 freetype2
|
71 |
|
|
xorg-x11-libX11"
|
72 |
|
|
# Ubuntu
|
73 |
|
|
unsupportedSeeds="$unsupportedSeeds libcomerr2 libidn11 libxi6 libxpm4 libxinerama1
|
74 |
|
|
libncurses5 libsm6 libice6 libc6 libxcursor1 libxmu6
|
75 |
|
|
libgl1-mesa-glx libxft2 perl-base xserver-xorg xserver-xorg-core
|
76 |
|
|
libfreetype6 libfontconfig1 libgl1-mesa libxrandr2 libglu1-mesa
|
77 |
|
|
libxext6 libx11-6 libxrender1"
|
78 |
|
|
# Fedora
|
79 |
|
|
unsupportedSeeds="$unsupportedSeeds libX11 libXmu libSM libICE libXcursor
|
80 |
|
|
libXext libXrandr libXft mesa-libGLU mesa-libGL e2fsprogs-libs libXi libXinerama
|
81 |
|
|
libXft libXrender libXpm"
|
82 |
|
|
|
83 |
|
|
# Case statement for additional provides.
|
84 |
|
|
case %cmsplatf in
|
85 |
|
|
osx* )
|
86 |
|
|
additionalProvides="AGL ApplicationServices Carbon CoreFoundation
|
87 |
|
|
CoreServices OpenGL Python QuickTime Tcl Tk
|
88 |
|
|
libintl.3.dylib"
|
89 |
|
|
;;
|
90 |
|
|
esac
|
91 |
|
|
|
92 |
|
|
unsupportedProvides="libtcl8.3.so libtk8.3.so /bin/env libcom_err.so.3
|
93 |
|
|
libcrypto.so.4 libgssapi_krb5.so.2 libk5crypto.so.3
|
94 |
|
|
libkrb5.so.3 libssl.so.4 /bin/csh /bin/tcsh libreadline.so.4
|
95 |
|
|
libtcl8.4.so libtk8.4.so"
|
96 |
|
|
|
97 |
eulisse |
1.8 |
defaultPkgs="cms+cms-common+$CMS_COMMON_VERSION"
|
98 |
|
|
|
99 |
eulisse |
1.1 |
mkdir -p %{i}/etc/profile.d
|
100 |
|
|
(echo "instroot=%{instroot}"; \
|
101 |
|
|
echo "rpm_version=$RPM_VERSION"; \
|
102 |
eulisse |
1.2 |
echo "apt_version=$APT_VERSION"; \
|
103 |
eulisse |
1.1 |
echo "platformSeeds=\"$platformSeeds\""; \
|
104 |
|
|
echo "unsupportedSeeds=\"$unsupportedSeeds\""; \
|
105 |
eulisse |
1.4 |
echo "packageList=\"`echo $packageList`\""; \
|
106 |
eulisse |
1.1 |
echo "additionalProvides=\"$additionalProvides\""; \
|
107 |
|
|
echo "unsupportedProvides=\"$unsupportedProvides\""; \
|
108 |
eulisse |
1.8 |
echo "defaultPkgs=\"$defaultPkgs\""; \
|
109 |
eulisse |
1.1 |
) > %{i}/%{cmsplatf}-driver.txt
|