Revision: | 1.1 |
Committed: | Fri Oct 30 20:05:36 2009 UTC (15 years, 6 months ago) by diego |
Branch: | MAIN |
CVS Tags: | davidlt_20130206_1149-62X, davidlt_20130206_0909-62X, davidlt_20130205_1939-62X, eulisse_20130128_1430-62X, eulisse_20130128_1043-62X, ge20110914-gcc461, DBS_2_1_6-pre1, CmsTC_0_0_4, FRONTEND_CONF_3_30_20100724, FRONTEND_CONF_3_29_20100723, ge20100722-rpm-osx-64-bit, ge20100621-bootstrap-rpm-4-8-macosx, ge20100611-apt-rpm-4-8-gcc-4-5-0, MotT0_1_0_15, MotT0_1_0_14, MotT0_1_0_13, MotT0_1_0_12, MotT0_1_0_11, MotT0_1_0_10, MotT0_1_0_9, MotT0_1_0_8, MotT0_1_0_6, MotT0_1_0_5, MotT0_1_0_4, MotT0_1_0_3, MotT0_1_0_2, MotT0_1_0_1, MotT0_1_0_0, MotT0_100531_1, MotT0_100528_1, ge20100521b-new-rpm, ge20100521-new-rpm, ge20100519-new-apt, T0Mon_100518_1, T0Mon_100503_1, ge20100427-rpm-on-linux, ge20100422-rpm-4-8-0, T0Mon_100316_1, T0Mon_100308_2, T0Mon_100308_1, DAS_20100302_slc5_amd64_gcc434, DBS_20100226_slc5_amd64_gcc434, DBS_20100217_slc5_amd64_gcc434, FILEMOVER_20100217_slc5_amd64_gcc434, FRONTEND_CONF_3_24_20100217, DAS_20100217_slc5_amd64_gcc434, DAS_20100216b_slc5_amd64_gcc434, T0Mon_100216_1, DAS_20100216_slc5_amd64_gcc434, T0Mon_100210_1, T0Mon_100204_4, T0Mon_100204_3, T0Mon_100204_2, T0Mon_100204_1, dg20100201-dbs3, FILEMOVER_20100201_slc5_amd64_gcc434, FILEMOVER_20100128b_slc5_amd64_gcc434, dg20100129-dbs3, dg20100128-dbs3, FILEMOVER_20100128_slc5_amd64_gcc434, DAS_20100127_slc5_amd64_gcc434, DAS_20100126_slc5_amd64_gcc434, FILEMOVER_20100122_slc5_amd64_gcc434, DAS_20100119_slc5_amd64_gcc434, DAS_20100115_slc5_amd64_gcc434, dg20100115-security, DBS_20100115_slc5_amd64_gcc434, dg20100112-security, DBS_20100112_slc5_amd64_gcc434, DBS_20100111_slc5_amd64_gcc434, dg20100111-security, dg20100107b-wmcore, dg20100107-wmcore, DAS_20100105_slc5_amd64_gcc434, DAS_20091221_slc5_amd64_gcc434, DAS_20091214_slc5_amd64_gcc434, dg20091211-couchdb, dg20091210-phedex, dg20091203c-comp-base, DD_20091208_slc5_amd64_gcc434, DAS_20091208_slc5_amd64_gcc434, FILEMOVER_20091208_slc5_amd64_gcc434, DBS_20091208_slc5_amd64_gcc434, dg20091203b-comp-base, DQMCATTEST_0_0_1, DAS_20091117, BUILDBOT_01, CERNOIDv02, HEAD |
Log Message: | Added spec files for buildbot and its dependancies |
# | User | Rev | Content |
---|---|---|---|
1 | diego | 1.1 | ### RPM external buildbot 0.7.11p3 |
2 | |||
3 | ## INITENV +PATH PYTHONPATH %i/lib/python%{pythonv}`echo $PYTHON_VERSION | cut -d. -f 1,2`/site-packages | ||
4 | %define pythonv %(echo $PYTHON_VERSION | cut -d. -f 1,2) | ||
5 | |||
6 | Requires: python twisted zope-interface | ||
7 | #Source: http://openidenabled.com/files/python-openid/packages/python-openid-2.2.4.tar.gz | ||
8 | Source: http://sourceforge.net/projects/buildbot/files/buildbot/0.7.11p3/buildbot-0.7.11p3.tar.gz/download | ||
9 | |||
10 | |||
11 | %prep | ||
12 | %setup -n buildbot-0.7.11p3 | ||
13 | #%setup -n python-openid-2.2.4 | ||
14 | |||
15 | %build | ||
16 | |||
17 | %install | ||
18 | python setup.py install --prefix=%i | ||
19 | # Perhaps the following is needed to fix python source headers | ||
20 | perl -p -i -e "s|^#!.*python(.*)|#!/usr/bin/env python$1|" `grep -r -e "^#\!.*python.*" %i | cut -d: -f1` | ||
21 | |||
22 | rm -rf %i/etc/profile.d | ||
23 | mkdir -p %i/etc/profile.d | ||
24 | echo '#!/bin/sh' > %{i}/etc/profile.d/dependencies-setup.sh | ||
25 | echo '#!/bin/tcsh' > %{i}/etc/profile.d/dependencies-setup.csh | ||
26 | echo requiredtools `echo %{requiredtools} | sed -e's|\s+| |;s|^\s+||'` | ||
27 | for tool in `echo %{requiredtools} | sed -e's|\s+| |;s|^\s+||'` | ||
28 | do | ||
29 | case X$tool in | ||
30 | Xdistcc|Xccache ) | ||
31 | ;; | ||
32 | * ) | ||
33 | toolcap=`echo $tool | tr a-z- A-Z_` | ||
34 | eval echo ". $`echo ${toolcap}_ROOT`/etc/profile.d/init.sh" >> %{i}/etc/profile.d/dependencies-setup.sh | ||
35 | eval echo "source $`echo ${toolcap}_ROOT`/etc/profile.d/init.csh" >> %{i}/etc/profile.d/dependencies-setup.csh | ||
36 | ;; | ||
37 | esac | ||
38 | done | ||
39 | |||
40 | perl -p -i -e 's|\. /etc/profile\.d/init\.sh||' %{i}/etc/profile.d/dependencies-setup.sh | ||
41 | perl -p -i -e 's|source /etc/profile\.d/init\.csh||' %{i}/etc/profile.d/dependencies-setup.csh | ||
42 | |||
43 | |||
44 | |||
45 | %post | ||
46 | %{relocateConfig}etc/profile.d/dependencies-setup.sh | ||
47 | %{relocateConfig}etc/profile.d/dependencies-setup.csh | ||
48 | |||
49 | |||
50 | #%files | ||
51 | #%i/ |