ViewVC Help
View File | Revision Log | Show Annotations | Root Listing
root/cvsroot/COMP/CMSDIST/cern.spec
Revision: 1.2
Committed: Wed May 31 10:28:11 2006 UTC (18 years, 11 months ago) by eulisse
Branch: MAIN
Changes since 1.1: +6 -2 lines
Log Message:
Example on how to get the configuration files from CVS.

File Contents

# User Rev Content
1 eulisse 1.1 ### RPM configuration cern 1.0
2     # Example file for site specific configurations.
3 eulisse 1.2 %define sitename %n
4     %define cvstag HEAD
5     Source: cvs://:pserver:anonymous@cmscvs.cern.ch:2401/cvs_server/repositories/CMSSW?passwd=AA_:yZZ3e&module=COMP/SITECONFIG/%{sitename}&export=SITECONFIG&tag=-r%{cvstag}&output=/SITECONFIG.tar.gz
6 eulisse 1.1
7     %prep
8     %build
9     %install
10     mkdir -p %instroot/SITECONFIG/%n
11    
12 eulisse 1.2 cp %{_sourcedir}/SITECONFIG/%{sitename}/... %{instroot}/SITECONFIG/%n/site-local.xml
13     cp %{_sourcedir}/SITECONFIG/%{sitename}/... %{instroot}/SITECONFIG/%n/storage.xml
14    
15 eulisse 1.1 cat << \EOF_SITE_LOCAL_XML > %{instroot}/SITECONFIG/%n/site-local.xml
16     Site local contents here.
17     EOF_SITE_LOCAL_XML
18    
19     cat << \EOF_STORAGE_XML > %{instroot}/SITECONFIG/%n/storage.xml
20     Trivial file catalog here.
21     EOF_STORAGE_XML
22     %post
23     perl -p -i -e "s|%{instroot}|$RPM_INSTALL_PREFIX|" SITECONFIG/%n/storage.xml SITECONFIG/%n/site-local.xml
24     ln -sf $RPM_INSTALL_PREFIX/%n $RPM_INSTALL_PREFIX/local
25     %files
26     %instroot/SITECONFIG/%n