ViewVC Help
View File | Revision Log | Show Annotations | Root Listing
root/cvsroot/COMP/CMSDIST/charybdis.spec
Revision: 1.8
Committed: Thu May 14 20:09:30 2009 UTC (15 years, 11 months ago) by andreasp
Branch: MAIN
CVS Tags: ap20090520-osx105, ap20090519-osx105
Changes since 1.7: +1 -0 lines
Log Message:
porting from Mac OS X:
added buildif statements to disable building on Mac OS X (for now)
re-arranged build-related stuff (like ./configure ...) from setup
section to build section, otherwise cmsBuild will try to execute
them (BUILDIF still runs the setup section) and fail.

File Contents

# User Rev Content
1 elmer 1.7 ### RPM external charybdis 1.003
2 andreasp 1.8 ## BUILDIF case $(uname):$(uname -p) in Linux:i*86 ) true ;; Linux:x86_64 ) true ;; Linux:ppc64 ) false ;; Darwin:* ) false ;; * ) false ;; esac
3 muzaffar 1.1 Source: http://cern.ch/service-spi/external/MCGenerators/distribution/%{n}-%{realversion}-src.tgz
4     %prep
5     %setup -q -n %{n}/%{realversion}
6 dlange 1.3 ./configure --lcgplatform=%cmsplatf --pythia_fragmentation
7 muzaffar 1.1
8     %build
9     which g77
10     make
11    
12     %install
13     tar -c lib include | tar -x -C %i
14     # SCRAM ToolBox toolfile
15     mkdir -p %i/etc/scram.d
16     cat << \EOF_TOOLFILE >%i/etc/scram.d/%n
17     <doc type=BuildSystem::ToolDoc version=1.0>
18     <Tool name=charybdis version=%v>
19     <Client>
20     <Environment name=CHARYBDIS_BASE default="%i"></Environment>
21     <Environment name=LIBDIR default="$CHARYBDIS_BASE/lib"></Environment>
22     <Environment name=INCLUDE default="$CHARYBDIS_BASE/include"></Environment>
23     </Client>
24     <lib name=charybdis>
25     <use name=f77compiler>
26 dlange 1.2 <use name=herwig>
27 dlange 1.4 <use name=pythia6>
28 muzaffar 1.1 </Tool>
29     EOF_TOOLFILE
30    
31     %post
32     %{relocateConfig}etc/scram.d/%n