ViewVC Help
View File | Revision Log | Show Annotations | Root Listing
root/cvsroot/COMP/CMSDIST/classlib.spec
Revision: 1.16
Committed: Fri Aug 31 14:24:37 2012 UTC (12 years, 8 months ago) by fwyzard
Branch: MAIN
CVS Tags: CMSSW_5_2_7_onlpatch2_ONLINE, CMSSW_5_2_7_onlpatch1_ONLINE, CMSSW_5_2_7_ONLINE, CMSSW_5_2_7_cand3_ONLINE-cms
Changes since 1.15: +5 -23 lines
Log Message:
on SLC5 and above, curl and openssl no longer need a special treatment for the online builds (CMSSW_5_2_X backport)

File Contents

# User Rev Content
1 lat 1.8 ### RPM external classlib 3.1.3
2 lat 1.11 %define online %(case %cmsplatf in (*onl_*_*) echo true;; (*) echo false;; esac)
3 lat 1.10 Source: http://lat.web.cern.ch/lat/exports/%n-%realversion.tar.bz2
4 fwyzard 1.16 Patch: classlib-3.1.3-gcc46
5 fwyzard 1.5
6 fwyzard 1.4 Requires: bz2lib
7     Requires: pcre
8 lat 1.11 Requires: xz
9 fwyzard 1.16 Requires: openssl
10 fwyzard 1.4 %if "%online" != "true"
11     Requires: zlib
12     %else
13     Requires: onlinesystemtools
14     %endif
15 lat 1.1
16     %prep
17     %setup -n %n-%realversion
18 fwyzard 1.16 %patch -p1
19 lat 1.1
20     %build
21     ./configure --prefix=%i \
22     --with-zlib-includes=$ZLIB_ROOT/include \
23     --with-zlib-libraries=$ZLIB_ROOT/lib \
24     --with-bz2lib-includes=$BZ2LIB_ROOT/include \
25     --with-bz2lib-libraries=$BZ2LIB_ROOT/lib \
26     --with-pcre-includes=$PCRE_ROOT/include \
27     --with-pcre-libraries=$PCRE_ROOT/lib \
28     --with-openssl-includes=$OPENSSL_ROOT/include \
29 lat 1.11 --with-openssl-libraries=$OPENSSL_ROOT/lib \
30     --with-lzma-includes=$XZ_ROOT/include \
31 fwyzard 1.16 --with-lzma-libraries=$XZ_ROOT/lib
32 lat 1.2
33     perl -p -i -e '
34 lat 1.11 s{-llzo2}{}g;
35     !/^\S+: / && s{\S+LZO((C|Dec)ompressor|Constants|Error)\S+}{}g' \
36 lat 1.2 Makefile
37 lat 1.1
38 fwyzard 1.16 make %makeprocesses
39 lat 1.1
40     %install
41     make %makeprocesses install