ViewVC Help
View File | Revision Log | Show Annotations | Root Listing
root/cvsroot/COMP/CMSDIST/classlib.spec
Revision: 1.2
Committed: Tue Oct 26 13:42:04 2010 UTC (14 years, 6 months ago) by lat
Branch: MAIN
CVS Tags: pe20101102e-for310Xrb, pe20101102d-for310Xrb, pe20101102c-for310Xrb, pe20101102b-for310Xrb, pe20101102a-for310Xrb, pe20101029a-for310Xrb, pe20101028a-for310Xrb
Changes since 1.1: +8 -6 lines
Log Message:
Disable LZO and XZ dependencies.

File Contents

# User Rev Content
1 lat 1.1 ### RPM external classlib 3.1.0
2     Source: http://cmsmac01.cern.ch/~lat/exports/%n-%realversion.tar.bz2
3 lat 1.2 # Requires: zlib bz2lib pcre openssl lzo xz
4     Requires: zlib bz2lib pcre openssl
5 lat 1.1
6     %prep
7     %setup -n %n-%realversion
8    
9     %build
10     ./configure --prefix=%i \
11     --with-zlib-includes=$ZLIB_ROOT/include \
12     --with-zlib-libraries=$ZLIB_ROOT/lib \
13     --with-bz2lib-includes=$BZ2LIB_ROOT/include \
14     --with-bz2lib-libraries=$BZ2LIB_ROOT/lib \
15     --with-pcre-includes=$PCRE_ROOT/include \
16     --with-pcre-libraries=$PCRE_ROOT/lib \
17     --with-openssl-includes=$OPENSSL_ROOT/include \
18 lat 1.2 --with-openssl-libraries=$OPENSSL_ROOT/lib
19    
20     perl -p -i -e '
21     s{-l(lzo2|lzma)}{}g;
22     !/^\S+: / && s{\S+LZ(O|MA)((C|Dec)ompressor|Constants|Error)\S+}{}g' \
23     Makefile
24 lat 1.1
25     make %makeprocesses
26    
27     %install
28     make %makeprocesses install