1 |
elmer |
1.3 |
### RPM external classlib 3.1.1
|
2 |
lat |
1.1 |
Source: http://cmsmac01.cern.ch/~lat/exports/%n-%realversion.tar.bz2
|
3 |
fwyzard |
1.4 |
Requires: bz2lib
|
4 |
|
|
Requires: pcre
|
5 |
|
|
%if "%online" != "true"
|
6 |
|
|
Requires: openssl
|
7 |
|
|
Requires: zlib
|
8 |
|
|
%else
|
9 |
|
|
Requires: onlinesystemtools
|
10 |
|
|
%endif
|
11 |
lat |
1.1 |
|
12 |
|
|
%prep
|
13 |
|
|
%setup -n %n-%realversion
|
14 |
|
|
|
15 |
|
|
%build
|
16 |
|
|
./configure --prefix=%i \
|
17 |
|
|
--with-zlib-includes=$ZLIB_ROOT/include \
|
18 |
|
|
--with-zlib-libraries=$ZLIB_ROOT/lib \
|
19 |
|
|
--with-bz2lib-includes=$BZ2LIB_ROOT/include \
|
20 |
|
|
--with-bz2lib-libraries=$BZ2LIB_ROOT/lib \
|
21 |
|
|
--with-pcre-includes=$PCRE_ROOT/include \
|
22 |
|
|
--with-pcre-libraries=$PCRE_ROOT/lib \
|
23 |
|
|
--with-openssl-includes=$OPENSSL_ROOT/include \
|
24 |
lat |
1.2 |
--with-openssl-libraries=$OPENSSL_ROOT/lib
|
25 |
|
|
|
26 |
|
|
perl -p -i -e '
|
27 |
|
|
s{-l(lzo2|lzma)}{}g;
|
28 |
|
|
!/^\S+: / && s{\S+LZ(O|MA)((C|Dec)ompressor|Constants|Error)\S+}{}g' \
|
29 |
|
|
Makefile
|
30 |
lat |
1.1 |
|
31 |
|
|
make %makeprocesses
|
32 |
|
|
|
33 |
|
|
%install
|
34 |
|
|
make %makeprocesses install
|