Revision: | 1.5 |
Committed: | Thu Jan 20 00:02:54 2011 UTC (14 years, 3 months ago) by fwyzard |
Branch: | MAIN |
CVS Tags: | pe20110203-for410p1, fw20110201-41X-online, pe20110131b-for4XY-ports, pe20110131b-for4XY, pe20110131a-for4XY-ports, pe20110131a-for4XY, fw20110131-311x-online, CMSSW_3_11_0_ONLINE, fw20110128-311X-online, CMSSW_4_2_0_pre1-ports, CMSSW_4_2_0_pre1, CMSSW_3_11_0, azFor420pre1gcc451, azFor420pre1g451n, azFor420pre1g434, pe20110127a-for311X-ports, pe20110127a-for311X, azFor420pre1g451, azFor420pre1, fw20110127a-311X, fw20110127-311X, fwFor3110, pe20110126b-for311X-ports, pe20110126b-for311X, fw20110126a-311X-online, fw20110126a-311X-ports, pe20110126a-for311X-ports, pe20110126a-for311X, sm110126a, sm110126, fw20110126-311X-online, sm110125, pe20110124b-311X-ports, pe20110124b-311X, pe20110124a-311X, fw20110122-311X-ports, fw20110122-311X-online, pe20110122b-311X-ports, pe20110122a-311X-ports, pe20110122a-311X, CMSSW_3_11_0_pre5_ONLINE, fw20110121b-311X-ports, fw20110121b-311X-online, fw20110121a-311X-ports, fw20110121a-311X-online, fw20110121-311X-ports, fw20110121-311X-online, fw20110121, pe20110120b-311X, pe20110120a-311X-ports, pe20110120a-311X, fw20110120b-311X-ports, fw20110120b-311X-online, fw20110120a-311X-ports, fw20110120a-311X-online |
Changes since 1.4: | +3 -0 lines |
Log Message: | actually %define online |
# | Content |
---|---|
1 | ### RPM external classlib 3.1.1 |
2 | Source: http://cmsmac01.cern.ch/~lat/exports/%n-%realversion.tar.bz2 |
3 | %define closingbrace ) |
4 | %define online %(case %cmsplatf in *onl_*_*%closingbrace echo true;; *%closingbrace echo false;; esac) |
5 | |
6 | Requires: bz2lib |
7 | Requires: pcre |
8 | %if "%online" != "true" |
9 | Requires: openssl |
10 | Requires: zlib |
11 | %else |
12 | Requires: onlinesystemtools |
13 | %endif |
14 | |
15 | %prep |
16 | %setup -n %n-%realversion |
17 | |
18 | %build |
19 | ./configure --prefix=%i \ |
20 | --with-zlib-includes=$ZLIB_ROOT/include \ |
21 | --with-zlib-libraries=$ZLIB_ROOT/lib \ |
22 | --with-bz2lib-includes=$BZ2LIB_ROOT/include \ |
23 | --with-bz2lib-libraries=$BZ2LIB_ROOT/lib \ |
24 | --with-pcre-includes=$PCRE_ROOT/include \ |
25 | --with-pcre-libraries=$PCRE_ROOT/lib \ |
26 | --with-openssl-includes=$OPENSSL_ROOT/include \ |
27 | --with-openssl-libraries=$OPENSSL_ROOT/lib |
28 | |
29 | perl -p -i -e ' |
30 | s{-l(lzo2|lzma)}{}g; |
31 | !/^\S+: / && s{\S+LZ(O|MA)((C|Dec)ompressor|Constants|Error)\S+}{}g' \ |
32 | Makefile |
33 | |
34 | make %makeprocesses |
35 | |
36 | %install |
37 | make %makeprocesses install |