Revision: | 1.2 |
Committed: | Fri Feb 10 15:09:58 2006 UTC (19 years, 2 months ago) by argiro |
Branch: | MAIN |
CVS Tags: | CRABSERVER_TEST_BUILD_V4, CRABSERVER_TEST_BUILD_V3, CRABSERVER_TEST_BUILD_V2, CRABSERVER_TEST_BUILD_V1, forCRABSERVER104test, forCRABSERVER103, PRODAGENT_0_10_12_V10, PRODAGENT_0_10_12_V9, PRODAGENT_0_10_12_V8, PRODAGENT_0_10_12_V7, PRODAGENT_0_10_12_V6, PRODAGENT_0_10_12_V5, PRODAGENT_0_10_12_V4, forCS102pre4, PRODAGENT_0_10_12_V3, PRODAGENT_0_10_12_V2, PRODAGENT_0_10_12, PRODAGENT_0_10_3, PRODAGENT_0_10_3_20080521, PRODAGENT_0_8_3_SL4, forPA070pre3-slc3, forPA070pre3-slc4, forPA070pre3-slc, forPA061, forPA060pre7-slc4, forPA060pre3, forDBS106, forPA050pre3, WEBTOOLS_CONFIG_1_pre2, WEBTOOLS_CONFIG_1_pre1, forPA030, forPA020, PR_0_5_4, PR_0_5_0, PR_0_4_21, PRODREQUEST_0_4_0, PR0_3_13, PR0_3_12, PR0-3-11, forPR034, forPR033, forPIL116, forPR032, forPR030, forPR020, forPA011, forPR010, forPA010, af20060928, ProdAgent_pa17, phedex_2_3_series, forLCG_44, forCMSSW_0_8_0_pre2, V00-01-02, V00-01-2, V00-01-01, V00-01-00, V00-00-11, V00-00-10, V00-00-09, V00-00-08, V00-00-07, V00-00-06, V00-00-05, V00-00-04, V00-00-03, V00-00-02, V00-00-01, V00-00-00, test2, test1, NataliaStart |
Changes since 1.1: | +29 -29 lines |
Log Message: | updated specs |
# | User | Rev | Content |
---|---|---|---|
1 | argiro | 1.1 | ### RPM external clhep 1.9.2.2 |
2 | Source: http://proj-clhep.web.cern.ch/proj-clhep/%n-%v.tgz | ||
3 | |||
4 | %prep | ||
5 | %setup -n %v/CLHEP | ||
6 | |||
7 | %build | ||
8 | CXX=g++ ./configure --prefix=%i | ||
9 | make | ||
10 | |||
11 | argiro | 1.2 | #mkdir -p shared-tmp |
12 | #cd shared-tmp | ||
13 | #case $(uname) in | ||
14 | # Darwin ) so=dylib shared="-dynamiclib -single_module" flags= ;; | ||
15 | # * ) so=so shared="-shared" flags="-D_GNU_SOURCE" ;; | ||
16 | #esac | ||
17 | # | ||
18 | #set -x | ||
19 | #cp -i ../Evaluator/*.cc . | ||
20 | #cp -i ../Evaluator/*.src . | ||
21 | #cp -i ../GenericFunctions/*.cc . | ||
22 | #cp -i ../Geometry/*.cc . | ||
23 | #cp -i ../Matrix/*.cc . | ||
24 | #cp -i ../Random/*.cc . | ||
25 | #cp -i ../Random/*.src . | ||
26 | #cp -i ../Random/*.cdat . | ||
27 | #cp -i ../RandomObjects/*.cc . | ||
28 | #cp -i ../Vector/*.cc . | ||
29 | #cp -i ../HepPDT/*.cc . | ||
30 | #cp -i ../HepMC/*.cc . | ||
31 | #cp -i ../StdHep/*.cc . | ||
32 | #for f in *.cc; do | ||
33 | # g++ -c -O2 -ansi -Wall -fPIC -I../.. $flags $f | ||
34 | #done | ||
35 | #g++ $shared -o libCLHEP-g++.%v.$so *.o | ||
36 | argiro | 1.1 | |
37 | %install | ||
38 | case $(uname) in Darwin ) so=dylib ;; * ) so=so ;; esac | ||
39 | make install | ||
40 | argiro | 1.2 | #cd shared-tmp |
41 | #cp libCLHEP-g++.%v.$so %i/lib | ||
42 | #ln -s libCLHEP-g++.%v.$so %i/lib/libCLHEP.$so | ||
43 | #n -s libCLHEP-g++.%v.a %i/lib/libCLHEP.a |