ViewVC Help
View File | Revision Log | Show Annotations | Root Listing
root/cvsroot/COMP/CMSDIST/clhep.spec
Revision: 1.26
Committed: Fri May 29 06:47:44 2009 UTC (15 years, 11 months ago) by andreasp
Branch: MAIN
CVS Tags: PerfSuiteDB_20090901, forHEARTBEATr04, RPMVERIFY_0_2, forHEARTBEATr01, CMSSW_2_2_13_offpatch1, apFor2213offpatch1v0, CMSSW_2_2_13_FWLITE, apFor2213fwlitev0, CMSSW_2_2_13_HLT, apFor2213hltv0, CMSSW_2_2_13, apFor2213v0, CMSSW_2_2_12_HLT, CMSSW_2_2_12, apFor2212hltv0, apFor2212v2, apFor2212v1, apFor2212v0
Changes since 1.25: +2 -3 lines
Log Message:
added patch for future-compatibility with 2.0 in prep for 2.2.12

File Contents

# User Rev Content
1 andreasp 1.26 ### RPM external clhep 1.9.3.2
2     Source: http://proj-clhep.web.cern.ch/proj-clhep/DISTRIBUTION/distributions/%n-%realversion-src.tgz
3 dlange 1.25 Patch0: clhep_20fwd
4    
5 argiro 1.1 %prep
6 elmer 1.12 %setup -n %realversion/CLHEP
7 dlange 1.25 %patch0 -p2
8 argiro 1.1
9     %build
10 elmer 1.9 if [ $(uname) = Darwin ]; then
11     export MACOSX_DEPLOYMENT_TARGET="10.4"
12     fi
13 argiro 1.1 CXX=g++ ./configure --prefix=%i
14     make
15    
16 argiro 1.2 #mkdir -p shared-tmp
17     #cd shared-tmp
18     #case $(uname) in
19     # Darwin ) so=dylib shared="-dynamiclib -single_module" flags= ;;
20     # * ) so=so shared="-shared" flags="-D_GNU_SOURCE" ;;
21     #esac
22     #
23     #set -x
24     #cp -i ../Evaluator/*.cc .
25     #cp -i ../Evaluator/*.src .
26     #cp -i ../GenericFunctions/*.cc .
27     #cp -i ../Geometry/*.cc .
28     #cp -i ../Matrix/*.cc .
29     #cp -i ../Random/*.cc .
30     #cp -i ../Random/*.src .
31     #cp -i ../Random/*.cdat .
32     #cp -i ../RandomObjects/*.cc .
33     #cp -i ../Vector/*.cc .
34     #cp -i ../HepPDT/*.cc .
35     #cp -i ../HepMC/*.cc .
36     #cp -i ../StdHep/*.cc .
37     #for f in *.cc; do
38     # g++ -c -O2 -ansi -Wall -fPIC -I../.. $flags $f
39     #done
40 elmer 1.12 #g++ $shared -o libCLHEP-g++.%realversion.$so *.o
41 argiro 1.1
42     %install
43     case $(uname) in Darwin ) so=dylib ;; * ) so=so ;; esac
44     make install
45 argiro 1.2 #cd shared-tmp
46 elmer 1.12 #cp libCLHEP-g++.%realversion.$so %i/lib
47     #ln -s libCLHEP-g++.%realversion.$so %i/lib/libCLHEP.$so
48     #n -s libCLHEP-g++.%realversion.a %i/lib/libCLHEP.a
49 dlange 1.14 #remove the .a files
50     rm %i/lib/*.a
51 andreasp 1.20 # remove the separate libs:
52     rm %i/lib/libCLHEP-[A-Z]*-%realversion.$so
53 dlange 1.14
54 muzaffar 1.15 # SCRAM ToolBox toolfile
55     mkdir -p %i/etc/scram.d
56     cat << \EOF_TOOLFILE >%i/etc/scram.d/%n
57     <doc type=BuildSystem::ToolDoc version=1.0>
58     <Tool name=%n version=%v>
59     <info url="http://wwwinfo.cern.ch/asd/lhc++/clhep"></info>
60 andreasp 1.19 <lib name=CLHEP-%realversion>
61 muzaffar 1.15 <Client>
62     <Environment name=CLHEP_BASE default="%i"></Environment>
63     <Environment name=LIBDIR default="$CLHEP_BASE/lib"></Environment>
64     <Environment name=INCLUDE default="$CLHEP_BASE/include"></Environment>
65     </Client>
66     <Runtime name=CLHEP_PARAM_PATH value="$CLHEP_BASE">
67 dlange 1.16 <Runtime name=LD_LIBRARY_PATH value="$CLHEP_BASE/lib" type=path>
68     <Runtime name=CMSSW_FWLITE_INCLUDE_PATH value="$CLHEP_BASE/include" type=path>
69 muzaffar 1.15 </Tool>
70     EOF_TOOLFILE
71    
72 eulisse 1.4 %post
73     %{relocateConfig}bin/Evaluator-config
74     %{relocateConfig}bin/Cast-config
75     %{relocateConfig}bin/GenericFunctions-config
76     %{relocateConfig}bin/Exceptions-config
77     %{relocateConfig}bin/RandomObjects-config
78     %{relocateConfig}bin/Geometry-config
79     %{relocateConfig}bin/Matrix-config
80     %{relocateConfig}bin/Random-config
81     %{relocateConfig}bin/RefCount-config
82     %{relocateConfig}bin/Units-config
83     %{relocateConfig}bin/Vector-config
84     %{relocateConfig}bin/clhep-config
85 muzaffar 1.15 %{relocateConfig}etc/scram.d/%n