Revision: | 1.38 |
Committed: | Thu May 3 19:48:13 2012 UTC (12 years, 11 months ago) by eulisse |
Branch: | MAIN |
CVS Tags: | davidlt_20120614_2147-gcc470, davidlt_20120611_1739-gcc470, CMSSW_6_0_0_pre6Nmix-gcc470, daForCMSSW_6_0_0_pre6Nmix-slc5_amd64_gcc470, davidlt_20120607_1041-60X-osx107, davidlt_20120607_1039-60X-slc6, CMSSW_6_0_0_pre6-slc6, CMSSW_6_0_0_pre6-osx107, CMSSW_6_0_0_pre6-gcc470, daForCMSSW_6_0_0_pre6-osx107_amd64_gcc462, ForCMSSW_6_0_0_pre6-slc6_amd64_gcc462, daForCMSSW_6_0_0_pre6-slc5_amd64_gcc470, davidlt_20120531_1114-60X-osx107, davidlt_20120531_1112-60X-slc6, davidlt_20120531_1111-60X-gcc470, davidlt_20120529_1110-60X-gcc470, davidlt_20120529_1112-60X-slc6, davidlt_20120529_1113-60X-osx107, davidlt_20120529_1024-60X-gcc470, davidlt_20120528_1234-60X-osx107, davidlt_20120528_1232-60X-slc6, davidlt_20120528_1230-60X-gcc470, davidlt_20120525_1144-60X-gcc470, cmsForCMSSW_6_0_X_2012-05-25-0200-slc5_amd64_gcc470, davidlt_20120525_0906-60X-slc6, davidlt_20120525_0901-60X-osx107, davidlt_20120524_1540-60X-gcc470, davidlt_test_gcc470_1, davidlt_20120523_1319-60X-slc6, davidlt_20120523_1316-60X-osx107, davidlt_20120523_1314-60X-gcc470, CMSSW_6_0_0_pre5-gcc470, CMSSW_6_0_0_pre5-osx107, CMSSW_6_0_0_pre5-slc6, daForCMSSW_6_0_0_pre5-slc5_amd64_gcc470, davidltForCMSSW_6_0_0_pre5-osx107_amd64_gcc462, ForCMSSW_6_0_0_pre5-slc6_amd64_gcc462, ge20120521-cms-common, cmsForCMSSW_6_0_X_2012-05-18-1400-slc5_amd64_gcc470, sm120518-60X-slc6, sm120518-60X-osx107, sm120518-60X-gcc470, sm120508a-60X-osx107, sm120508a-60X-gcc470, sm120508-60X-slc6, sm120508-60X-gcc470, sm120508-60X-osx107, sm120508-slc6, sm120508-gcc470, sm120508-osx107, davidlt_20120514_1052-60X-gcc470, davidlt_20120514_1054-60X-slc6, davidlt_20120514_1057-60X-osx107, cmsForCMSSW_6_0_X_2012-05-11-1400-slc5_amd64_gcc470, ge20120511-clang, davidlt_20120510_1021-60X-gcc470, davidlt_20120510_1028-60X-osx107, davidlt_20120510_1008-60X-slc6, ge20120503-60x-gcc470 |
Changes since 1.37: | +0 -13 lines |
Log Message: | Misc fixes. * Fix warnings coming from clhep. * Apply patch to remove virtual methods from being inline also on linux. Fixes link problems with LTO. |
# | User | Rev | Content |
---|---|---|---|
1 | elmer | 1.32 | ### RPM external clhep 2.0.4.6 |
2 | elmer | 1.27 | Source: http://proj-clhep.web.cern.ch/proj-clhep/DISTRIBUTION/distributions/%n-%realversion.tgz |
3 | elmer | 1.34 | Patch: clhep-2.0.4.2-no-virtual-inline |
4 | dlange | 1.25 | |
5 | davidlt | 1.36 | %if "%{?cms_cxx:set}" != "set" |
6 | %define cms_cxx g++ | ||
7 | %endif | ||
8 | |||
9 | %if "%{?cms_cxxflags:set}" != "set" | ||
10 | davidlt | 1.37 | %define cms_cxxflags -O2 -std=c++0x |
11 | davidlt | 1.36 | %endif |
12 | |||
13 | argiro | 1.1 | %prep |
14 | elmer | 1.12 | %setup -n %realversion/CLHEP |
15 | elmer | 1.33 | # Apply the patch only for MacOSX and gcc45 (test builds as of Dec2010) |
16 | # (Technically these aren't guaranteed to be mutually exclusive, but in | ||
17 | # practice they are at the moment.) | ||
18 | elmer | 1.35 | %patch -p1 |
19 | argiro | 1.1 | |
20 | %build | ||
21 | davidlt | 1.36 | CXX="%cms_cxx" CXXFLAGS="%cms_cxxflags" ./configure --prefix=%i |
22 | argiro | 1.1 | make |
23 | |||
24 | argiro | 1.2 | #mkdir -p shared-tmp |
25 | #cd shared-tmp | ||
26 | #case $(uname) in | ||
27 | # Darwin ) so=dylib shared="-dynamiclib -single_module" flags= ;; | ||
28 | # * ) so=so shared="-shared" flags="-D_GNU_SOURCE" ;; | ||
29 | #esac | ||
30 | # | ||
31 | #set -x | ||
32 | #cp -i ../Evaluator/*.cc . | ||
33 | #cp -i ../Evaluator/*.src . | ||
34 | #cp -i ../GenericFunctions/*.cc . | ||
35 | #cp -i ../Geometry/*.cc . | ||
36 | #cp -i ../Matrix/*.cc . | ||
37 | #cp -i ../Random/*.cc . | ||
38 | #cp -i ../Random/*.src . | ||
39 | #cp -i ../Random/*.cdat . | ||
40 | #cp -i ../RandomObjects/*.cc . | ||
41 | #cp -i ../Vector/*.cc . | ||
42 | #cp -i ../HepPDT/*.cc . | ||
43 | #cp -i ../HepMC/*.cc . | ||
44 | #cp -i ../StdHep/*.cc . | ||
45 | #for f in *.cc; do | ||
46 | # g++ -c -O2 -ansi -Wall -fPIC -I../.. $flags $f | ||
47 | #done | ||
48 | elmer | 1.12 | #g++ $shared -o libCLHEP-g++.%realversion.$so *.o |
49 | argiro | 1.1 | |
50 | %install | ||
51 | case $(uname) in Darwin ) so=dylib ;; * ) so=so ;; esac | ||
52 | make install | ||
53 | argiro | 1.2 | #cd shared-tmp |
54 | elmer | 1.12 | #cp libCLHEP-g++.%realversion.$so %i/lib |
55 | #ln -s libCLHEP-g++.%realversion.$so %i/lib/libCLHEP.$so | ||
56 | #n -s libCLHEP-g++.%realversion.a %i/lib/libCLHEP.a | ||
57 | dlange | 1.14 | #remove the .a files |
58 | rm %i/lib/*.a | ||
59 | andreasp | 1.20 | # remove the separate libs: |
60 | rm %i/lib/libCLHEP-[A-Z]*-%realversion.$so | ||
61 | dlange | 1.14 | |
62 | eulisse | 1.4 | %post |
63 | %{relocateConfig}bin/Evaluator-config | ||
64 | %{relocateConfig}bin/Cast-config | ||
65 | %{relocateConfig}bin/GenericFunctions-config | ||
66 | %{relocateConfig}bin/Exceptions-config | ||
67 | %{relocateConfig}bin/RandomObjects-config | ||
68 | %{relocateConfig}bin/Geometry-config | ||
69 | %{relocateConfig}bin/Matrix-config | ||
70 | %{relocateConfig}bin/Random-config | ||
71 | %{relocateConfig}bin/RefCount-config | ||
72 | %{relocateConfig}bin/Units-config | ||
73 | %{relocateConfig}bin/Vector-config | ||
74 | %{relocateConfig}bin/clhep-config |