ViewVC Help
View File | Revision Log | Show Annotations | Root Listing
root/cvsroot/COMP/CMSDIST/clhep.spec
Revision: 1.32
Committed: Thu Dec 2 09:45:16 2010 UTC (14 years, 4 months ago) by elmer
Branch: MAIN
CVS Tags: CMSSW_3_10_1, smFor3101, sm110117, fwFor3100xdaq11b4online, CMSSW_3_11_0_pre3, smFor3110pre3a, smFor3110pre3, pe20101230-311XAB, CMSSW_3_11_0_pre2, pe20101229-for311X, fwFor311pre2, CMSSW_3_10_0, smFor3100c, pe20101221a-for3100p9io, smFor3100b, smFor3100a, smFor3100, pe20101217b-for3100p9io, pe20101217a-for3100p9io, CMSSW_3_11_0_pre1, fwFor311pre1, CMSSW_3_10_0_pre9r52706b, pe20101215-for3100p9r52706b, CMSSW_3_10_0_pre9, smFor3100pre9a, smFor3100pre9, CMSSW_3_10_0_pre7g494c1, smFor3100pre7G494C1a, pe20101202a-for310Xrb
Changes since 1.31: +1 -1 lines
Log Message:
  Update to version 2.0.4.6

File Contents

# User Rev Content
1 elmer 1.32 ### RPM external clhep 2.0.4.6
2 elmer 1.27 Source: http://proj-clhep.web.cern.ch/proj-clhep/DISTRIBUTION/distributions/%n-%realversion.tgz
3 dlange 1.25
4 argiro 1.1 %prep
5 elmer 1.12 %setup -n %realversion/CLHEP
6 argiro 1.1
7     %build
8 elmer 1.9 if [ $(uname) = Darwin ]; then
9     export MACOSX_DEPLOYMENT_TARGET="10.4"
10     fi
11 argiro 1.1 CXX=g++ ./configure --prefix=%i
12     make
13    
14 argiro 1.2 #mkdir -p shared-tmp
15     #cd shared-tmp
16     #case $(uname) in
17     # Darwin ) so=dylib shared="-dynamiclib -single_module" flags= ;;
18     # * ) so=so shared="-shared" flags="-D_GNU_SOURCE" ;;
19     #esac
20     #
21     #set -x
22     #cp -i ../Evaluator/*.cc .
23     #cp -i ../Evaluator/*.src .
24     #cp -i ../GenericFunctions/*.cc .
25     #cp -i ../Geometry/*.cc .
26     #cp -i ../Matrix/*.cc .
27     #cp -i ../Random/*.cc .
28     #cp -i ../Random/*.src .
29     #cp -i ../Random/*.cdat .
30     #cp -i ../RandomObjects/*.cc .
31     #cp -i ../Vector/*.cc .
32     #cp -i ../HepPDT/*.cc .
33     #cp -i ../HepMC/*.cc .
34     #cp -i ../StdHep/*.cc .
35     #for f in *.cc; do
36     # g++ -c -O2 -ansi -Wall -fPIC -I../.. $flags $f
37     #done
38 elmer 1.12 #g++ $shared -o libCLHEP-g++.%realversion.$so *.o
39 argiro 1.1
40     %install
41     case $(uname) in Darwin ) so=dylib ;; * ) so=so ;; esac
42     make install
43 argiro 1.2 #cd shared-tmp
44 elmer 1.12 #cp libCLHEP-g++.%realversion.$so %i/lib
45     #ln -s libCLHEP-g++.%realversion.$so %i/lib/libCLHEP.$so
46     #n -s libCLHEP-g++.%realversion.a %i/lib/libCLHEP.a
47 dlange 1.14 #remove the .a files
48     rm %i/lib/*.a
49 andreasp 1.20 # remove the separate libs:
50     rm %i/lib/libCLHEP-[A-Z]*-%realversion.$so
51 dlange 1.14
52 eulisse 1.4 %post
53     %{relocateConfig}bin/Evaluator-config
54     %{relocateConfig}bin/Cast-config
55     %{relocateConfig}bin/GenericFunctions-config
56     %{relocateConfig}bin/Exceptions-config
57     %{relocateConfig}bin/RandomObjects-config
58     %{relocateConfig}bin/Geometry-config
59     %{relocateConfig}bin/Matrix-config
60     %{relocateConfig}bin/Random-config
61     %{relocateConfig}bin/RefCount-config
62     %{relocateConfig}bin/Units-config
63     %{relocateConfig}bin/Vector-config
64     %{relocateConfig}bin/clhep-config