ViewVC Help
View File | Revision Log | Show Annotations | Root Listing
root/cvsroot/COMP/CMSDIST/cmssw-validation.spec
Revision: 1.3
Committed: Mon Jan 30 13:52:47 2012 UTC (13 years, 3 months ago) by eulisse
Branch: MAIN
Changes since 1.2: +14 -9 lines
Log Message:
Run runTheMatrix -s as well.

File Contents

# User Rev Content
1 eulisse 1.2 ### RPM cms cmssw-validation 1.0.0
2 davidlt 1.1
3     Requires: cmssw SCRAMV1
4     Source: none
5    
6     %define scram $SCRAMV1_ROOT/bin/scram --arch %cmsplatf
7    
8     %prep
9     %scram project CMSSW $CMSSW_VERSION
10     cd $CMSSW_VERSION
11     %scram build clean
12     eval `%scram runtime -sh`
13 eulisse 1.2 #rsync -av $CMSSW_RELEASE_BASE/src/ src/
14 davidlt 1.1
15     %build
16     cd $CMSSW_VERSION
17     eval `%scram runtime -sh`
18 eulisse 1.3 rm -rf test-addontests test-runTheMatrix
19 davidlt 1.1 mkdir test-addontests
20 eulisse 1.3 pushd test-addontests
21     BEGIN_TT=`date +%s`
22     addOnTests.py -j %compiling_processes &> result.log
23     END_TT=`date +%s`
24     DIFF_TT=$((END_TT - BEGIN_TT))
25 davidlt 1.1
26 eulisse 1.3 PASSED_TESTS=`cat result.log | awk '/tests passed/ { print $1 }'`
27     FAILED_TESTS=`cat result.log | awk '/tests passed/ { print $4 }'`
28     popd
29     # Do runTheMatrix.py (let's start with -s)
30     mkdir test-runTheMatrix
31     pushd test-addontests
32     runTheMatrix.py -s
33     popd
34 davidlt 1.1
35     # TODO: Add logs to the package or send them directly to the DB.
36     %install
37     # NOP
38    
39     %post
40     # NOP