ViewVC Help
View File | Revision Log | Show Annotations | Root Listing
root/cvsroot/COMP/CMSDIST/cmsswdata-toolfile.spec
Revision: 1.1
Committed: Tue Aug 10 14:20:14 2010 UTC (14 years, 8 months ago) by muzaffar
Branch: MAIN
CVS Tags: pe20100922b-for39Xrb, pe20100922a-for39Xrb, pe20100908b-for39Xrb, pe20100908a-for39Xrb, pe20100907c-for39Xrb, pe20100907b-for39Xrb, pe20100907a-for39Xrb, pe20100906a-for39Xrb, pe20100902a-for39Xrb, pe20100901b-for39Xrb, pe20100901a-for39Xrb, pe20100830c-for39Xrb, pe20100830b-for39Xrb, pe20100830a-for39Xrb, pe20100829a-for39Xrb, pe20100827a-for39Xrb, sm100826a, pe20100826a-for39Xrb, pe20100825b-for39Xrb, pe20100825a-for39Xrb, pe20100824c-for39Xrb, pe20100824b-for39Xrb, sm100824a, pe20100824a-for39Xrb, sm100811b, sm100811a, sm20100810a
Log Message:
added new spec files to define the scram tools

File Contents

# User Rev Content
1 muzaffar 1.1 ### RPM cms cmsswdata-toolfile 1.0
2     Requires: cmsswdata
3     %prep
4    
5     %build
6    
7     %install
8    
9     mkdir -p %i/etc/scram.d
10     cat << \EOF_TOOLFILE >%i/etc/scram.d/cmsswdata.xml
11     <tool name="cmsswdata" version="@TOOL_VERSION@">
12     <client>
13     <environment name="CMSSWDATA_BASE" default="%{instroot}/%{cmsplatf}/%{pkgcategory}"/>
14     <environment name="CMSSW_DATA_PATH" default="$CMSSWDATA_BASE"/>
15     </client>
16     <runtime name="CMSSW_DATA_PATH" value="$CMSSWDATA_BASE" handler="warn" type="path"/>
17     EOF_TOOLFILE
18     for tool in `echo %requiredtools | tr ' ' '\n' | grep 'data-'` ; do
19     uctool=`echo $tool | tr '-' '_' | tr '[a-z]' '[A-Z]'`
20     toolbase=`perl -e 'print "$ENV{'$uctool'_ROOT}\n";'`
21     echo "$uctool = $toolbase"
22     if [ "X$toolbase" = X -o ! -d $toolbase/etc ] ; then continue ; fi
23     echo "<runtime name=\"CMSSW_SEARCH_PATH\" default=\"$toolbase\" handler=\"warn\" type=\"path\"/>" >> %i/etc/scram.d/cmsswdata.xml
24     done
25     echo "</tool>" >> %i/etc/scram.d/cmsswdata.xml
26    
27     ## IMPORT scram-tools-post