1 |
elmer |
1.21 |
### RPM cms cmsswdata 19.0d
|
2 |
muzaffar |
1.1 |
Source: none
|
3 |
|
|
|
4 |
|
|
Requires: data-FastSimulation-MaterialEffects
|
5 |
|
|
Requires: data-FastSimulation-PileUpProducer
|
6 |
|
|
Requires: data-Geometry-CaloTopology
|
7 |
|
|
Requires: data-MagneticField-Interpolation
|
8 |
|
|
Requires: data-RecoParticleFlow-PFBlockProducer
|
9 |
dlange |
1.4 |
Requires: data-RecoParticleFlow-PFTracking
|
10 |
muzaffar |
1.1 |
Requires: data-RecoTracker-RingESSource
|
11 |
|
|
Requires: data-RecoTracker-RoadMapESSource
|
12 |
|
|
Requires: data-SimG4CMS-Calo
|
13 |
|
|
Requires: data-Validation-EcalDigis
|
14 |
|
|
Requires: data-Validation-EcalHits
|
15 |
|
|
Requires: data-Validation-EcalRecHits
|
16 |
|
|
Requires: data-Validation-Geometry
|
17 |
|
|
Requires: data-Validation-HcalHits
|
18 |
|
|
Requires: data-RecoMuon-MuonIdentification
|
19 |
|
|
Requires: data-CondCore-SQLiteData
|
20 |
|
|
|
21 |
|
|
%prep
|
22 |
|
|
%build
|
23 |
|
|
%install
|
24 |
|
|
# SCRAM ToolBox toolfile
|
25 |
|
|
mkdir -p %i/etc/scram.d
|
26 |
|
|
cat << \EOF_TOOLFILE >%i/etc/scram.d/%n
|
27 |
|
|
<doc type=BuildSystem::ToolDoc version=1.0>
|
28 |
|
|
<Tool name=CMSSWData version=%v>
|
29 |
|
|
<Client>
|
30 |
|
|
<Environment name=CMSSWDATA_BASE default="%{instroot}/%{cmsplatf}/%{pkgcategory}"></Environment>
|
31 |
|
|
<Environment name=CMSSW_DATA_PATH default="$CMSSWDATA_BASE"></Environment>
|
32 |
|
|
</Client>
|
33 |
|
|
<Runtime name=CMSSW_DATA_PATH value="$CMSSWDATA_BASE" type=path handler=warn>
|
34 |
|
|
EOF_TOOLFILE
|
35 |
|
|
for tool in `echo %requiredtools | tr ' ' '\n' | grep 'data-'` ; do
|
36 |
|
|
uctool=`echo $tool | tr '-' '_' | tr '[a-z]' '[A-Z]'`
|
37 |
|
|
toolbase=`perl -e 'print "$ENV{'$uctool'_ROOT}\n";'`
|
38 |
|
|
echo "$uctool = $toolbase"
|
39 |
|
|
if [ "X$toolbase" = X -o ! -d $toolbase/etc ] ; then continue ; fi
|
40 |
|
|
echo "<Runtime name=CMSSW_SEARCH_PATH default=\"$toolbase\" type=path handler=warn>" >> %i/etc/scram.d/%n
|
41 |
|
|
done
|
42 |
|
|
echo "</Tool>" >> %i/etc/scram.d/%n
|
43 |
|
|
|
44 |
|
|
%post
|
45 |
|
|
%{relocateConfig}etc/scram.d/%n
|