1 |
muzaffar |
1.128 |
### RPM cms coral CORAL_2_3_0_pre2
|
2 |
elmer |
1.117 |
## IMPORT configurations
|
3 |
muzaffar |
1.39 |
Provides: /bin/zsh
|
4 |
ratnik |
1.107 |
Provides: libexpat.so.0
|
5 |
eulisse |
1.1 |
Requires: coral-tool-conf
|
6 |
muzaffar |
1.128 |
%define online %(case %cmsplatf in *onl_*_*) echo true ;; esac)
|
7 |
andreasp |
1.127 |
|
8 |
muzaffar |
1.54 |
%define cvsprojuc %(echo %n | sed -e "s|-debug||"| tr 'a-z' 'A-Z')
|
9 |
|
|
%define cvsprojlc %(echo %cvsprojuc | tr 'A-Z' 'a-z')
|
10 |
|
|
%define cvsdir %cvsprojlc
|
11 |
|
|
%define cvsserver %cvsprojlc
|
12 |
muzaffar |
1.128 |
%define preBuildCommand (rm -rf LFCLookupService LFCReplicaService MySQLAccess)
|
13 |
muzaffar |
1.54 |
%define prebuildtarget prebuild
|
14 |
|
|
%define buildtarget release-build
|
15 |
ratnik |
1.103 |
|
16 |
muzaffar |
1.128 |
%if "%online" == "true"
|
17 |
ratnik |
1.107 |
# Disable building tests in online release,
|
18 |
|
|
# since they bring dependency on cppunit:
|
19 |
|
|
%define patchsrc4 perl -p -i -e 's!(<classpath.*/tests\\+.*>)!!;' config/BuildFile.xml
|
20 |
muzaffar |
1.128 |
%define patchsrc5 rm -rf src/UnitTests
|
21 |
ratnik |
1.107 |
%endif
|
22 |
|
|
|
23 |
andreasp |
1.127 |
%if "%(echo %{cmsos} | cut -d_ -f 1 | sed -e 's|osx.*|osx|')" == "osx"
|
24 |
|
|
%define patchsrc4 echo "<use name=boost>" >>src/UnitTests/BuildFile
|
25 |
|
|
# Disable building tests, since they bring dependency on cppunit:
|
26 |
|
|
%define patchsrc5 perl -p -i -e 's!(<classpath.*/tests\\+.*>)!!;' config/BuildFile.xml
|
27 |
|
|
%define patchsrc %patch -p0
|
28 |
|
|
%define patchsrc1 %patch1 -p0
|
29 |
|
|
%endif
|
30 |
|
|
|
31 |
eulisse |
1.1 |
## IMPORT lcg-scram-build
|
32 |
muzaffar |
1.54 |
## IMPORT cms-scram-build
|
33 |
ratnik |
1.37 |
## IMPORT scramv1-build
|