1 |
argiro |
1.25 |
### RPM lcg coral CORAL_1_5_3-forCMS141b
|
2 |
eulisse |
1.13 |
## IMPORT configurations
|
3 |
eulisse |
1.1 |
Requires: coral-tool-conf
|
4 |
eulisse |
1.13 |
%define confversion %lcgConfiguration
|
5 |
eulisse |
1.1 |
%define toolconf ${CORAL_TOOL_CONF_ROOT}/configurations/tools-STANDALONE.conf
|
6 |
eulisse |
1.5 |
%define cvsdir coral
|
7 |
|
|
%define cvsserver CORAL
|
8 |
|
|
%define srctree coral
|
9 |
eulisse |
1.7 |
%define configtree coral/config/scram
|
10 |
eulisse |
1.2 |
# This allows to compile CORAL on linux systems that are not recognized as slc3 but still linux based.
|
11 |
eulisse |
1.10 |
%define patchsrc if [ "%cmsplatf" != "slc3_ia32_gcc323" ] && [ "$(uname)" = "Linux" ]; then cp %{configtree}/slc3_ia32_gcc323.mk %{configtree}/%{cmsplatf}.mk; fi
|
12 |
eulisse |
1.15 |
%define patchsrc2 perl -p -i -e "s|(project name=CORAL version=).*>|project name=CORAL version=%v>/BootStrapFileSRC|" %{configtree}/BootStrapFileSRC
|
13 |
eulisse |
1.16 |
%define patchsrc3 rm -rf %{srctree}/SQLiteAccess/tests
|
14 |
eulisse |
1.6 |
%define patchinstall mkdir -p %{i}/include; for x in `ls %{i}/src`; do if [ -d %{i}/src/$x/$x ]; then cp -r %{i}/src/$x/$x %{i}/include; fi ; done
|
15 |
eulisse |
1.5 |
|
16 |
|
|
%define conflevel _1
|
17 |
|
|
# FIXME: Remove when it successfully builds... should just be release
|
18 |
|
|
%define buildtarget release-build release-docs release-freeze
|
19 |
|
|
#%define buildtarget %{nil}
|
20 |
|
|
|
21 |
eulisse |
1.1 |
## IMPORT lcg-scram-build
|
22 |
|
|
## IMPORT scram-build
|
23 |
eulisse |
1.18 |
#
|