1 |
eulisse |
1.1 |
### RPM configuration cppunit-toolfile 1.10.2
|
2 |
|
|
## IMPORT scramtoolbox-common
|
3 |
|
|
|
4 |
|
|
Source: none
|
5 |
|
|
Requires: cppunit
|
6 |
|
|
|
7 |
|
|
%build
|
8 |
|
|
%install
|
9 |
|
|
mkdir -p %toolConfDir %toolBoxDir/TestingTools
|
10 |
|
|
|
11 |
|
|
cat << \EOF_cppunit_TOOLCONF_FRAGMENT > %toolConfDir/cppunit.conf
|
12 |
|
|
TOOL:cppunit
|
13 |
|
|
+CPPUNIT_BASE:${CPPUNIT_ROOT}
|
14 |
|
|
+PATH:${CPPUNIT_ROOT}/bin
|
15 |
|
|
+LIBDIR:${CPPUNIT_ROOT}/lib
|
16 |
|
|
+INCLUDE:${CPPUNIT_ROOT}/include
|
17 |
|
|
EOF_cppunit_TOOLCONF_FRAGMENT
|
18 |
|
|
|
19 |
|
|
cat << \EOF_cppunit_TOOLFILE > %toolBoxDir/TestingTools/cppunit
|
20 |
|
|
<doc type=BuildSystem::ToolDoc version=1.0>
|
21 |
|
|
<tool name=%toolname version=%v>
|
22 |
|
|
<architecture name=macosx>
|
23 |
|
|
<lib name=cppunit>
|
24 |
|
|
</architecture>
|
25 |
|
|
<architecture name=osx>
|
26 |
|
|
<lib name=cppunit>
|
27 |
|
|
</architecture>
|
28 |
|
|
<architecture name=sl>
|
29 |
|
|
<lib name=cppunit>
|
30 |
|
|
</architecture>
|
31 |
|
|
<architecture name=win>
|
32 |
|
|
<lib name=cppunit_dll>
|
33 |
|
|
</architecture>
|
34 |
|
|
<client>
|
35 |
|
|
<environment name=CPPUNIT_BASE>
|
36 |
|
|
The top of the CPpUnit distribution.
|
37 |
|
|
</environment>
|
38 |
|
|
<environment name=LIBDIR default="$CPPUNIT_BASE/lib" type=lib>
|
39 |
|
|
Location of CppUnit libraries.
|
40 |
|
|
</environment>
|
41 |
|
|
<environment name=INCLUDE default="$CPPUNIT_BASE/include">
|
42 |
|
|
Location of CppUnit include files.
|
43 |
|
|
</environment>
|
44 |
|
|
</client>
|
45 |
|
|
<environment name=LD_LIBRARY_PATH value="$LIBDIR" type=Runtime_path></environment>
|
46 |
|
|
<architecture name=win>
|
47 |
|
|
<environment name=PATH value="$LIBDIR" type=Runtime_path></environment>
|
48 |
|
|
</architecture>
|
49 |
|
|
</tool>
|
50 |
|
|
EOF_cppunit_TOOLFILE
|
51 |
|
|
%files
|
52 |
|
|
%toolBoxDir/TestingTools/cppunit
|
53 |
|
|
%toolConfDir/cppunit.conf
|