ViewVC Help
View File | Revision Log | Show Annotations | Root Listing
root/cvsroot/COMP/CMSDIST/cppunit.spec
Revision: 1.20
Committed: Tue Jul 6 08:34:43 2010 UTC (14 years, 9 months ago) by muzaffar
Branch: MAIN
CVS Tags: ge20100722-rpm-osx-64-bit
Changes since 1.19: +11 -12 lines
Log Message:
converted tools files to xml format

File Contents

# User Rev Content
1 elmer 1.18 ### RPM external cppunit 1.12.1
2 elmer 1.10 Source0: http://switch.dl.sourceforge.net/sourceforge/%n/%n-%realversion.tar.gz
3 eulisse 1.1 Source1: http://spi.cvs.cern.ch:8180/cgi-bin/spi.cgi/*checkout*/Components/UnitTesting/Tools/CppUnit/CppUnit_testdriver.cpp?rev=1.1
4 elmer 1.10
5     %prep
6     %setup -n %n-%realversion
7    
8 eulisse 1.2 %build
9 eulisse 1.16 case %cmsplatf in
10     osx105* ) perl -p -i -e 's|rm(.*)conftest|rm -fr $1 conftest|g' configure \
11     aclocal.m4 \
12     libtool \
13     config/ltmain.sh
14     ;;
15     esac
16 elmer 1.19 case $(uname) in
17     Linux )
18     # Ugly hack to force -ldl to be linked, which for some reason is
19     # not currently happening via configure
20     perl -p -i -e 's|LIBS.*LIBS.*lm|LIBS="$LIBS -lm -ldl|' configure
21     ;;
22     esac
23 eulisse 1.16 ./configure --prefix=%i
24 eulisse 1.2 make %makeprocesses
25 eulisse 1.1 %install
26     make install
27     cp %_sourcedir/CppUnit_testdriver.cpp* %i/include/CppUnit_testdriver.cpp
28 muzaffar 1.12
29     # SCRAM ToolBox toolfile
30     mkdir -p %i/etc/scram.d
31 muzaffar 1.20 cat << \EOF_TOOLFILE >%i/etc/scram.d/%n.xml
32     <tool name="%n" version="%v">
33     <lib name="cppunit"/>
34     <client>
35     <environment name="CPPUNIT_BASE" default="%i"/>
36     <environment name="LIBDIR" default="$CPPUNIT_BASE/lib"/>
37     <environment name="INCLUDE" default="$CPPUNIT_BASE/include"/>
38     </client>
39     <use name="sockets"/>
40     </tool>
41 muzaffar 1.12 EOF_TOOLFILE
42    
43 eulisse 1.6 %post
44     %{relocateConfig}/bin/cppunit-config
45 eulisse 1.7 %{relocateConfig}/lib/libcppunit.la
46 muzaffar 1.20 %{relocateConfig}etc/scram.d/%n.xml