1 |
### RPM external cppunit 1.12.1
|
2 |
Source0: http://switch.dl.sourceforge.net/sourceforge/%n/%n-%realversion.tar.gz
|
3 |
Source1: http://spi.cvs.cern.ch:8180/cgi-bin/spi.cgi/*checkout*/Components/UnitTesting/Tools/CppUnit/CppUnit_testdriver.cpp?rev=1.1
|
4 |
|
5 |
%prep
|
6 |
%setup -n %n-%realversion
|
7 |
|
8 |
%build
|
9 |
case %cmsplatf in
|
10 |
osx105* ) perl -p -i -e 's|rm(.*)conftest|rm -fr $1 conftest|g' configure \
|
11 |
aclocal.m4 \
|
12 |
libtool \
|
13 |
config/ltmain.sh
|
14 |
;;
|
15 |
esac
|
16 |
case $(uname) in
|
17 |
Linux )
|
18 |
# Ugly hack to force -ldl to be linked, which for some reason is
|
19 |
# not currently happening via configure
|
20 |
perl -p -i -e 's|LIBS.*LIBS.*lm|LIBS="$LIBS -lm -ldl|' configure
|
21 |
;;
|
22 |
esac
|
23 |
./configure --prefix=%i
|
24 |
make %makeprocesses
|
25 |
%install
|
26 |
make install
|
27 |
cp %_sourcedir/CppUnit_testdriver.cpp* %i/include/CppUnit_testdriver.cpp
|
28 |
|
29 |
%post
|
30 |
%{relocateConfig}/bin/cppunit-config
|
31 |
%{relocateConfig}/lib/libcppunit.la
|