1 |
afanfani |
1.7 |
### RPM cms crab-server CRABSERVER_0_0_2
|
2 |
afanfani |
1.1 |
## INITENV +PATH PYTHONPATH %i/lib
|
3 |
|
|
|
4 |
|
|
%define cvstag %v
|
5 |
|
|
Source: cvs://:pserver:anonymous@cmscvs.cern.ch:2401/cvs_server/repositories/CMSSW?passwd=AA_:yZZ3e&module=CRAB/CRABSERVER&export=CRAB&&tag=-r%{cvstag}&output=/CRABSERVER.tar.gz
|
6 |
|
|
Requires: python boss dbs-client dls prodcommon prodagent
|
7 |
|
|
|
8 |
|
|
%prep
|
9 |
|
|
%setup -n CRAB
|
10 |
|
|
%build
|
11 |
|
|
|
12 |
|
|
echo "PWD=$PWD"
|
13 |
|
|
#cd CRABSERVER
|
14 |
|
|
#echo "PWD=$PWD"
|
15 |
|
|
mv CRABSERVER/* .
|
16 |
|
|
|
17 |
|
|
%install
|
18 |
|
|
make PREFIX=%i install
|
19 |
|
|
mkdir -p %i/bin
|
20 |
|
|
cp bin/* %{i}/bin
|
21 |
|
|
mkdir -p %{i}/etc/profile.d
|
22 |
|
|
|
23 |
|
|
|
24 |
|
|
(echo "#!/bin/sh"; \
|
25 |
|
|
echo "source $PYTHON_ROOT/etc/profile.d/init.sh"; \
|
26 |
|
|
echo "source $DBS_CLIENT_ROOT/etc/profile.d/init.sh"; \
|
27 |
|
|
echo "source $DLS_ROOT/etc/profile.d/init.sh"; \
|
28 |
|
|
echo "source $PRODCOMMON_ROOT/etc/profile.d/init.sh"; \
|
29 |
|
|
echo "source $PRODAGENT_ROOT/etc/profile.d/init.sh"; \
|
30 |
|
|
echo "source $BOSS_ROOT/etc/profile.d/init.sh" ) > %{i}/etc/profile.d/dependencies-setup.sh
|
31 |
|
|
|
32 |
|
|
(echo "#!/bin/tcsh"; \
|
33 |
|
|
echo "source $PYTHON_ROOT/etc/profile.d/init.csh"; \
|
34 |
|
|
echo "source $DBS_CLIENT_ROOT/etc/profile.d/init.csh"; \
|
35 |
|
|
echo "source $DLS_ROOT/etc/profile.d/init.csh"; \
|
36 |
|
|
echo "source $PRODCOMMON_ROOT/etc/profile.d/init.csh"; \
|
37 |
|
|
echo "source $PRODAGENT_ROOT/etc/profile.d/init.csh"; \
|
38 |
|
|
echo "source $BOSS_ROOT/etc/profile.d/init.csh" ) > %{i}/etc/profile.d/dependencies-setup.csh
|
39 |
|
|
|
40 |
|
|
%post
|
41 |
|
|
%{relocateConfig}etc/profile.d/dependencies-setup.sh
|
42 |
|
|
%{relocateConfig}etc/profile.d/dependencies-setup.csh
|