ViewVC Help
View File | Revision Log | Show Annotations | Root Listing
root/cvsroot/COMP/CMSDIST/crab.spec
Revision: 1.23
Committed: Thu Mar 8 17:18:23 2012 UTC (13 years, 1 month ago) by spiga
Branch: MAIN
CVS Tags: HEAD
Changes since 1.22: +0 -0 lines
State: FILE REMOVED
Log Message:
remove obsolete file

File Contents

# Content
1 ### RPM cms crab 1201a
2
3 # This is a meta-package to group all cms webtools services from comp repository
4
5 Requires: crab-client3 crab-server3 asyncstageout
6
7 %prep
8 %build
9 %install
10
11 # Generate dependencies-setup.{sh,csh} so init.{sh,csh} picks full environment.
12 rm -rf %i/etc/profile.d
13 mkdir -p %i/etc/profile.d
14 for tool in $(echo %{requiredtools} | sed -e's|\s+| |;s|^\s+||'); do
15 root=$(echo $tool | tr a-z- A-Z_)_ROOT; eval r=\$$root
16 if [ X"$r" != X ] && [ -r "$r/etc/profile.d/init.sh" ]; then
17 echo "test X\$$root != X || . $r/etc/profile.d/init.sh" >> %i/etc/profile.d/dependencies-setup.sh
18 echo "test X\$$root != X || source $r/etc/profile.d/init.csh" >> %i/etc/profile.d/dependencies-setup.csh
19 fi
20 done
21
22 %post
23 # The relocation is also needed because of dependencies
24 %{relocateConfig}etc/profile.d/dependencies-setup.*sh