1 |
### RPM cms dbs-apps DBS_2_0_4
|
2 |
|
3 |
#Requires: dbs-server dbs-client dbs-schema dbs-light dbs-web
|
4 |
Requires: dbs-server dbs-client dbs-schema dbs-web
|
5 |
Source: none
|
6 |
|
7 |
%prep
|
8 |
cd %_builddir
|
9 |
mkdir dbs-apps-dummy
|
10 |
cd dbs-apps-dummy
|
11 |
cp -f %_sourcedir/none .
|
12 |
%build
|
13 |
%install
|
14 |
mkdir -p %{i}/bin
|
15 |
mkdir -p %{i}/lib
|
16 |
mkdir -p %{i}/etc/profile.d
|
17 |
|
18 |
(echo "#!/bin/sh"; \
|
19 |
echo "source $DBS_SERVER_ROOT/etc/profile.d/init.sh"; \
|
20 |
echo "source $DBS_CLIENT_ROOT/etc/profile.d/init.sh"; \
|
21 |
echo "source $DBS_SCHEMA_ROOT/etc/profile.d/init.sh"; \
|
22 |
echo "source $DBS_LIGHT_ROOT/etc/profile.d/init.sh"; \
|
23 |
echo "source $DBS_WEB_ROOT/etc/profile.d/init.sh"; \
|
24 |
) > %{i}/etc/profile.d/dependencies-setup.sh
|
25 |
|
26 |
(echo "#!/bin/tcsh"; \
|
27 |
echo "source $DBS_SERVER_ROOT/etc/profile.d/init.csh"; \
|
28 |
echo "source $DBS_CLIENT_ROOT/etc/profile.d/init.csh"; \
|
29 |
echo "source $DBS_SCHEMA_ROOT/etc/profile.d/init.csh"; \
|
30 |
echo "source $DBS_LIGHT_ROOT/etc/profile.d/init.csh"; \
|
31 |
echo "source $DBS_WEB_ROOT/etc/profile.d/init.csh"; \
|
32 |
) > %{i}/etc/profile.d/dependencies-setup.csh
|
33 |
|
34 |
%post
|
35 |
%{relocateConfig}etc/profile.d/dependencies-setup.sh
|
36 |
%{relocateConfig}etc/profile.d/dependencies-setup.csh
|