ViewVC Help
View File | Revision Log | Show Annotations | Root Listing
root/cvsroot/COMP/CMSDIST/dbs-client.spec
Revision: 1.57
Committed: Tue Jul 15 19:13:36 2008 UTC (16 years, 9 months ago) by valya
Branch: MAIN
CVS Tags: WEBTOOLS-APPS_20080715_1
Changes since 1.56: +0 -1 lines
Log Message:
Need to generate new RPMs

File Contents

# User Rev Content
1 valya 1.56 ### RPM cms dbs-client DBS_1_2_3
2 valya 1.46 ## INITENV +PATH PYTHONPATH %i/lib/
3 valya 1.50
4 metson 1.43 %define cvstag %{realversion}
5 metson 1.44 %define cvsserver cvs://:pserver:anonymous@cmscvs.cern.ch:2401/cvs_server/repositories/CMSSW?passwd=AA_:yZZ3e
6 metson 1.45 Source: %cvsserver&strategy=checkout&module=DBS/Clients/Python&nocache=true&export=DBS&tag=-r%{cvstag}&output=/dbs-client.tar.gz
7 valya 1.36 Requires: python openssl py2-zsi
8 eulisse 1.1
9     %prep
10 metson 1.41 %setup -n DBS
11 eulisse 1.1 %build
12     (make DBSHOME=%_builddir/DBS/Clients/Python )
13    
14     %install
15 valya 1.3 mkdir -p %{i}/bin
16     mkdir -p %{i}/lib
17 valya 1.6 mkdir -p %{i}/etc/profile.d
18 valya 1.3 cp -r Clients/Python/* %{i}/lib/
19 eulisse 1.1
20 valya 1.6 (echo "#!/bin/sh"; \
21     echo "source $PYTHON_ROOT/etc/profile.d/init.sh"; \
22 valya 1.8 echo "source $OPENSSL_ROOT/etc/profile.d/init.sh"; \
23 valya 1.42 echo "source $PY2_ZSI_ROOT/etc/profile.d/init.sh"; \
24 valya 1.6 ) > %{i}/etc/profile.d/dependencies-setup.sh
25    
26     (echo "#!/bin/tcsh"; \
27     echo "source $PYTHON_ROOT/etc/profile.d/init.csh"; \
28 valya 1.8 echo "source $OPENSSL_ROOT/etc/profile.d/init.csh"; \
29 valya 1.42 echo "source $PY2_ZSI_ROOT/etc/profile.d/init.csh"; \
30 valya 1.6 ) > %{i}/etc/profile.d/dependencies-setup.csh
31    
32 dlange 1.47 # SCRAM ToolBox toolfile
33     mkdir -p %i/etc/scram.d
34     cat << \EOF_TOOLFILE >%i/etc/scram.d/%n
35     <doc type=BuildSystem::ToolDoc version=1.0>
36     <Tool name=dbs-client version=%v>
37     <client>
38     <Environment name=DBS_CLIENT_BASE default="%i"></Environment>
39     </client>
40     <Runtime name=PATH value="$DBS_CLIENT_BASE/bin" type=path>
41     </Tool>
42     EOF_TOOLFILE
43    
44 valya 1.6 %post
45     %{relocateConfig}etc/profile.d/dependencies-setup.sh
46     %{relocateConfig}etc/profile.d/dependencies-setup.csh
47 dlange 1.47 %{relocateConfig}etc/scram.d/%n