ViewVC Help
View File | Revision Log | Show Annotations | Root Listing
root/cvsroot/COMP/CMSDIST/dbs-libs.spec
Revision: 1.9
Committed: Thu Nov 13 02:14:04 2008 UTC (16 years, 5 months ago) by valya
Branch: MAIN
CVS Tags: DBS-APPS_20081126_1, DBS-APPS_20081126, DBS-APPS_20081125, testofc, DBS-APPS_20081119, DBS-APPS_20081118, DBS-APPS_20081117, DBS-APPS_20081114_1, DBS-APPS_20081114, DBS-APPS_20081112
Changes since 1.8: +1 -1 lines
Log Message:
DBS new tag

File Contents

# Content
1 ### RPM cms dbs-libs DBS_2_0_4
2 ## INITENV +PATH PYTHONPATH %i/lib/
3
4 %define cvstag %{realversion}
5 %define cvsserver cvs://:pserver:anonymous@cmscvs.cern.ch:2401/cvs_server/repositories/CMSSW?passwd=AA_:yZZ3e
6 Source: %cvsserver&strategy=checkout&module=DBS/LibValut&nocache=true&export=DBS&tag=-r%{cvstag}&output=/dbs-libs.tar.gz
7
8 %prep
9 %setup -n DBS
10 %build
11 (make DBSHOME=%_builddir/DBS/LibValut )
12
13 %install
14 mkdir -p %{i}/bin
15 mkdir -p %{i}/lib
16 mkdir -p %{i}/etc/profile.d
17 cp -r LibValut/* %{i}/lib/
18
19 (echo "#!/bin/sh"; \
20 ) > %{i}/etc/profile.d/dependencies-setup.sh
21
22 (echo "#!/bin/tcsh"; \
23 ) > %{i}/etc/profile.d/dependencies-setup.csh
24
25 # SCRAM ToolBox toolfile
26 mkdir -p %i/etc/scram.d
27 cat << \EOF_TOOLFILE >%i/etc/scram.d/%n
28 <doc type=BuildSystem::ToolDoc version=1.0>
29 <Tool name=dbs-client version=%v>
30 <client>
31 <Environment name=DBS_LIBS_BASE default="%i"></Environment>
32 </client>
33 <Runtime name=PATH value="$DBS_LIBS_BASE/bin" type=path>
34 </Tool>
35 EOF_TOOLFILE
36
37 %post
38 %{relocateConfig}etc/profile.d/dependencies-setup.sh
39 %{relocateConfig}etc/profile.d/dependencies-setup.csh
40 %{relocateConfig}etc/scram.d/%n