ViewVC Help
View File | Revision Log | Show Annotations | Root Listing
root/cvsroot/COMP/CMSDIST/dbs-server.spec
Revision: 1.10
Committed: Wed Apr 18 23:46:01 2007 UTC (18 years ago) by ratnik
Branch: MAIN
Changes since 1.9: +2 -0 lines
Log Message:
Changes for building  externals in 64/32 mode: added gcc-wrapper .

File Contents

# User Rev Content
1 valya 1.8 ### RPM cms dbs-server pre4_v01_00_00
2 ratnik 1.10 Requires: gcc-wrapper
3 eulisse 1.1
4     %define cvstag %v
5 eulisse 1.4 Source: cvs://:pserver:anonymous@cmscvs.cern.ch:2401/cvs_server/repositories/CMSSW?passwd=AA_:yZZ3e&module=DBS/Servers/JavaServer&export=DBS&tag=-r%{cvstag}&output=/dbs-server.tar.gz
6 valya 1.9 #Requires: apache-ant mysql oracle apache-tomcat
7     Requires: apache-ant mysql oracle apache-tomcat java-jdk
8 valya 1.5 #Requires: apache-ant apache-tomcat
9 eulisse 1.1
10     %prep
11     %setup -n DBS
12     %build
13 ratnik 1.10 ## IMPORT gcc-wrapper
14 eulisse 1.4 echo "PWD=$PWD"
15     cd Servers/JavaServer
16     echo "PWD=$PWD"
17     ant --noconfig dist
18     cd ../../
19 eulisse 1.1
20     %install
21 valya 1.7 mkdir -p %{i}/Servers/JavaServer/
22     cp -r Servers/JavaServer/* %{i}/Servers/JavaServer
23 eulisse 1.1
24 valya 1.8 # copy war file
25     cp %{i}/Servers/JavaServer/DBS.war $APACHE_TOMCAT_ROOT/webapps
26    
27     mkdir -p %{i}/etc/profile.d
28     (echo "#!/bin/sh"; \
29     echo "source $ORACLE_ROOT/etc/profile.d/init.sh"; \
30     echo "source $MYSQL_ROOT/etc/profile.d/init.sh"; \
31     echo "source $APACHE_TOMCAT_ROOT/etc/profile.d/init.sh"; \
32     echo "source $APACHE_ANT_ROOT/etc/profile.d/init.sh"; \
33     echo "source $JAVA_JDK_ROOT/etc/profile.d/init.sh"; \
34     ) > %{i}/etc/profile.d/dependencies-setup.sh
35    
36     (echo "#!/bin/tcsh"; \
37     echo "source $ORACLE_ROOT/etc/profile.d/init.csh"; \
38     echo "source $MYSQL_ROOT/etc/profile.d/init.csh"; \
39     echo "source $APACHE_TOMCAT_ROOT/etc/profile.d/init.csh"; \
40     echo "source $APACHE_ANT_ROOT/etc/profile.d/init.csh"; \
41     echo "source $JAVA_JDK_ROOT/etc/profile.d/init.csh"; \
42     ) > %{i}/etc/profile.d/dependencies-setup.csh
43    
44    
45     %post
46     %{relocateConfig}etc/profile.d/dependencies-setup.sh
47     %{relocateConfig}etc/profile.d/dependencies-setup.csh
48 valya 1.9